[SRU] openldap 2.4.9 from 8.04.1.

Bug #237688 reported by Chuck Short on 2008-06-05
10
Affects Status Importance Assigned to Milestone
openldap2.3 (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned

Bug Description

Hello,

I would like to propose to udate openldap from 2.4.7 (current) to 2.4.9, the reasons for this is the following:

- Already merged openldap for intrepid.
- Been testing it for the past couple of days haven't seen a regression.
- Ran the ubuntu-qa and openldap testsuite against it.
- Fixes a number of bugs after 2.4.7 released (113 Fixed upstream bugs between 2.4.7 to 2.4.9) -
- Launchpad bugs fixed #218734, #227187
- However, still needs patches backported from HEAD.
- syncrepl not usuable in 2.4.7
- Upstream recommended us not to use 2.4.7 at UDS.

I have attached the following for your review:

- the changelog between 2.4.7 and 2.4.9
- A breakdown of the changelog grouped by syncrepl issues, crashers/hangs, and other bugs. (With the links to the upstream bug tracker)
- The openldap 2.4.9 testsuite run.
- A debdiff between intrepid's version of openldap and hardy's version.

I made the version of 2.4.9 backported in my ppa archive for testing. Users have tried it and it has fixed issues previously seen in bug reports for hardy.

If you have any questions please let me know.

Thanks
chuck

Chuck Short (zulcss) wrote :
Chuck Short (zulcss) wrote :
Chuck Short (zulcss) wrote :
Chuck Short (zulcss) wrote :
Chuck Short (zulcss) wrote :

Both testsuites ran succesfully. In the openldap2.3 test suite test035 and test036 are known to have failed in 2.4.7 are were not run in the 2.4.9 test run. However no regressions were introduced as far as the test suite was concerned.

chuck

Martin Pitt (pitti) wrote :

Just bug fixes and small documentation updates. This looks appropriate for an SRU. The only thing that is not self-explanatory is "Removed lint"; what does it mean? is it a shipped tool? If so, is anything using it in the distro? if it is shipped in hardy final, it should not suddenly disappear, people could use it for something.

Martin Pitt (pitti) wrote :

Intrepid has 2.4.9.

Changed in openldap2.3:
status: New → Fix Released
status: New → Incomplete
Chuck Short (zulcss) wrote :

Its apart of the openldap build system so users dont see it.

Martin Pitt (pitti) wrote :

OK, looks good. I rejected the current upload from the queue, please upload again with the following things fixed:
 - Mention this SRU bug in the changelog
 - Make the version number lower than the one in intrepid (-0ubuntu0.8.04, for example)
 - reformat the changelog to be interesting to users of hardy (not focus on merge, focus on changes since last hardy version)

Changed in openldap2.3:
status: Incomplete → Confirmed
Steve Langasek (vorlon) wrote :

I've just noticed by chance that openldap2.3 is not building in intrepid; the reason for this is that the merged package has picked up a build-dependency on heimdal-dev, which is in universe.

The package uploaded to hardy-proposed has the same build-dependency, and is therefore not viable as an SRU.

Rejecting from the queue; please reupload with SRU-appropriate packaging changes only.

Steve Langasek [2008-06-10 17:15 -0000]:
> I've just noticed by chance that openldap2.3 is not building in
> intrepid; the reason for this is that the merged package has picked up a
> build-dependency on heimdal-dev, which is in universe.

Please also note that I'm not keen at all to move a second kerberos
implementation to main. Doesn't it work with MIT kerberos?
(libkrb5-dev)

Steve Langasek (vorlon) wrote :

On Tue, Jun 10, 2008 at 07:16:16PM -0000, Martin Pitt wrote:
> Steve Langasek [2008-06-10 17:15 -0000]:
> > I've just noticed by chance that openldap2.3 is not building in
> > intrepid; the reason for this is that the merged package has picked up a
> > build-dependency on heimdal-dev, which is in universe.

> Please also note that I'm not keen at all to move a second kerberos
> implementation to main. Doesn't it work with MIT kerberos?
> (libkrb5-dev)

This is actually an entirely spurious build-dependency that was added to try
to support the smbk5pwd overlay, which was subsequently disabled in the
Debian package - the build-dep should just plain be dropped again.

I'll take care of that on the Debian side so that it's fixed in the next
merge, but the concern about not including superfluous packaging changes in
SRU still stands.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Martin Pitt (pitti) wrote :

The recent upload just says "Resynchronize dependencies with the hardy version.", which is not acceptable as a changelog for an SRU. Also, the version number is "2.4.9-0ubuntu0.804.2", it only needs to be "2.4.9-0ubuntu0.804.1" or even "2.4.9-0ubuntu0.804" (also, "2.4.9-0ubuntu0.8.04" is common practice). You should just do the dependency change and reupload it as 2.4.9-0ubuntu0.8.04 with a complete SRU-conformant changelog (describe the changes in 2.4.9, reference the LP # bugs, etc.).

I rejected 2.4.9-0ubuntu0.804.2 from the queue.

Martin Pitt (pitti) wrote :

The changelog is ok now, but the upload contains plenty of changes in debian/ which are not appropriate for an SRU:

- you removed the previous hardy-updates changelog, and has plenty of other changelogs from Debian
- debian/compat got bumped to 6
- still adds the build dependency heimdal-dev
- adds a Conflicts: libldap2
- a lot of added/removed patches which seem unrelated, e. g. the hurd fix
- changes the init script; conffile changes on stable updates should be avoided in general, unless absolutely necessary

In general it's best to leave the packaging as it is, and just do uupdate and adopt the patches as necessary.

Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in openldap2.3:
status: Confirmed → Fix Committed
Adam Sommer (asommer) wrote :

Version 2.4.9-0ubuntu0.8.04 in -proposed worked fine for me. Tested syncrepl, adding users, deleting user, and authenticating. All tests worked without issue.

Thanks for all your work on this.

Martin Pitt (pitti) wrote :

Thanks for testing!

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in openldap2.3:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches