apt-get install slapd => Can't locate object method "new" via package "Debconf::Element::Noninteractive::Booleam"

Bug #666028 reported by KLEIN Stéphane on 2010-10-24
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
openldap
Invalid
Undecided
Unassigned
openldap (Ubuntu)
Medium
James Page
Declined for Natty by Mathias Gug
Maverick
Medium
James Page

Bug Description

IMPACT: Due to a incorrectly specified debconf parameter introduced to fix bug 658227, some installations of slapd/openldap will fail with the error message detailed below.

FIX: Correct the typo in the slapd.templates file to specify the slapd/move_old_database parameter as boolean (instead of booleam).

PATCH: See proposed linked branch

TEST CASE:
Install slapd on a clean maverick installation
Configure and load data (using example from server guide).
Remove and purge slapd package
Re-install slapd (fails with error message detailed below).

REGRESSION POTENTIAL: Bearing in mind the heritage of this bug the following test cases should be tested once in -proposed:
Clean installation
Test Case (as detailed above)
Upgrade from Lucid->Maverick.

ORIGINAL BUG REPORT:

Hi,

when I try to install "slapd", I've this :

root@stephane-macbook:~# apt-get install slapd
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  ldap-utils
The following NEW packages will be installed:
  slapd
0 upgraded, 1 newly installed, 0 to remove and 57 not upgraded.
Need to get 0B/1514kB of archives.
After this operation, 4047kB of additional disk space will be used.
Preconfiguring packages ...
Can't locate object method "new" via package "Debconf::Element::Noninteractive::Booleam" (perhaps you forgot to load "Debconf::Element::Noninteractive::Booleam"?) at /usr/share/perl5/Debconf/FrontEnd.pm line 68, <GEN1> line 5.
(Reading database ... 480491 files and directories currently installed.)
Unpacking slapd (from .../slapd_2.4.23-0ubuntu3.2_i386.deb) ...
Can't locate object method "new" via package "Debconf::Element::Noninteractive::Booleam" (perhaps you forgot to load "Debconf::Element::Noninteractive::Booleam"?) at /usr/share/perl5/Debconf/FrontEnd.pm line 68, <GEN1> line 5.
dpkg: error processing /var/cache/apt/archives/slapd_2.4.23-0ubuntu3.2_i386.deb (--unpack):
 subprocess new pre-installation script returned error exit status 2
Errors were encountered while processing:
 /var/cache/apt/archives/slapd_2.4.23-0ubuntu3.2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@stephane-macbook:~#

I'm on Ubuntu 10.10

Related branches

trinkity (trinkity) wrote :

This error is when you install slapd -> remove slapd -> reinstall slapd.
You can around the problem installing manually
1) dpkg --install libldap-2.4-2_2.4.23-0ubuntu3_amd64.deb
2) dpkg --install slapd_2.4.23-0ubuntu3_amd64.deb
3) apt-get dist-upgrade

I confirm this problem on ubuntu 10.10 amd 64

> This error is when you install slapd -> remove slapd -> reinstall slapd.
> You can around the pro>blem installing manually
> 1) dpkg --install libldap-2.4-2_2.4.23-0ubuntu3_amd64.deb
> 2) dpkg --install slapd_2.4.23-0ubuntu3_amd64.deb
> 3) apt-get dist-upgrade
>
> I confirm this problem on ubuntu 10.10 amd 64

I've always the same error when I launch :

# dpkg --install slapd_2.4.23-0ubuntu3.2_i386.deb
(Lecture de la base de données... 503850 fichiers et répertoires déjà installés.)
Dépaquetage de slapd (à partir de slapd_2.4.23-0ubuntu3.2_i386.deb) ...
Can't locate object method "new" via package "Debconf::Element::Noninteractive::Booleam" (perhaps you forgot to load "Debconf::Element::Noninteractive::Booleam"?) at /usr/share/perl5/Debconf/FrontEnd.pm line 68, <GEN1> line 5.
dpkg : erreur de traitement de slapd_2.4.23-0ubuntu3.2_i386.deb (--install) :
 le sous-processus nouveau script pre-installation a retourné une erreur de sortie d'état 2
Des erreurs ont été rencontrées pendant l'exécution :
 slapd_2.4.23-0ubuntu3.2_i386.deb

trinkity (trinkity) wrote :

you must purge old version -> download old package slapd -> install -> dist-upgrade

Ok, this package version work with success :

* libldap-2.4-2_2.4.23-0ubuntu3_i386.deb
* slapd_2.4.23-0ubuntu3_i386.deb

but we can confirm the error with last slapd version : slapd_2.4.23-0ubuntu3.2_i386.deb

Changed in openldap (Ubuntu):
status: New → Confirmed
Michael Milligan (milli) wrote :

The error is a typo in slapd.templates, so I guess this goes upstream. Here's a quick patch. My package version is 2.4.23-0ubuntu3.2 (maverick) on AMD64. This file gets installed in /var/lib/dpkg/info/slapd.templates if you want to hand edit, dpkg-reconfigure, and move on with life...

# diff -u slapd.templates.orig slapd.templates
--- slapd.templates.orig 2010-11-05 12:01:38.977450608 -0600
+++ slapd.templates 2010-11-05 12:01:50.246765129 -0600
@@ -189,7 +189,7 @@
 Description-vi.UTF-8: Khi tẩy gói phần mềm slapd, bạn cũng có muốn gỡ bỏ cơ sở dữ liệu không?

 Template: slapd/move_old_database
-Type: booleam
+Type: boolean
 Default: true
 Description: Do you want to backup the old database when slapd is upgraded?
  If you disable this option upgrades which change the underlying BDB

James Page (james-page) wrote :

This change (and bug) was introduced in 2.4.23-0ubuntu3.2 to deal with a db format issue when upgrading from Lucid->Maverick.

As a result this will impact the version of openldap in Maverick and Natty (where this change has also been applied).

Changed in openldap (Ubuntu):
assignee: nobody → James Page (james-page)
importance: Undecided → High
status: Confirmed → In Progress
James Page (james-page) on 2010-11-08
tags: added: maverick
James Page (james-page) on 2010-11-08
description: updated
Changed in openldap (Ubuntu):
importance: High → Medium
Mathias Gug (mathiaz) on 2010-11-08
Changed in openldap (Ubuntu Maverick):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → James Page (james-page)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openldap - 2.4.23-0ubuntu4

---------------
openldap (2.4.23-0ubuntu4) natty; urgency=low

  * debian/slapd.templates: amended typo in slapd/move_old_database
    (LP: #666028)
 -- James Page <email address hidden> Mon, 08 Nov 2010 10:00:58 +0000

Changed in openldap (Ubuntu):
status: In Progress → Fix Released
PEIGNOT Kévin (kpeignot) wrote :

When will it be uploaded in maverick's repos?

Accepted openldap into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in openldap (Ubuntu Maverick):
status: Triaged → Fix Committed
tags: added: verification-needed
PEIGNOT Kévin (kpeignot) wrote :

It's OK, it works for me with the proposed version. Good works !

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openldap - 2.4.23-0ubuntu3.3

---------------
openldap (2.4.23-0ubuntu3.3) maverick-proposed; urgency=low

  * debian/slapd.templates: amended typo in slapd/move_old_database
    (LP: #666028)
 -- James Page <email address hidden> Mon, 08 Nov 2010 10:00:58 +0000

Changed in openldap (Ubuntu Maverick):
status: Fix Committed → Fix Released
James Page (james-page) on 2010-11-18
Changed in openldap:
status: New → Invalid
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers