Enable GSSAPI support (for likewise-open)

Bug #495418 reported by Thierry Carrez on 2009-12-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openldap (Ubuntu)
Wishlist
Thierry Carrez

Bug Description

Proposed patch does two things:

(a) Adds the --with-gssapi autoconf option necessary to
enable code in libraries/libldap/gssapi.c (i.e #define HAVE_GSSAPI).
This option was present in 2.4.16 from what I can tell but is not in the 2.4.18 code in
lucid.

(b) Makes guess_service_principal() more robust when trying
to determine what principal name to use (based on the hostname
or dns name) when binding to a server.

Thierry Carrez (ttx) on 2009-12-11
Changed in openldap (Ubuntu):
assignee: nobody → Thierry Carrez (ttx)
importance: Undecided → Wishlist
status: New → Triaged
Thierry Carrez (ttx) on 2009-12-11
Changed in openldap (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openldap - 2.4.18-0ubuntu2

---------------
openldap (2.4.18-0ubuntu2) lucid; urgency=low

  * debian/patches/gssapi.diff, thanks to Jerry Carter (Likewise):
    - Add --with-gssapi support
    - Make guess_service_principal() more robust when determining principal
  * Enable GSSAPI support (LP: #495418):
    - debian/configure.options: Configure with --with-gssapi
    - debian/control: Added libkrb5-dev as a build depend
 -- Thierry Carrez <email address hidden> Fri, 11 Dec 2009 11:31:11 +0100

Changed in openldap (Ubuntu):
status: In Progress → Fix Released
Quanah Gibson-Mount (mishikal) wrote :

This should be backed out. Use cyrus-sasl for SASL/GSSAPI binds with OpenLDAP. It would be nice if folks would actually clear stuff with upstream instead of cluelessly hacking on the OpenLDAP source. There have been enough issues caused by this already with the debian and ubuntu folks over the years. At least the Debian developers finally got things cleaned up and work with upstream now. It'd be nice to see ubuntu do the same.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers