package slapd 2.4.11-0ubuntu6.1 failed to install/upgrade:

Bug #366691 reported by Dan Stover on 2009-04-25
2
Affects Status Importance Assigned to Milestone
openldap (Ubuntu)
Low
Unassigned

Bug Description

While upgrading from 8.10 to 9.04 I received an error dialog with the following header and content:

Could not install /var/cache/apt/archives/slapd_2.4.15-1ubuntu3_i386.deb

The upgrade will continue but the '/var/cache/apt/archives/slapd_2.4.15-1ubuntu3_i386.deb' package may be in a not working state. Please consider submitting a bug report about it.

subprocess pre-installation script returned error exit status 1

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 9.04
ErrorMessage:
 ErrorMessage: subprocess pre-installation script returned error exit status 1
Package: slapd 2.4.11-0ubuntu6.1
SourcePackage: openldap
Title: package slapd 2.4.11-0ubuntu6.1 failed to install/upgrade:
Uname: Linux 2.6.27-11-generic i686

Dan Stover (dan-stover) wrote :
affects: ubuntu → openldap (Ubuntu)
Mathias Gug (mathiaz) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add the log files from '/var/log/dist-upgrade/' to this bug report as separate attachments? Thanks in advance.

Changed in openldap (Ubuntu):
status: New → Incomplete
Dan Stover (dan-stover) wrote :
Dan Stover (dan-stover) wrote :
Dan Stover (dan-stover) wrote :
Dan Stover (dan-stover) wrote :
Dan Stover (dan-stover) wrote :
Dan Stover (dan-stover) wrote :

Added attachments as requested (apt.log, apt-term.log, main.log, term.log, xorg_fix_intrepid.log). In /var/log/dist-upgrade/ there is also a subdirectory (../20090424-2130). This subdirectory contains older versions of apt.log (2009-02-15) and apt-term.log (2009-01-31). Please advise if those logs are also desired.

Although I don't see it, I thought I had updated this issue to indicate that I was able to resolve this by uninstalling a partially-completed installation of openldap.

Mathias Gug (mathiaz) wrote :

Relevant error message:

Preparing to replace slapd 2.4.11-0ubuntu6.1 (using .../slapd_2.4.15-1ubuntu3_i386.deb) ...
Stopping OpenLDAP: slapd.
  Dumping to /var/backups/slapd-2.4.11-0ubuntu6.1:
  - directory dc=kowboy,dc=com... /etc/ldap/slapd.conf: line 126: <suffix> Only one suffix is allowed on this hdb backend
slapcat: bad configuration file!
failed.
dpkg: error processing /var/cache/apt/archives/slapd_2.4.15-1ubuntu3_i386.deb (--unpack):
 subprocess pre-installation script returned error exit status 1
  Backing up /etc/ldap/slapd.conf in /var/backups/slapd-2.4.15-1ubuntu3... done.
chown: cannot access `/var/lib/ldap\n/var/lib/ldap': No such file or directory
dpkg: error while cleaning up:
 subprocess post-installation script returned error exit status 1

Was slapd configured properly and running before the upgrade?

Changed in openldap (Ubuntu):
importance: Undecided → Low
Chuck Short (zulcss) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Dan Stover (dan-stover) wrote :

I tried reporting several times (obviously unsuccessfully) that this problem was caused by an incomplete attempt to set up OpenLDAP. The problem has been corrected. Most recent upgrade from 9.04 to 9.10 was successful with no errors. Thanks.

Changed in openldap (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers