slapd fails to upgrade when the configuration uses evolutionperson.schema

Bug #225919 reported by David McKelvie on 2008-05-02
10
Affects Status Importance Assigned to Milestone
openldap (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: update-manager

Sorry, the package update-manager failed to install or upgrade
During upgrade from 7.10 to 8.04

Possibly due to an error I introduced trying to clean up space in /boot

update-initramfs: Generating /boot/initrd.img-2.6.24-16-386
The link /initrd.img is a dangling linkto /boot/initrd.img-2.6.22-14-generic
The link /vmlinuz is a dangling linkto /boot/vmlinuz-2.6.22-14-generic

ProblemType: Package
Architecture: i386
Date: Fri May 2 22:08:06 2008
DistroRelease: Ubuntu 8.04
ErrorMessage: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg returned an error code (1), E:Sub-process /usr/bin/dpkg returned an error code (1)

NonfreeKernelModules: nvidia hcfpciengine
Package: update-manager 1:0.87.24
PackageArchitecture: all
SourcePackage: update-manager
Title: package update-manager 1:0.87.24 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg returned an error code (1), E:Sub-process /usr/bin/dpkg returned an error code (1)
Uname: Linux 2.6.22-14-386 i686

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Please attach the files in /var/log/dist-upgrade to this bugreport.
 Thanks Michael

Changed in update-manager:
status: New → Incomplete

Michael Vogt <email address hidden> asked
>> Please attach the files in /var/log/dist-upgrade to this bugreport.

Ralph Janke (txwikinger) on 2008-06-10
Changed in update-manager:
importance: Undecided → Medium
status: Incomplete → Triaged
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your time.

The cause of the failure is:
=====
Preparing to replace slapd 2.3.35-1ubuntu0.2 (using .../slapd_2.4.7-6ubuntu3_i386.deb) ...
Stopping OpenLDAP: slapd.
  Dumping to /var/backups/slapd-2.3.35-1ubuntu0.2:
_1%3a2.4.0-3ubuntu6_all.deb) ...
/var/lib/dpkg/tmp.ci/preinst: 1153: cannot open /usr/share/evolution-data-server-1.12/evolutionperson.schema: No such file
  - directory dc=nodomain...
  - directory dc=nodomain... slapcat: database doesn't support necessary operations.
failed.
dpkg: error processing /var/cache/apt/archives/slapd_2.4.7-6ubuntu3_i386.deb (--unpack):
 subprocess pre-installation script returned error exit status 1
=====

Affecting to openldap

pit_hoessler (pit-hoessler) wrote :

Excuse me, may be it is my fault, not assigned a domain-name at the moment.
What I am doing and what I see is:
------------
pit@platsch:~/temp$ sudo apt-get install slapd ldap-utils
[sudo] password for pit:
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Lese Status-Informationen ein... Fertig
Die folgenden NEUEN Pakete werden installiert:
  ldap-utils slapd
0 aktualisiert, 2 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen noch 0B von 1733kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 4588kB Plattenplatz zusätzlich benutzt.
Vorkonfiguration der Pakete ...
Wähle vormals abgewähltes Paket slapd.
(Lese Datenbank ... 124519 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacke slapd (aus .../slapd_2.4.11-0ubuntu6.1_i386.deb) ...
Wähle vormals abgewähltes Paket ldap-utils.
Entpacke ldap-utils (aus .../ldap-utils_2.4.11-0ubuntu6.1_i386.deb) ...
Verarbeite Trigger für man-db ...
Richte slapd ein (2.4.11-0ubuntu6.1) ...
  Moving old database directory to /var/backups:
  - directory unknown... done.
  Creating initial slapd configuration... done.
  Creating initial LDAP directory... failed.

Loading the initial directory structure from the ldif file (/tmp/slapd_init_dir.ldif.LyoAz10032) failed with the following
error while running slapadd:
    slapadd: slap_init invalid suffix ("dc=nodomain")
dpkg: Fehler beim Bearbeiten von slapd (--configure):
 Unterprozess post-installation script gab den Fehlerwert 1 zurück
Richte ldap-utils ein (2.4.11-0ubuntu6.1) ...
Fehler traten auf beim Bearbeiten von:
 slapd
E: Sub-process /usr/bin/dpkg returned an error code (1)
pit@platsch:~/temp$
---------------
Thank you, pit

Mathias Gug (mathiaz) wrote :

@pit_hoessler:
Thanks for taking the time to report this bug and comment on it. However your report is a different issue. Would you please open a new bug report for it?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers