Please merge openldap 2.4.41+dfsg-1 (main) from Debian unstable (main)

Bug #1471831 reported by Kartik Subbarao on 2015-07-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openldap (Ubuntu)
Undecided
Ryan Tandy

Bug Description

OpenLDAP version 2.4.41 is now available, and includes the bugfix for the issue I reported in bug #1461276, as well as many other bugfixes. Requesting an Ubuntu package for this release.

tags: added: upgrade-software-version
Ryan Tandy (rtandy) on 2015-07-09
Changed in openldap (Ubuntu):
assignee: nobody → Ryan Tandy (rtandy)
status: New → Confirmed
Ryan Tandy (rtandy) on 2015-07-24
Changed in openldap (Ubuntu):
status: Confirmed → In Progress

Hi sponsors,

Please review the attached merge of openldap from Debian unstable.

Thanks in advance.

summary: - Requesting a package for 2.4.41
+ Please merge openldap 2.4.41+dfsg-1 (main) from Debian unstable (main)
Chris J Arges (arges) wrote :

Looks good. Sponsored for Wily.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openldap - 2.4.41+dfsg-1ubuntu1

---------------
openldap (2.4.41+dfsg-1ubuntu1) wily; urgency=medium

  * Merge from Debian testing (LP: #1471831). Remaining changes:
    - Enable AppArmor support:
      - d/apparmor-profile: add AppArmor profile
      - d/rules: use dh_apparmor
      - d/control: Build-Depends on dh-apparmor
      - d/slapd.README.Debian: add note about AppArmor
    - Enable GSSAPI support:
      - d/patches/gssapi.diff, thanks to Jerry Carter (Likewise):
        - Add --with-gssapi support
        - Make guess_service_principal() more robust when determining
          principal
      - d/configure.options: Configure with --with-gssapi
      - d/control: Added heimdal-dev as a build depend
    - Enable ufw support:
      - d/control: suggest ufw.
      - d/rules: install ufw profile.
      - d/slapd.ufw.profile: add ufw profile.
    - Enable nss overlay:
      - d/{patches/nssov-build,rules}: Apply, build and package the
        nss overlay.
    - d/{rules,slapd.py}: Add apport hook.
    - d/slapd.init.ldif: don't set olcRootDN since it's not defined in
      either the default DIT nor via an Authn mapping.
    - d/slapd.scripts-common:
      - add slapcat_opts to local variables.
      - Remove unused variable new_conf.
      - Fix backup directory naming for multiple reconfiguration.
    - d/{slapd.default,slapd.README.Debian}: use the new configuration style.
    - d/rules: Enable -DLDAP_CONNECTIONLESS to build CLDAP (UDP) support
      in the openldap library, as required by Likewise-Open
    - Show distribution in version:
      - d/control: added lsb-release
      - d/patches/fix-ldap-distribution.patch: show distribution in version
  * Dropped changes:
    - Fix cpp calls for GCC 5: fixed upstream (ITS#8056)
  * Upstream fixes:
    - slapd crash with auditlog overlay and large (~27KB) attribute values
      (ITS#8003) (LP: #1461276)
    - nssov updated to support recent nss-pam-ldapd client libraries
      (ITS#8097) (LP: #1393306)
  * Update d/patches/nssov-build for upstream changes.
  * Tweak d/patches/gssapi.diff to apply without fuzz.
  * d/libldap-2.4-2.symbols: Add symbols not present in Debian.
    - CLDAP (UDP) was added in 2.4.17-1ubuntu2
    - GSSAPI support was enabled in 2.4.18-0ubuntu2

 -- Ryan Tandy <email address hidden> Fri, 24 Jul 2015 14:12:06 -0700

Changed in openldap (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers