package libldap-2.4-2 2.4.31-1+nmu2ubuntu8 failed to install/upgrade: trying to overwrite shared '/etc/ldap/ldap.conf', which is different from other instances of package libldap-2.4-2:amd64

Bug #1436558 reported by Klaus Schäfer on 2015-03-25
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
openldap (Debian)
Fix Released
Unknown
openldap (Ubuntu)
Medium
Unassigned

Bug Description

package libldap-2.4-2 2.4.31-1+nmu2ubuntu8 failed to install/upgrade: Versuch, gemeinsam benutztes »/etc/ldap/ldap.conf« zu überschreiben, welches verschieden von anderen Instanzen des Paketes libldap-2.4-2:amd64 ist

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: libldap-2.4-2 2.4.31-1+nmu2ubuntu8
ProcVersionSignature: Ubuntu 3.13.0-39.66-generic 3.13.11.8
Uname: Linux 3.13.0-39-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3.8
Architecture: amd64
Date: Wed Mar 25 16:48:52 2015
DuplicateSignature: package:libldap-2.4-2:2.4.31-1+nmu2ubuntu8:Versuch, gemeinsam benutztes »/etc/ldap/ldap.conf« zu überschreiben, welches verschieden von anderen Instanzen des Paketes libldap-2.4-2:amd64 ist
ErrorMessage: Versuch, gemeinsam benutztes »/etc/ldap/ldap.conf« zu überschreiben, welches verschieden von anderen Instanzen des Paketes libldap-2.4-2:amd64 ist
InstallationDate: Installed on 2014-11-23 (122 days ago)
InstallationMedia: Xubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140723)
SourcePackage: openldap
Title: package libldap-2.4-2 2.4.31-1+nmu2ubuntu8 failed to install/upgrade: Versuch, gemeinsam benutztes »/etc/ldap/ldap.conf« zu überschreiben, welches verschieden von anderen Instanzen des Paketes libldap-2.4-2:amd64 ist
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.ldap.ldap.conf: [deleted]

Klaus Schäfer (klausx-c) wrote :
tags: removed: need-duplicate-check
Ryan Tandy (rtandy) wrote :

Thanks for the report. I guess this is caused by https://bugs.debian.org/330695 which is not fixed yet. :/

Easy to reproduce by installing libldap-2.4-2:amd64, removing (but not purging) it, and then trying to install :i386.

Klaus: in this case a workaround is probably to purge the old packages (apt-get purge libldap-2.4-2:amd64 libldap-2.4-2:i386) before trying to install them again.

Changed in openldap (Ubuntu):
status: New → Confirmed
summary: package libldap-2.4-2 2.4.31-1+nmu2ubuntu8 failed to install/upgrade:
- Versuch, gemeinsam benutztes »/etc/ldap/ldap.conf« zu überschreiben,
- welches verschieden von anderen Instanzen des Paketes
- libldap-2.4-2:amd64 ist
+ trying to overwrite shared '/etc/ldap/ldap.conf', which is different
+ from other instances of package libldap-2.4-2:amd64
Changed in openldap (Debian):
status: Unknown → Confirmed
Darxus (darxus) wrote :

I'm not certain I had the same problem, but the workaround I used was:

dpkg --force-depends -r purge libldap-2.4-2:amd64 libldap-2.4-2:i386
apt-get -f install

Because apt-get purge refuses due to dependencies.

Robie Basak (racb) on 2015-11-06
Changed in openldap (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Changed in openldap (Debian):
status: Confirmed → Fix Committed
Changed in openldap (Debian):
status: Fix Committed → Fix Released
Nish Aravamudan (nacc) wrote :

If we were to merge to the latest release in Debian (2.4.44+dfsg-2), zesty will get the Debian fix for this issue. We could then consider backporting the fix from Helmut Grohne.

Ryan Tandy (rtandy) wrote :

This should be fixed in zesty now.

openldap (2.4.44+dfsg-3ubuntu1) zesty; urgency=medium

  * Merge with Debian unstable (LP: #1663702, LP: #1654416).

openldap (2.4.44+dfsg-1) unstable; urgency=medium

  * Fix policy 8.2 violation (Closes: #330695)
    + Move /etc/ldap/ldap.conf and manpage to new package libldap-common.

Changed in openldap (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.