java crashed with SIGABRT in JNU_GetEnv()

Bug #1551532 reported by Jane Manchun Wong on 2016-03-01
98
This bug affects 18 people
Affects Status Importance Assigned to Milestone
openjdk-9 (Ubuntu)
Medium
Unassigned

Bug Description

I tried to open a JAR file with "java -jar Minecraft.jar" and it crashed.

ProblemType: Crash
DistroRelease: Ubuntu 16.04
Package: openjdk-9-jre-headless 9~b102-1
ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
Uname: Linux 4.4.0-8-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Feb 29 22:50:03 2016
ExecutablePath: /usr/lib/jvm/java-9-openjdk-amd64/bin/java
InstallationDate: Installed on 2016-03-01 (0 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160228)
ProcCmdline: java -jar Minecraft.jar
Signal: 6
SourcePackage: openjdk-9
StacktraceTop:
 JNU_GetEnv () from /usr/lib/jvm/java-9-openjdk-amd64/lib/amd64/libjava.so
 ?? () from /usr/lib/jvm/java-9-openjdk-amd64/lib/amd64/libfontmanager.so
 FT_Stream_Seek () from /usr/lib/x86_64-linux-gnu/libfreetype.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libfreetype.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libfreetype.so.6
Title: java crashed with SIGABRT in JNU_GetEnv()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Jane Manchun Wong (wongmjane) wrote :

StacktraceTop:
 JNU_GetEnv () from /tmp/apport_sandbox_i6JWnF/usr/lib/jvm/java-9-openjdk-amd64/lib/amd64/libjava.so
 ReadTTFontFileFunc () from /tmp/apport_sandbox_i6JWnF/usr/lib/jvm/java-9-openjdk-amd64/lib/amd64/libfontmanager.so
 FT_Stream_Seek (stream=stream@entry=0x7fb62033f6e0, pos=pos@entry=0) at /build/freetype-QxOIWz/freetype-2.6.1/freetype-2.6.1/src/base/ftstream.c:65
 tt_face_init (stream=0x7fb62033f6e0, ttface=0x7fb620a4d660, face_index=0, num_params=0, params=0x0) at /build/freetype-QxOIWz/freetype-2.6.1/freetype-2.6.1/src/truetype/ttobjs.c:534
 open_face (driver=driver@entry=0x7fb620a4cc60, astream=astream@entry=0x7fb628c03ef8, external_stream=external_stream@entry=1 '\001', face_index=face_index@entry=0, num_params=0, params=0x0, aface=0x7fb628c03f00) at /build/freetype-QxOIWz/freetype-2.6.1/freetype-2.6.1/src/base/ftobjs.c:1166

Changed in openjdk-9 (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openjdk-9 (Ubuntu):
status: New → Confirmed
Matthias Klose (doko) on 2016-04-21
information type: Private → Public

To solve that, I used 'sudo dpkg --remove --force-all openjdk-9-*'. But, on the place of *, you put the rest of the name package. Example:
sudo dpkg --remove --force-all openjdk-9-jre-headless

OR DO THIS, and MAYBE work

sudo dpkg --remove --force-all openjdk-9-jre-headless
sudo dpkg --remove --force-all openjdk-9-demo
sudo dpkg --remove --force-all openjdk-9-dbg
sudo dpkg --remove --force-all openjdk-9-doc
sudo dpkg --remove --force-all openjdk-9-jre
sudo dpkg --remove --force-all openjdk-9-jdk
sudo dpkg --remove --force-all openjdk-9-jdk-headless
sudo dpkg --remove --force-all openjdk-9-source

Then:
sudo apt-get install openjdk-8-*

G.M. (sexxxenator) wrote :

Same problem here, runnind java -jar weka.jar (http://www.cs.waikato.ac.nz/ml/weka/ v3.8):
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007f01d701d009, pid=15317, tid=15438
#
# JRE version: OpenJDK Runtime Environment (9.0) (build 9-internal+0-2016-04-14-195246.buildd.src)
# Java VM: OpenJDK 64-Bit Server VM (9-internal+0-2016-04-14-195246.buildd.src, mixed mode, tiered, compressed oops, g1 gc, linux-amd64)
# Problematic frame:
# C [libjava.so+0x1d009] JNU_GetEnv+0x19
#
# Core dump will be written. Default location: Core dumps may be processed with "/usr/share/apport/apport %p %s %c %P" (or dumping to /home/gmuller/Downloads/core.15317)
#
# An error report file with more information is saved as:
# /home/gmuller/Downloads/hs_err_pid15317.log
#
# If you would like to submit a bug report, please visit:
# http://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Aborted (core dumped)

CaptainPlanet (captainplanet) wrote :

Hi,
this problem occurs to me to other java programs as well for example Jitsi, jdownloader or i2p. I just wanted to make clear this is not solely a minecraft error.

D-ubuntuone-a (d-ubuntuone-a) wrote :

For geogebra (the application which brought me here) I found a simple solution on xenial:

$ sudo apt-get install openjdk-8-jdk
$ JAVACMD=/usr/lib/jvm/java-8-openjdk-amd64/bin/java geogebra

Works for me.

Darren Conway (darren-conway) wrote :

I got this fatal error trying to run Netbeans. Haven't tried running other Java programs yet
Installed using the command:
sudo apt-get -o Dpkg::Options::="--force-overwrite" install openjdk-9-jdk
Got the crash everytime I ran Netbeans.

Tried running:
apt-get update
apt-get install openjdk-9-jdk
apt-get autoremove

Netbeans flashed the startup image for a fraction of a second, then nothing. No crash, no Netbeans.

Adam Jurčík (adam86) wrote :

Hi,
also affects IzPack. Moreover, I guess it also affects most of the Java Swing GUI programs.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers