package openjdk-9-jdk 9~b102-1 failed to install/upgrade: trying to overwrite '/usr/lib/jvm/java-9-openjdk-amd64/include/linux/jawt_md.h', which is also in package openjdk-9-jdk-headless:amd64 9~b107-0ubuntu1

Bug #1550950 reported by Joni Graf
This bug affects 577 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
openjdk-9 (Ubuntu)
Medium
DangQuang
Xenial
Medium
Bhosad Chod

Bug Description

Ubuntu Xenial Xerus (development branch)

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: openjdk-9-jdk 9~b102-1
ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
Uname: Linux 4.4.0-8-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
Date: Sun Feb 28 16:44:30 2016
ErrorMessage: trying to overwrite '/usr/lib/jvm/java-9-openjdk-amd64/include/linux/jawt_md.h', which is also in package openjdk-9-jdk-headless:amd64 9~b107-0ubuntu1
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1
 apt 1.2.3
SourcePackage: openjdk-9
Title: package openjdk-9-jdk 9~b102-1 failed to install/upgrade: trying to overwrite '/usr/lib/jvm/java-9-openjdk-amd64/include/linux/jawt_md.h', which is also in package openjdk-9-jdk-headless:amd64 9~b107-0ubuntu1
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Joni Graf (joni-z) wrote :
Changed in openjdk-9 (Ubuntu):
status: New → Confirmed
Changed in openjdk-9 (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openjdk-9 - 9~b115-1ubuntu3

---------------
openjdk-9 (9~b115-1ubuntu3) yakkety; urgency=medium

  * Backport 8132051, 8146518, 8150654, 8154210 from the hs repo.
  * Apply proposed patch for 8153275.
  * Set initial VMThreadStackSize to 1600 on s390x.

 -- Matthias Klose <email address hidden> Fri, 22 Apr 2016 22:09:04 +0200

Changed in openjdk-9 (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
賴家亨 (laichiaheng) wrote :

I still can't install it!!

Revision history for this message
Sergi Granell (xerpi) wrote :

Yeah, still not on the Xenial Xerus repositories...

Revision history for this message
William Geiger (whgiii-q) wrote :

just tried on xenial using b114 and did not work. I'll try with the yakkety b115 and see how it goes.

Revision history for this message
William Geiger (whgiii-q) wrote :

I just tried installing b115-2 on a machine that I have done a partial upgrade to yakkety.

On this machine I originally did a fresh xenial alpha install and have been doing daily upgrades (and other tinkering) ever since. Last night or the night before I added yakkety depositories to my sources.list and the machine did a partial upgrade and a few upgrades since then.

The machine reports it's 16.10 but I really don't know what state it is in right now and unsure on how to get what I need to do a clean Yakkety install for testing (I couldn't find any yakkety.iso and the dailies just show xenial).

hope this helps.

Revision history for this message
William Geiger (whgiii-q) wrote :

Anyone looking for a manual "fix" I went and installed the jdk-headerless which works fine. The I downloaded the jdk .deb file and installed using dpkg with the --force all option. It seem to take care of the install problem. I am not a big java user but if anyone needs me to check it out further drop me a note.

hope this helps,

Revision history for this message
Stéphane Brunner (stephane-brunner) wrote :

This should be backported in xenial...

Revision history for this message
Ahmad Haghighi (haghighi-ahmad) wrote :

Fix not included in xenial repositories :|

Revision history for this message
Byte Commander (bytecommander) wrote :

For Ubuntu Xenial (and probably all other releases receiving the same malformed package), I have provided a workaround how to force installing the package and let it overwrite the doubled file here at Ask Ubuntu: http://askubuntu.com/a/769484/367990

Changed in hundredpapercuts:
status: New → Confirmed
Changed in openjdk-9 (Ubuntu Xenial):
status: New → Confirmed
Revision history for this message
Matthias Klose (doko) wrote :

looks like this became a very nice honey pot. those who really want to install this package can work around it, anybody else shouldn't install it. It's still a pre-release, and unfortunately the upstream release date was moved to Feb 2017.

satyender (bluejteacher)
Changed in openjdk-9 (Ubuntu):
assignee: nobody → satyender (bluejteacher)
Changed in openjdk-9 (Ubuntu Xenial):
importance: Undecided → Medium
Changed in hundredpapercuts:
importance: Undecided → Medium
Antonio Cezar (ntncezar)
Changed in openjdk-9 (Ubuntu Xenial):
status: Confirmed → Incomplete
status: Incomplete → Confirmed
Revision history for this message
Dereck Wonnacott (dereck) wrote :

I had to install via:

sudo apt-get -o Dpkg::Options::="--force-overwrite" install openjdk-9-jdk

tags: added: bugpattern-written
Revision history for this message
guchuanhang (guchuanhang) wrote :

Just now I install openjdk-9-jre-headless .

Revision history for this message
abazuos@gmail.com (abazuos) wrote : Re: [Bug 1550950] Re: package openjdk-9-jdk 9~b102-1 failed to install/upgrade: trying to overwrite '/usr/lib/jvm/java-9-openjdk-amd64/include/linux/jawt_md.h', which is also in package openjdk-9-jdk-headless:amd64 9~b107-0ubuntu1

sorry .. On any application you talking about?

On 28 October 2016 at 04:01, guchuanhang <email address hidden> wrote:

> Just now I install openjdk-9-jre-headless .
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1550950
>
> Title:
> package openjdk-9-jdk 9~b102-1 failed to install/upgrade: trying to
> overwrite '/usr/lib/jvm/java-9-openjdk-amd64/include/linux/jawt_md.h',
> which is also in package openjdk-9-jdk-headless:amd64 9~b107-0ubuntu1
>
> Status in One Hundred Papercuts:
> Confirmed
> Status in openjdk-9 package in Ubuntu:
> Fix Released
> Status in openjdk-9 source package in Xenial:
> Confirmed
>
> Bug description:
> Ubuntu Xenial Xerus (development branch)
>
> ProblemType: Package
> DistroRelease: Ubuntu 16.04
> Package: openjdk-9-jdk 9~b102-1
> ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
> Uname: Linux 4.4.0-8-generic x86_64
> ApportVersion: 2.20-0ubuntu3
> Architecture: amd64
> Date: Sun Feb 28 16:44:30 2016
> ErrorMessage: trying to overwrite '/usr/lib/jvm/java-9-openjdk-
> amd64/include/linux/jawt_md.h', which is also in package
> openjdk-9-jdk-headless:amd64 9~b107-0ubuntu1
> RelatedPackageVersions:
> dpkg 1.18.4ubuntu1
> apt 1.2.3
> SourcePackage: openjdk-9
> Title: package openjdk-9-jdk 9~b102-1 failed to install/upgrade: trying
> to overwrite '/usr/lib/jvm/java-9-openjdk-amd64/include/linux/jawt_md.h',
> which is also in package openjdk-9-jdk-headless:amd64 9~b107-0ubuntu1
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hundredpapercuts/+bug/1550950/+subscriptions
>

Revision history for this message
Martin Marčan (martin-marcan) wrote :

I am sorry, cannot remember what I've tried to install; probably the
package itself; I'm already using yakkety.

Possibly the Aircontrol (aircontrol2-2.0-Beta18.1416.151204.1451-ubuntu.deb)

But I'm sure I use x86 architecture; could be clue.

M.

Dne 28.10.2016 v 11:21 <email address hidden> napsal(a):
> sorry .. On any application you talking about?
>
> On 28 October 2016 at 04:01, guchuanhang <email address hidden>
> wrote:
>
>> Just now I install openjdk-9-jre-headless .
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1550950
>>
>> Title:
>> package openjdk-9-jdk 9~b102-1 failed to install/upgrade: trying to
>> overwrite '/usr/lib/jvm/java-9-openjdk-amd64/include/linux/jawt_md.h',
>> which is also in package openjdk-9-jdk-headless:amd64 9~b107-0ubuntu1
>>
>> Status in One Hundred Papercuts:
>> Confirmed
>> Status in openjdk-9 package in Ubuntu:
>> Fix Released
>> Status in openjdk-9 source package in Xenial:
>> Confirmed
>>
>> Bug description:
>> Ubuntu Xenial Xerus (development branch)
>>
>> ProblemType: Package
>> DistroRelease: Ubuntu 16.04
>> Package: openjdk-9-jdk 9~b102-1
>> ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
>> Uname: Linux 4.4.0-8-generic x86_64
>> ApportVersion: 2.20-0ubuntu3
>> Architecture: amd64
>> Date: Sun Feb 28 16:44:30 2016
>> ErrorMessage: trying to overwrite '/usr/lib/jvm/java-9-openjdk-
>> amd64/include/linux/jawt_md.h', which is also in package
>> openjdk-9-jdk-headless:amd64 9~b107-0ubuntu1
>> RelatedPackageVersions:
>> dpkg 1.18.4ubuntu1
>> apt 1.2.3
>> SourcePackage: openjdk-9
>> Title: package openjdk-9-jdk 9~b102-1 failed to install/upgrade: trying
>> to overwrite '/usr/lib/jvm/java-9-openjdk-amd64/include/linux/jawt_md.h',
>> which is also in package openjdk-9-jdk-headless:amd64 9~b107-0ubuntu1
>> UpgradeStatus: No upgrade log present (probably fresh install)
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/hundredpapercuts/+bug/1550950/+subscriptions
>>

Revision history for this message
L@u (laurent-roche) wrote :

This still affects a fresh Xubuntu install.
To install Javan, I had to run:
sudo apt-get -o Dpkg::Options::="--force-overwrite" install openjdk-9-jdk
(thanks Dereck)

information type: Public → Public Security
information type: Public Security → Public
Revision history for this message
Cory Albrecht (bytor) wrote :

I see that this was assigned to somebody back in May, but the packaging bug still exists.

Revision history for this message
Devansh (devanshrtrivedi) wrote :

what?

On Friday 28 October 2016 02:51 PM, <email address hidden> wrote:
> sorry .. On any application you talking about?
>
> On 28 October 2016 at 04:01, guchuanhang <email address hidden>
> wrote:
>
>> Just now I install openjdk-9-jre-headless .
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1550950
>>
>> Title:
>> package openjdk-9-jdk 9~b102-1 failed to install/upgrade: trying to
>> overwrite '/usr/lib/jvm/java-9-openjdk-amd64/include/linux/jawt_md.h',
>> which is also in package openjdk-9-jdk-headless:amd64 9~b107-0ubuntu1
>>
>> Status in One Hundred Papercuts:
>> Confirmed
>> Status in openjdk-9 package in Ubuntu:
>> Fix Released
>> Status in openjdk-9 source package in Xenial:
>> Confirmed
>>
>> Bug description:
>> Ubuntu Xenial Xerus (development branch)
>>
>> ProblemType: Package
>> DistroRelease: Ubuntu 16.04
>> Package: openjdk-9-jdk 9~b102-1
>> ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
>> Uname: Linux 4.4.0-8-generic x86_64
>> ApportVersion: 2.20-0ubuntu3
>> Architecture: amd64
>> Date: Sun Feb 28 16:44:30 2016
>> ErrorMessage: trying to overwrite '/usr/lib/jvm/java-9-openjdk-
>> amd64/include/linux/jawt_md.h', which is also in package
>> openjdk-9-jdk-headless:amd64 9~b107-0ubuntu1
>> RelatedPackageVersions:
>> dpkg 1.18.4ubuntu1
>> apt 1.2.3
>> SourcePackage: openjdk-9
>> Title: package openjdk-9-jdk 9~b102-1 failed to install/upgrade: trying
>> to overwrite '/usr/lib/jvm/java-9-openjdk-amd64/include/linux/jawt_md.h',
>> which is also in package openjdk-9-jdk-headless:amd64 9~b107-0ubuntu1
>> UpgradeStatus: No upgrade log present (probably fresh install)
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/hundredpapercuts/+bug/1550950/+subscriptions
>>

Revision history for this message
Hilal H Muhammed (hilalhmuhammed) wrote :

Still facing the issue from xenial repos, could some one re open the issue

Revision history for this message
Hans Joachim Desserud (hjd) wrote :

>Still facing the issue from xenial repos, could some one re open the issue

The bug report in general was marked as fixed released since the issue is resolved in Ubuntu 16.10 and later (ref comment #3). However there is still an open task to also fix it in 16.04 (Xenial), see under Affects between the title and description.

Revision history for this message
mr (enderman) wrote :

i am trying to download java for minecraft and it fails to load the whole entire code because of an error/bug. please give me a solution.

Changed in hundredpapercuts:
status: Confirmed → New
Revision history for this message
Ilya (xahon) wrote :

I have same problem too

Revision history for this message
Ilya (xahon) wrote :

This issue solves by this answer https://askubuntu.com/a/772485/502795

Revision history for this message
suhail (8125527706ms) wrote :

thank you

On Jul 9, 2017 5:05 PM, "Ilya" <email address hidden> wrote:

> This issue solves by this answer https://askubuntu.com/a/772485/502795
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1550950
>
> Title:
> package openjdk-9-jdk 9~b102-1 failed to install/upgrade: trying to
> overwrite '/usr/lib/jvm/java-9-openjdk-amd64/include/linux/jawt_md.h',
> which is also in package openjdk-9-jdk-headless:amd64 9~b107-0ubuntu1
>
> Status in One Hundred Papercuts:
> New
> Status in openjdk-9 package in Ubuntu:
> Fix Released
> Status in openjdk-9 source package in Xenial:
> Confirmed
>
> Bug description:
> Ubuntu Xenial Xerus (development branch)
>
> ProblemType: Package
> DistroRelease: Ubuntu 16.04
> Package: openjdk-9-jdk 9~b102-1
> ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
> Uname: Linux 4.4.0-8-generic x86_64
> ApportVersion: 2.20-0ubuntu3
> Architecture: amd64
> Date: Sun Feb 28 16:44:30 2016
> ErrorMessage: trying to overwrite '/usr/lib/jvm/java-9-openjdk-
> amd64/include/linux/jawt_md.h', which is also in package
> openjdk-9-jdk-headless:amd64 9~b107-0ubuntu1
> RelatedPackageVersions:
> dpkg 1.18.4ubuntu1
> apt 1.2.3
> SourcePackage: openjdk-9
> Title: package openjdk-9-jdk 9~b102-1 failed to install/upgrade: trying
> to overwrite '/usr/lib/jvm/java-9-openjdk-amd64/include/linux/jawt_md.h',
> which is also in package openjdk-9-jdk-headless:amd64 9~b107-0ubuntu1
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hundredpapercuts/+bug/1550950/+subscriptions
>

Revision history for this message
Smruti Ranjan Sahoo (c99-smruti) wrote :

I wasn't able to install openjdk-9

Revision history for this message
Demon (demonrx) wrote :

My successful installation for openjdk on Ubuntu 16.04.3 LTS is set up with these installed packages:

ii openjdk-9-jdk-headless:amd64 9~b114-0ubuntu1 amd64 OpenJDK Development Kit (JDK) (headless)

ii openjdk-9-jre:amd64 9~b114-0ubuntu1 amd64 OpenJDK Java runtime, using Hotspot JIT

ii openjdk-9-jre-headless:amd64 9~b114-0ubuntu1 amd64 OpenJDK Java runtime, using Hotspot JIT (headless)

Revision history for this message
Nuriddin (nur.94) wrote :

Unpacking openjdk-9-jdk:amd64 (9~b114-0ubuntu1) ...
dpkg: error processing archive /var/cache/apt/archives/openjdk-9-jdk_9~b114-0ubuntu1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/jvm/java-9-openjdk-amd64/include/linux/jawt_md.h', which is also in package openjdk-9-jdk-headless:amd64 9~b114-0ubuntu1
Processing triggers for man-db (2.7.5-1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/openjdk-9-jdk_9~b114-0ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Revision history for this message
Greg Kennedy (envirocoug) wrote :

I see the "probably a fresh install" at bottom. Yep! I will update immediately. Am getting off the Microsoft teet, and messing up regularly. Just bear with me and maybe I'll will be able to contribute to the Ubuntu Community in the future.

sekaran (sekaran)
Changed in openjdk-9 (Ubuntu Xenial):
status: Confirmed → Fix Released
Klaus Eder (kiecmi-23)
Changed in openjdk-9 (Ubuntu):
assignee: satyender (bluejteacher) → Klaus Eder (kiecmi-23)
Revision history for this message
David Brown (vm-unix) wrote :

I can confirm that the askubuntu link on #25 worked; but shouldn't this be in a better state now that it is no longer pre-release?

Revision history for this message
João Manuel Rodrigues (jmr) wrote :

I'm on Ubuntu 16.04 (Xenial). I just did a `apt update; apt upgrade`.

    ~$ apt show openjdk-9-jdk
    Package: openjdk-9-jdk
    Version: 9~b114-0ubuntu1
    ...

If I install this package I still get the error, so it seems the fixed version is not in the Xenial repos, yet.

Revision history for this message
Jeffrey Walton (noloader) wrote :

Bump... Still a problem on the latest Ubuntu machines (fully patched):

   $ lsb_release -a
   No LSB modules are available.
   Distributor ID: Ubuntu
   Description: Ubuntu 16.04.4 LTS
   Release: 16.04
   Codename: xenial

And:

   $ sudo apt-get install openjdk-9-jdk
   Reading package lists... Done
   Building dependency tree
   Reading state information... Done
   Suggested packages:
     openjdk-9-demo openjdk-9-source visualvm
   The following NEW packages will be installed:
     openjdk-9-jdk
   0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
   12 not fully installed or removed.
   Need to get 0 B/16.6 kB of archives.
   After this operation, 58.4 kB of additional disk space will be used.
   (Reading database ... 198589 files and directories currently installed.)
   Preparing to unpack .../openjdk-9-jdk_9~b114-0ubuntu1_amd64.deb ...
   Unpacking openjdk-9-jdk:amd64 (9~b114-0ubuntu1) ...
   dpkg: error processing archive /var/cache/apt/archives/openjdk-9-jdk_9~b114-0ubuntu1_amd64.deb (--unpack):
    trying to overwrite '/usr/lib/jvm/java-9-openjdk-amd64/include/linux/jawt_md.h', which is also in package openjdk-9-jdk-headless:amd64 9~b114-0ubuntu1
   Errors were encountered while processing:
    /var/cache/apt/archives/openjdk-9-jdk_9~b114-0ubuntu1_amd64.deb
   E: Sub-process /usr/bin/dpkg returned an error code (1)

Revision history for this message
elatllat (elatllat) wrote :

bump

Revision history for this message
Michael K. Edwards (m-k-edwards) wrote :

Still broken:

Preparing to unpack .../openjdk-9-jdk_9~b115-1ubuntu1_amd64.deb ...
Unpacking openjdk-9-jdk:amd64 (9~b115-1ubuntu1) ...
dpkg: error processing archive /var/cache/apt/archives/openjdk-9-jdk_9~b115-1ubuntu1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/jvm/java-9-openjdk-amd64/include/linux/jawt_md.h', which is also in package openjdk-9-jdk-headless:amd64 9~b115-1ubuntu1

Revision history for this message
Illia Sorokoumov (ilya40umov) wrote :

Encountered the same problem:

dpkg: error processing archive /var/cache/apt/archives/openjdk-9-jdk_9~b114-0ubuntu1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/jvm/java-9-openjdk-amd64/include/linux/jawt_md.h', which is also in package openjdk-9-jdk-headless:amd64 9~b114-0ubuntu1

Revision history for this message
linex83 (linex83) wrote :

Unpacking openjdk-9-jdk:amd64 (9~b114-0ubuntu1) ...
dpkg: error processing archive /var/cache/apt/archives/openjdk-9-jdk_9~b114-0ubuntu1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/jvm/java-9-openjdk-amd64/include/linux/jawt_md.h', which is also in package openjdk-9-jdk-headless:amd64 9~b114-0ubuntu1

Revision history for this message
Ken Sharp (kennybobs) wrote :

There is zero point in commenting on a closed bug.

Go to Bug #1770646 and mark the bug as "affects me" - it does not need a hundred "me too" comments.

Changed in openjdk-9 (Ubuntu):
assignee: Klaus Eder (kiecmi-23) → DangQuang (quangtran1996)
Revision history for this message
jorge ortiz (jjo-lubunt) wrote :

no puedo instalar el whatsapp para pc

Changed in hundredpapercuts:
status: New → Fix Released
Revision history for this message
Norbert (nrbrtx) wrote :

Still happens on fresh Ubuntu 16.04 LTS while executing:

```
$ sudo apt-get install openjdk-9*
...
Unpacking openjdk-9-jdk:amd64 (9~b114-0ubuntu1) ...
dpkg: error processing archive /var/cache/apt/archives/openjdk-9-jdk_9~b114-0ubuntu1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/jvm/java-9-openjdk-amd64/include/linux/jawt_md.h', which is also in package openjdk-9-jdk-headless:amd64 9~b114-0ubuntu1
...
Errors were encountered while processing:
 /var/cache/apt/archives/openjdk-9-jdk_9~b114-0ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

```

So the bug is not yet fixed.

Revision history for this message
Bhosad Chod (bchodh) wrote :

Nice

Changed in openjdk-9 (Ubuntu Xenial):
assignee: nobody → Bhosad Chod (bchodh)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers