[needs-packaging]openjdk-8 in ubuntu

Bug #1297065 reported by andrew on 2014-03-25
722
This bug affects 96 people
Affects Status Importance Assigned to Milestone
openjdk-8 (Debian)
Fix Released
Unknown
openjdk-8 (Ubuntu)
Wishlist
Unassigned

Bug Description

I'm an avid Java developer. And rely on the simplicity of Ubuntu + Eclipse + JDK (openjdk-7) for my main environment. A few days ago, JDK 8 was released. How much would it take to see openjdk-8 as part of the official repository? I don't want to manually install it. I prefer it got updated through the Ubuntu's own update manager.

I know there is a PPA with the Oracle JDK 8 but I prefer to stick with OpenJDK and not have to add new PPA's to my servers.

James Ramsay (f-jack) wrote :

I tagged it as needing packaging so that MOTU can package open-jdk 8

tags: added: needs-packaging
summary: - openjdk-8 in ubuntu
+ [needs-packaging]openjdk-8 in ubuntu
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Changed in openjdk-7 (Ubuntu):
importance: Undecided → Wishlist
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openjdk-7 (Ubuntu):
status: New → Confirmed
Philipp Wendler (philw85) wrote :

It would be great if it could land at least in Trusty, so that we don't have a LTS version where the only available Java version is quite outdated. I expect many Java programs to require Java 8 some time while Trusty is still supported.

In fact, I am also a Java developer, and we will surely switch to Java 8 somewhere in the next 2 years. As most of our users are based on LTS versions of Ubuntu, having Java 8 in Trusty would be a major improvement for us.

information type: Public → Public Security
HRJ (harshad-rj) wrote :

Emmanuel Borg has published a test build of openjdk8 package here:
https://lists.launchpad.net/openjdk/msg09995.html

Sadly, no one has responded to it yet. I am going to try it, and encourage others try it too.

Changed in debian:
status: Unknown → New
Logan Rosen (logan) on 2014-05-11
affects: openjdk-7 (Ubuntu) → ubuntu
Changed in ubuntu:
status: Confirmed → Triaged
Changed in debian:
status: New → Fix Released
Saikrishna Arcot (saiarcot895) wrote :

I believe this should be marked as "Fix Released", now that there is an openjdk-8 package in Utopic?

andrew (andrew-j-matheny) wrote :

Any idea if these will be backported to trusty or precise?

Saikrishna Arcot (saiarcot895) wrote :

That will have to be a separate request, and won't be done automatically by this request. In addition, (assuming the initial request is approved) because there will be security updates in Utopic, someone will have to probably keep requesting the backport so that previous versions stay secure.

HRJ (harshad-rj) wrote :

In reply to #8,

I get the part about a separate request. But since 14.04 is LTS, wouldn't security updates be automatically applicable for the duration of the LTS?

Saikrishna Arcot (saiarcot895) wrote :

Security updates would apply, but I don't think this would be considered a security update, since this is an entirely new version and this source package (openjdk-8) isn't present in 14.04.

As always, an exception might be made since 14.04 has to live for the next 5 years, assuming the build dependencies can be brought down somehow.

Logan Rosen (logan) on 2014-07-14
affects: debian → openjdk-8 (Debian)
affects: ubuntu → openjdk-8 (Ubuntu)
Changed in openjdk-8 (Ubuntu):
status: Triaged → Fix Released
HRJ (harshad-rj) wrote :
Silvio Bierman (sbierman) wrote :

I have a development machine running Ubuntu 14.10 and have installed package openjdk-8-jdk. Unfortunately "java -version" reports "openjdk version 1.8.0_01-internal-fastdebug" which makes it a debug Java runtime build.

Running anything like Eclipse with this JDK is about five times slower than using openjdk-7-jdk, which is not a debug build.

Can we have a normal build please, possibly offering the debug build as a separate package?

Logan Rosen (logan) wrote :

Silvio, please file a bug against the openjdk-8 package: https://bugs.launchpad.net/ubuntu/+source/openjdk-8/+filebug

Silvio Bierman (sbierman) wrote :

Done.

Mitch Claborn (mitch-news) wrote :

Can you post the bug number here so I can follow it?

Saikrishna Arcot (saiarcot895) wrote :

The bug number is #1361895.

To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.