openjdk-7-jre-headless does not configure Rhino interpreter properly

Bug #920214 reported by Reiger on 2012-01-22
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
openjdk-7 (Ubuntu)
Undecided
Unassigned

Bug Description

The OpenJDK 7 JRE headless package does not configure the Rhino interpreter for use with JSR223 interface. (Presumably, it is not on the classpath.)

To test: Use the Jrunscript tool from the JDK (install openjdk-7-jdk), run: /usr/lib/jvm/openjdk-7-jdk/bin/jrunscript -q

Expect:
It should output a list of installed JSR223 interpreters, one of which is the Mozilla Rhino JavaScript interpreter:

Got:
Nothing.

For a comparison here is what an old SUN Java 6 JDK installation reports:
Run: /usr/lib/jvm/java-6-sun/bin/jrunscript -q

Language ECMAScript 1.6 implemention "Mozilla Rhino" 1.6 release 2

---------------

Note that the Mozilla Rhino interpreter is definitely shipped with the OpenJDK 7 JRE headless package:

dpkg -L openjdk-7-jre-headless |grep rhino
/usr/lib/jvm/java-7-openjdk-amd64/jre/lib/rhino.jar

System info:

lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

apt-cache policy openjdk-7-jdk
openjdk-7-jdk:
  Installed: 7~b147-2.0-1ubuntu2
  Candidate: 7~b147-2.0-1ubuntu2
  Version table:
 *** 7~b147-2.0-1ubuntu2 0
        500 http://main.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
        100 /var/lib/dpkg/status

apt-cache policy openjdk-7-jre-headless
openjdk-7-jre-headless:
  Installed: 7~b147-2.0-1ubuntu2
  Candidate: 7~b147-2.0-1ubuntu2
  Version table:
 *** 7~b147-2.0-1ubuntu2 0
        500 http://main.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
        100 /var/lib/dpkg/status

Reiger (jm-ouwerkerk) on 2012-01-22
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openjdk-7 (Ubuntu):
status: New → Confirmed
Damien Raude-Morvan (drazzib) wrote :

Fixed since 7~u3-2.1.1~pre1-1ubuntu2 upload.

Changed in openjdk-7 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers