path resolving issue: libsoftokn3.so not found, maybe affecting other native libraries

Bug #814306 reported by veyvr on 2011-07-21
70
This bug affects 11 people
Affects Status Importance Assigned to Milestone
openjdk-7 (Debian)
Fix Released
Unknown
openjdk-7 (Ubuntu)
Undecided
Unassigned

Bug Description

OpenJDK 7 (b147 amd64 from Oneiric Alpha PPA) sometimes shows strange path resolving behavior. 2 ways to reproduce it:
This bug is not present in (and does not affect):
- Oracle's JDK7 b147 (only testet on natty)
- OpenJDK 6 (6b22)

Affects at least: Natty amd64, Oneiric amd64

1. With Eclipse 3.7 (from eclipse.org), 3.6 (from eclipse.org), 3.5.2 (from Natty default PPA, not for Oneiric since it does not start in oneiric because of swt dependencie issue)
1.1 Open Eclipse-based application
1.2 Open "Help ⇒ About Eclipse"
1.3 Open "Configuration Details" or "Plugin Details"
1.4 Error dialog opens, error Message details:
_______
An internal error occurred during: "org.eclipse.ui.internal.dialogs.AboutPluginsDialog".
Library /usr/lib/x86_64-linux-gnu/libsoftokn3.so does not exist
_______
This file really does not exist in this folder, but in /usr/lib/x86_64-linux-gnu/nss and /usr/lib32/nss .
Starting Eclipse from other openjdk/oracle JRE this problem does not occurr.
For further details see attached files.

This affects RSSOwl (based on Eclipse 3.4) and some Eclipse Plugins (like UML LAB http://marketplace.eclipse.org/content/uml-lab ) as well as other Eclipse RCP based Software.

Eclipse 3.5.2 from Natty default PPA shows a little different behavior: "Plugin Details" is displayed without error message, "Configuration Details" tab is empty (no content but there must be one).

2. Minecraft does not find the same file ( /usr/lib/x86_64-linux-gnu/libsoftokn3.so ), see attachment

All problems described here do not occurr on openjdk6 or oracle's JDK 7.

I have noticed a similar problem with jMonkeyEngine (JMonkeyPlatform SDK, Mythruna) but am not sure if these problems are related. I'll keep investigating ;).

veyvr (chris-std) wrote :
veyvr (chris-std) wrote :

Eclipse 3.6 log file entry

veyvr (chris-std) wrote :

Minecraft Exception

Matthias Klose (doko) on 2011-07-21
tags: added: multiarch
veyvr (chris-std) wrote :

JMonkeyEngine (tested applications: JMonkeyPlatform SDK, Mythruna) which is based on lwjgl is not affected by this bug since it works with neither OpenJDK7 nor Oracle's JDK7.

jDownloader shows an Exception Stack Trace on start that libsoftokn3.so could not be found, but with all tested JVMs (OpenJDK 6, OpenJDK7 and Oracle's JDK 7). It keeps on starting anyway.

Under certain circumstances Eclipse-based applications get memory leaks when this bug occurs (and run out of Memory in less than 10 seconds even if 800MB were free before).

related package: libnss3 (containing libsoftokn3.so )
libnss3 3.12.9+ckbi-1.82-0ubuntu2 (amd64 binary) in ubuntu natty, https://launchpad.net/ubuntu/natty/amd64/libnss3/3.12.9+ckbi-1.82-0ubuntu2

libnss3 3.12.9+ckbi-1.82-0ubuntu4 (amd64 binary) in ubuntu oneiric, https://launchpad.net/ubuntu/oneiric/amd64/libnss3/3.12.9+ckbi-1.82-0ubuntu4

How about creating a symlink when installing libnss3 or openjdk-7 package?
I created a symlink from /usr/lib/x86_86-linux-gnu/nss/libsoftokn3.so to /usr/lib/x86_64-linux-gnu/libsoftokn3.so which fixed my problem for Natty and Oneiric (both with Oneiric version of libnss3 installed). Please note that libsoftokn3.so is located in another directory in libnss3 package for Natty.
Another way of fixing this bug is editing source code of openjdk-7, but I don't know how.

veyvr (chris-std) wrote :

Another thing: Installation of Eclipse plugins sometimes fails because of this bug since some security/signature checks use libsoftokn3.so .

Changed in openjdk-7 (Ubuntu):
status: New → Confirmed
Changed in openjdk-7 (Debian):
status: Unknown → New
Changed in openjdk-7 (Debian):
status: New → Fix Released
kurapix (warren.levin) wrote :

It is still present in the latest "Precise Pangolin (12.04)" distribution.

Why is the fix still not integrated?

The fix:
ln -s /usr/lib/x86_64-linux-gnu/nss/libsoftokn3.so /usr/lib/x86_64-linux-gnu/libsoftokn3.so

Matthias Klose (doko) wrote :

the "fix" is wrong.

get the 7~u3-2.1-1ubuntu3 package

Changed in openjdk-7 (Ubuntu):
status: Confirmed → Fix Released
kurapix (warren.levin) wrote :

It works fine for me.

Precise Pangolin (12.04) AMD64 and I've got package named netbeans 7.0.1+dfsg1-4

kurapix (warren.levin) wrote :

Whoops my mistake this package version is for netbeans ...

Anyway, I have the latest version for openjdk for sure.
It is 7~u3-2.1-1ubuntu3 and I had this message error ...
But i tried the symlinks trick before the fix was poster (27th of February).
I'm deleting my symlink and reinstalling the package :).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.