Ubuntu

wishlist: backport of openjdk-7 package

Reported by Manfred Moser on 2011-07-07
56
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Oneiric Backports
Undecided
Unassigned
Baltix
Undecided
Unassigned
openjdk-7 (Ubuntu)
Undecided
Unassigned

Bug Description

I would like to start using openjdk 7 via a repository asap (and not have to manually install the upstream release). Would it be possible to have the openjdk-7 packages from oneiric become available in natty-backports?

Micah Gersten (micahg) wrote :

Backports are handled outside the regular Ubuntu bug tracking, so I added a backports task and am therefore closing the Ubuntu task.

Changed in openjdk-7 (Ubuntu):
status: New → Invalid
Manfred Moser (mosabua) wrote :

Thank you.

Matthias Klose (doko) wrote :

for now unlikely before the final release, please use an oneiric chroot

Manfred Moser (mosabua) wrote :

Fair enough. However final release is on the 28th of July..

Iain Lane (laney) wrote :

I'm afraid we have a policy to not allow new language runtimes/interpreters into backports: "No changes to language interpreters (python, mono, java). These tend to have a greater risk of regression that is extremely difficult to test for. "

From https://help.ubuntu.com/community/UbuntuBackports#How%20to%20request%20new%20packages

So we won't be able to backport openjdk. My apologies.

Changed in natty-backports:
status: New → Invalid
Evan Broder (broder) wrote :

After some discussion on IRC, I think we've concluded that it's totally OK to backport openjdk-7, since all of the packages have separate names and can't conflict with old packages.

But I agree with Matthias that it's a good idea to hold off on the backport until openjdk-7 is released, so let's re-examine this then.

Once the final release is available in oneiric, the easiest way to accelerate the process is to test the backport yourself. Our requirements are fairly straightforward: we require that the package builds, installs, and starts on the release you're backporting it to. The easiest way to test this is with the backportpackage script from ubuntu-dev-tools.

Changed in openjdk-7 (Ubuntu):
status: Invalid → Incomplete
Manfred Moser (mosabua) wrote :

I will have a look and monitor this bug once the release is out and I am back from Oscon. Also in absence of a backport a ppa for it would be fine as well imho since only people in the know will want to upgrade ...

Manfred Moser (mosabua) wrote :

So the final release is available from Oracle now from all I know. Not sure about the state of OpenJDK package in oneric but the website says to just do an install via apt which is clearly only true if you are running oneric.. and who does that now?

http://openjdk.java.net/install/

Ideally this would get into backports asap

Changed in openjdk-7 (Ubuntu):
status: Incomplete → Confirmed

Any news of a backport?

Now that version u3 is out with the fix for the slow X graphics it would very, very appreciated to have the capability to install it on Oneiric

affects: natty-backports → oneiric-backports
Changed in oneiric-backports:
status: Invalid → New
summary: - wishlist: openjdk-7 package for natty backports
+ wishlist: backport of openjdk-7 package
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers