Menus unusable with gnome3 when windows maximised

Bug #777425 reported by Oliver Smith on 2011-05-04
256
This bug affects 56 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Expired
High
Iced Tea
Fix Released
Medium
JOSM
Unknown
High
openjdk-7 (Ubuntu)
Undecided
Unassigned

Bug Description

When using java applications on natty such as netbeans or arduino and openjdk in combination with gnome3/gnome-shell from the official ppa if a window is maximized the main menus are unusable.

- when you click on a menu, it disappears as soon as you release the
mouse button.

- when holding the mouse button and drawing along the menu (from File to
Edit for instance), nothing happens (the File menu remains opened the
Edit menu is not visible).

- when dragging further on the right, the Edit menu is finally
displayed, but the mouse is on the Refactor menu

- It is almost impossible to select an item in the menu and when it
finally works, you cannot select a sub-menu item

This problem is not resolved consistently by using sun-jre.

I am using the latest openjdk package 6b22-1.10.1-0ubuntu1 in a clean install of 11.04

Elie M. (elie-md) wrote :

I dont have open-jdk installed and I have jdk 1.7 installed with netbeans 7 on ubuntu 11.04 and gnome-shell aka gnome 3 and this bug affects me. I thought it always affects me but when I did read the title it looks like only when maximized. when I did minimise it worked correctly

Latchezar Tzvetkoff (polizei) wrote :

Almost sure it's Gnome3 related - my workstation has XFCE installed and menus are working fine, while on my Gnome3 laptop I can't click anywhere. I've tried both OpenJDK and Sun's JDK and I've also tested other java IDEs, PyCharm for example - same issue...

limpangel (limpangel) wrote :

This issue appears to be fixed in the latest Sun JDK update (v6.26).

teixeiras (teixeiras) wrote :

Hi!
java -version
java version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
Java HotSpot(TM) Server VM (build 20.1-b02, mixed mode)

I can confirm is not solved.

Changed in openjdk-6 (Ubuntu):
status: New → Confirmed
limpangel (limpangel) wrote :

Using:

java -version
java version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)

In Netbeans 7.0.1 menus are working as expected.

It might be a problem with openJDK or with the 32bit version of java.

beytu (beytu) wrote :

Hi,

Netbeans 7
sun jdk 6 x64
Gnome Shell

I also encounter issue with menu in fullscreen mode. The top menu is very buggy. The pop up menu on right click (on a file) is also buggy. It seems the application didn't receive the coordinate coordinate when i right click on a file in the project explorer tree.

open JDK 7 64:
I changed the JVM to openJDK 7 to check and no issue with menus.

Forage (forage) wrote :

The issue is not just related to openjdk, when using sun java jdk the issue occurs as well.

Confirmed with:
Ubuntu 11.10
Sun Java JDK 1.6.0.26
GNOME Shell 3.2

David Ramalho (dramalho-gmail) wrote :

Yep, happening with Netbeans 7.1RC1 , the ALT-SHIFT-ENTER twice to enter and leave fullscreen trick works

fiXedd (jeremy-logan) wrote :

I can confirm it on 64-bit "Sun" Java as well:

Confirmed with:
Ubuntu 11.10
GNOME Shell 3.2
Sun Java JDK 1.6.0.26
    Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
    Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)

HenryGR (henrygr) wrote :

Not fully sure that the problem is Java, I got the same issue using Firefox, Bluefish, ....
Anyhow, I am using:
Ubuntu 11.10
Gnome Shell 3.2
OpenJDK java 7
   Version: openjdk-7-jre 7~b147-2.0-0ubuntu0.11.10.1

Changed in gnome-shell:
importance: Unknown → High
status: Unknown → Incomplete

How to reproduce:

1. Start a Swing application (e.g. jEdit) under GNOME Shell
2. Open a window with a menu bar
3. Maximize the window
4. Try to use the menu

Expected: Menu is usable
Actual: When single-clicking, the menu closes immediately. When dragging, the entries can not activated.

What is interesting is that when the window is moved to the top left corner before maximizing it, the menu works. So it seems the menu position of the pre-maximized states is used.

The problem seems to be the switch on line 753 here on the WM Name/ID:

http://hg.openjdk.java.net/jdk8/awt/jdk/file/dcdf8cd4b09e/src/solaris/classes/sun/awt/X11/XDecoratedPeer.java

GNOME Shell uses "GNOME Shell" nowadays, not "Mutter" and so the code is not executed. Either the switch should also include "GNOME Shell" or it should be done for all cases as mentioned in the TODO above the switch.

magowiz (magowiz) wrote :

The issue also affects me with different jdk/jre : oracle 6 and 7 , openjdk 6 & 7 :
I'm using Ubuntu 12.10 on x86_64 and gnome-shell 3.6 from official repository

MATE desktop suffers from same problem. Please include that in the fix

The menus opened by combo boxes have the same problem, not sure if it's caused by the same code.

Daniel Bonniot (bonniot) wrote :

As reported in the previous comment, this also happens with openjdk-7

affects: openjdk-6 (Ubuntu) → openjdk-7 (Ubuntu)
Changed in icedtea:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in icedtea:
status: Confirmed → In Progress
Luthfi (luthfi-rasta) on 2013-07-21
Changed in openjdk-7 (Ubuntu):
status: Confirmed → Fix Committed

GNOME Shell is now fixed in OpenJDK8:
http://hg.openjdk.java.net/jdk8/awt/jdk/rev/8530456e0091

(In reply to comment #1)
> MATE desktop suffers from same problem. Please include that in the fix

The OpenJDK code is quite messy in this location, so it basically handles window managers on a case-by-case basis.

What's the _NET_WM_NAME used by mate?

Good to hear there is finally some progress on this.
MATE's vmname is Marco
It can be verified by looking at this source file: https://github.com/mate-desktop/mate-window-manager/blob/master/src/core/display.c

    meta_prop_set_utf8_string_hint (the_display,
                                    the_display->leader_window,
                                    the_display->atom__NET_WM_NAME,
                                    "Marco");

stefano.fraccaro (sf-1) wrote :

I have the same problem with LinuxMint Mate. The vmware is Marco as reported by the command

$ vmctrl -m

stefano.fraccaro (sf-1) wrote :

We should wait OpenJdk8 or it's possible to fix this issue also in openjdk7?

Don-vip (vincent-privat) on 2013-09-30
Changed in josm:
importance: Unknown → High

details: http://icedtea.classpath.org//hg/release/icedtea7-forest-2.3/jdk?cmd=changeset;node=7764e0491978
author: andrew
date: Tue Oct 08 16:37:50 2013 +0100

 PR1400: Menu of maximized AWT window not working in Mate

I've backported 8024863 to 7, against which this was filed, and also added a fix for MATE, which I've treated in the same way as Metacity, though with its own ID.

details: http://icedtea.classpath.org//hg/release/icedtea7-forest-2.4/jdk?cmd=changeset;node=e4ea4c3db76c
author: andrew
date: Tue Oct 08 16:37:50 2013 +0100

 PR1400: Menu of maximized AWT window not working in Mate

details: http://icedtea.classpath.org//hg/icedtea7-forest/jdk?cmd=changeset;node=0ff397456868
author: andrew
date: Tue Oct 08 16:37:50 2013 +0100

 PR1400: Menu of maximized AWT window not working in Mate

Changed in icedtea:
status: In Progress → Fix Released
Changed in gnome-shell:
status: Incomplete → Expired
Marcin Mielniczuk (marmistrz) wrote :

This still persists in 7u65 OpenJDK while using GeoGebra 4.4 on Mate (Linux Mint 17).

fgr1986 (fernando-garca) wrote :

Still persists on Ubuntu 15.04, both openjdk and oracle JVM. (v8).
The problem appears, at least, using Matlab.

Still persists on Ubuntu 18.04. Gnome-shell will not let you right-click in a java application. Other desktop environments like Unity and Openbox(LXDE) don't have this issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.