eclipse,visualvm crashes with SIGSEGV in libsoup.2-4

Bug #1174550 reported by KorRaf on 2013-04-29
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
openjdk-7 (Ubuntu)
Undecided
Unassigned

Bug Description

I'm not sure wether this shouldn't be reported to eclipse, however this error occurred after upgrade to 13.04(from 12.10).
here is trace from coredump of eclipse4.2:
Core was generated by `/usr/bin/java -Dosgi.requiredJavaVersion=1.5 -Dhelp.lucene.tokenizer=standard -'.
Program terminated with signal 6, Aborted.
#0 0x00007f872d10e037 in raise () from /lib/x86_64-linux-gnu/libc.so.6
(gdb) bt
#0 0x00007f872d10e037 in raise () from /lib/x86_64-linux-gnu/libc.so.6
#1 0x00007f872d111698 in abort () from /lib/x86_64-linux-gnu/libc.so.6
#2 0x00007f872c4d35a9 in os::abort(bool) ()
   from /usr/lib/jvm/java-7-openjdk-amd64/jre/lib/amd64/server/libjvm.so
#3 0x00007f872c62f85f in VMError::report_and_die() ()
   from /usr/lib/jvm/java-7-openjdk-amd64/jre/lib/amd64/server/libjvm.so
#4 0x00007f872c4daa8d in JVM_handle_linux_signal ()
   from /usr/lib/jvm/java-7-openjdk-amd64/jre/lib/amd64/server/libjvm.so
#5 <signal handler called>
#6 0x00007f865d36e009 in soup_session_feature_detach () from /usr/lib/x86_64-linux-gnu/libsoup-2.4.so.1
#7 0x00007f8695666aa9 in Java_org_eclipse_swt_internal_webkit_WebKitGTK__1soup_1session_1feature_1detach
    ()
   from /home/rakorai9/DEV/TOOLS/eclipse_JUNOjee/configuration/org.eclipse.osgi/bundles/634/1/.cp/libswt-webkit-gtk-4236.so
#8 0x00007f8721011f90 in ?? ()
#9 0x00007f87fffffffe in ?? ()
#10 0x00007f872c2fa6a9 in InterpreterRuntime::resolve_invoke(JavaThread*, Bytecodes::Code) ()
   from /usr/lib/jvm/java-7-openjdk-amd64/jre/lib/amd64/server/libjvm.so
#11 0x00007f8721006158 in ?? ()
#12 0x00000000f9be6fd8 in ?? ()
#13 0x00007f872100edd8 in ?? ()
#14 0x00007f87247439f0 in ?? ()
#15 0x00007f8721005410 in ?? ()
#16 0x0000000000000000 in ?? ()

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: openjdk-7-jre-headless 7u21-2.3.9-1ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
Uname: Linux 3.8.0-19-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
Date: Mon Apr 29 22:58:11 2013
ExecutablePath: /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java
InstallationDate: Installed on 2013-03-04 (56 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
LocalLibraries: /home/rakorai9/DEV/TOOLS/eclipse_JUNOjee/configuration/org.eclipse.osgi/bundles/634/1/.cp/libswt-cairo-gtk-4236.so /home/rakorai9/DEV/TOOLS/eclipse_JUNOjee/configuration/org.eclipse.osgi/bundles/634/1/.cp/libswt-pi-gtk-4236.so /home/rakorai9/DEV/TOOLS/eclipse_JUNOjee/configuration/org.eclipse.osgi/bundles/634/1/.cp/libswt-gtk-4236.so /home/rakorai9/DEV/TOOLS/eclipse_JUNOjee/configuration/org.eclipse.osgi/bundles/71/1/.cp/os/linux/x86_64/libunixfile_1_0_0.so /home/rakorai9/DEV/TOOLS/eclipse_JUNOjee/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20120913-144807/eclipse_1502.so /home/rakorai9/DEV/TOOLS/eclipse_JUNOjee/configuration/org.eclipse.osgi/bundles/634/1/.cp/libswt-atk-gtk-4236.so
MarkForUpload: True
SourcePackage: openjdk-7
UpgradeStatus: Upgraded to raring on 2013-04-28 (1 days ago)

KorRaf (rakorai9) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openjdk-7 (Ubuntu):
status: New → Confirmed

Suggested workaround until the bug is fixed here:

https://jira.appcelerator.org/browse/APSTUD-7816

Essentially, start eclipse with "-Dorg.eclipse.swt.browser.DefaultType=mozilla".

Sorry, in eclipse.ini, not command line. Not sure if it works (yet).

Paul Hudlow (paul-hudlow) wrote :

I just had the same (or a similar) problem using Eclipse on Ubuntu 14.04. I just got Eclipse installed and it was crashing very frequently. The suggested workaround seems to have worked.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers