Ubuntu

Internal Error (os_linux_zero.cpp:236)

Reported by Marty Vona on 2012-01-16
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
openjdk-6 (Ubuntu)
Undecided
Unassigned
openjdk-6b18 (Ubuntu)
Undecided
Unassigned

Bug Description

Some java code frequently crashes in native code with this error message. For one reproducable example, see

http://code.google.com/p/ohmm-sw/issues/detail?id=3

This is using the default "server" vm in openjdk-6 6b18-1.1.10 natty armel (pandaboard).

This appears to be a known issue: http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=720

The only real workaround seems to be to switch to the oracle proprietary EJRE, which runs this code fine.

Disabling JIT with "-XX:+PrintCommandLineFlags" as suggested in the above report also may work but is painfully slow. Installing openjdk-6-jre-zero and then running with "-zero" (how is the "zero" vm different than the openjdk "server" vm?) may also work but is also slow.

Xerxes Rånby (xranby) wrote :

The ARM assembler port and thumb 2 JIT have been maintained again and are now
included in the icedtea6-1.11 release. Can you check if this bug still exist in
icedtea6-1.11 ?
https://launchpad.net/ubuntu/+source/openjdk-6/6b24-1.11-2ubuntu1

Marty Vona (vona) wrote :

Xerxes -

This is great! Thanks for your work. I am testing now but so far I have not seen the bug again. Of course, it was an intermittent issue, so we should test further. The speed also looks good. Some more details are also now updated in the above referenced bug in our ohmm-sw project.

I am still using natty so to install the new jvm I had to first remove all java packages; then I manually installed

openjdk-6-jdk_6b24-1.11-2ubuntu1_armel.deb
openjdk-6-jre_6b24-1.11-2ubuntu1_armel.deb
openjdk-6-jre-headless_6b24-1.11-2ubuntu1_armel.deb
openjdk-6-jre-lib_6b24-1.11-2ubuntu1_all.deb
libjpeg8_8c-2ubuntu6_armel.deb
libjpeg-turbo8_1.1.90+svn733-0ubuntu4_armel.deb
libnss3-1d_3.13.1.with.ckbi.1.88-1ubuntu3_armel.deb
libnss3_3.13.1.with.ckbi.1.88-1ubuntu3_armel.deb

from precise. This breaks apt dependencies, of course, but the jre seems to work.

> java -version
java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11) (6b24-1.11-2ubuntu1)
OpenJDK Zero VM (build 20.0-b12, mixed mode)

We will probably update our system to precise this summer, and will test further then.

Xerxes Rånby (xranby) on 2012-03-15
Changed in openjdk-6 (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openjdk-6b18 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints