Scilab crshes when trying the editor

Bug #615085 reported by Jaime F. Meade Collins on 2010-08-08
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
openjdk-6 (Ubuntu)
Undecided
Unassigned

Bug Description

Whe i'm trying to run the editor of scilab, it crashes and i get this message from the console

(process:7702): Gtk-WARNING **: Locale not supported by C library.
 Using the fallback 'C' locale.
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0xb50cba71, pid=7702, tid=3014749072
#
# JRE version: 6.0_18-b18
# Java VM: OpenJDK Server VM (16.0-b13 mixed mode linux-x86 )
# Derivative: IcedTea6 1.8
# Distribution: Ubuntu 9.04, package 6b18-1.8-4ubuntu3~9.04.2
# Problematic frame:
# C [libjava.so+0x13a71] JNU_CallStaticMethodByName+0x31
#
# An error report file with more information is saved as:
# /home/jfmeade/hs_err_pid7702.log
#
# If you would like to submit a bug report, please include
# instructions how to reproduce the bug and visit:
# https://bugs.launchpad.net/ubuntu/+source/openjdk-6/
#
Aborted

I have the same problem when I try to use the menu of plots. I plot some results and when I try to use the graphical interface to change some display options I get the fatal error.

I include the lo generated by the fatal error.

Fernando Malick (fmalick) wrote :
Download full text (59.1 KiB)

I'm using Scilab 5.1.1 tht comes bundled with Ubuntu 9.10. It worked fine until a few weeks ago.
Apparently after a Java update it started crashing.
If I try to load functions to scilab or try to open the text editor, it simply crashes.

#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x009ba967, pid=6842, tid=3078585200
#
# JRE version: 6.0_20-b20
# Java VM: OpenJDK Server VM (19.0-b09 mixed mode linux-x86 )
# Derivative: IcedTea6 1.9.7
# Distribution: Ubuntu 9.10, package 6b20-1.9.7-0ubuntu1~9.10.1
# Problematic frame:
# C [libjava.so+0x13967] JNU_CallStaticMethodByName+0x47
#
# If you would like to submit a bug report, please include
# instructions how to reproduce the bug and visit:
# https://bugs.launchpad.net/ubuntu/+source/openjdk-6/
#

--------------- T H R E A D ---------------

Current thread is native thread

siginfo:si_signo=SIGSEGV: si_errno=0, si_code=1 (SEGV_MAPERR), si_addr=0x00000000

Registers:
EAX=0xb77f4f18, EBX=0x009caff4, ECX=0x01fa0841, EDX=0x01fa0828
ESP=0xb77f4ea0, EBP=0xb77f4ed8, ESI=0x00000000, EDI=0x01fa082b
EIP=0x009ba967, CR2=0x00000000, EFLAGS=0x00010246

Register to memory mapping:

EAX=0xb77f4f18
0xb77f4f18 is pointing to unknown location

EBX=0x009caff4
0x009caff4: <offset 0x23ff4> in /usr/lib/jvm/java-6-openjdk//jre/lib/i386/libjava.so at 0x009a7000

ECX=0x01fa0841
0x01fa0841: <offset 0x3e841> in /usr/lib/jvm/java-6-openjdk/jre/lib/i386/xawt/libmawt.so at 0x01f62000

EDX=0x01fa0828
0x01fa0828: <offset 0x3e828> in /usr/lib/jvm/java-6-openjdk/jre/lib/i386/xawt/libmawt.so at 0x01f62000

ESP=0xb77f4ea0
0xb77f4ea0 is pointing to unknown location

EBP=0xb77f4ed8
0xb77f4ed8 is pointing to unknown location

ESI=0x00000000
0x00000000 is pointing to unknown location

EDI=0x01fa082b
0x01fa082b: <offset 0x3e82b> in /usr/lib/jvm/java-6-openjdk/jre/lib/i386/xawt/libmawt.so at 0x01f62000

Top of Stack: (sp=0xb77f4ea0)
0xb77f4ea0: 0a6f9b08 b77f4f6c b77f4ed8 009b9baf
0xb77f4eb0: 08d4d724 b77f4ecc 00010002 036997a1
0xb77f4ec0: 036abff4 0a6f9b08 b77f4ee8 01fa7ff4
0xb77f4ed0: 00000000 b77f4f6c b77f4f28 01f71246
0xb77f4ee0: b77f4f18 00000000 00000000 01fa0841
0xb77f4ef0: 01fa082e 01fa0828 09be59c8 00000000
0xb77f4f00: b77f4f6c ffffffff 000009bd 002cdff4
0xb77f4f10: 00000001 b77f4fcc 00000000 01f711ca

Instructions: (pc=0x009ba967)
0x009ba957: 29 74 04 84 c0 75 f2 8b 45 08 c7 00 00 00 00 00
0x009ba967: 8b 06 c7 44 24 04 03 00 00 00 89 34 24 ff 50 68

Stack: [0xb6ff7000,0xb77f8000], sp=0xb77f4ea0, free space=8183k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C [libjava.so+0x13967] JNU_CallStaticMethodByName+0x47
C [libmawt.so+0xf246]
C [libX11.so.6+0x3a839] _XError+0x109
C [libX11.so.6+0x415ce] _XReply+0x1ae
C [libX11.so.6+0x2f591] XQueryTree+0x71
C [libtk8.5.so.0+0x27db0] Tk_HandleEvent+0x620
C [libtk8.5.so.0+0x28580]
C [libtcl8.5.so.0+0xa2c3b] Tcl_ServiceEvent+0x8b
C [libtcl8.5.so.0+0xa3017] Tcl_DoOneEvent+0x177
C [libtk8.5.so.0+0x20e2e]
C [libtcl8.5.so.0+0x20b59]
C [libtcl8.5.so.0+0x690e9]
C [libtcl8.5.so.0+0x67791]
C [libtcl8.5.so.0+0x21f89] TclEvalObjEx+0x169
C [libtcl8.5.so.0+0x2c9bb]
C [li...

Changed in openjdk-6 (Ubuntu):
status: New → Confirmed
Sylvestre Ledru (sylvestre) wrote :

This bug has been fixed in the 5.3.2 (or 5.3.1) release

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers