Comment 126 for bug 445009

Please try the RPMs from this koji build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1901359

You'll have to click the link for your architecture (i686 or x86_64, for example) and then download all the RPMs listed at the bottom of that page. Upgrade your existing package with something like:

# rpm -Uvh eclipse*3.5.1-22*.rpm

It fixes the "open update manager, click cancel -> crash" bug for me. I'd appreciate more feedback. Thanks.