first applet load asks for temp dir (cancel freeze firefox)

Bug #285729 reported by ®om on 2008-10-19
4
Affects Status Importance Assigned to Milestone
OpenJDK
Fix Released
Medium
openjdk-6 (Ubuntu)
Medium
Unassigned
Hardy
Medium
Unassigned
Intrepid
Medium
Unassigned

Bug Description

If I use icedtea6-plugin (openjdk browser plugin) to execute java applets, the first time (after installing it) I load an applet, it asks for the temp directory (default is /tmp), with 2 buttons : OK and cancel.

This question should be removed :
- 99% people don't care about what is the temp directory
- 99% of those who care will choose /tmp

Moreover, there is a problem if you click on cancel : no temp dir is selected.
Firefox takes 100%cpu and no applet can be executed until a kill -9 / restart of firefox, then choosing a temp dir and click on OK.

Related branches

"the first time (after installing it) I load an applet, it asks
for the temp directory (default is /tmp), with 2 buttons : OK and
cancel.

This question should be removed :
- 99% people don't care about what is the temp directory
- 99% of those who care will choose /tmp

Moreover, there is a problem if you click on cancel : no temp dir is selected.
Firefox takes 100%cpu and no applet can be executed until a kill -9 / restart of firefox, then choosing a temp dir and click on OK."

Changed in openjdk-6:
importance: Undecided → Medium
status: New → Triaged
Changed in openjdk:
status: Unknown → Confirmed

Fixed in tip (1180).

Changed in openjdk:
status: Confirmed → Fix Released
Adam Niedling (krychek) wrote :

I clicked OK and Firefox still freezes. This is a duplicate of bug #288642 . Should be marked as such.

James Stansell (jamesstansell) wrote :

This bug cannot be a duplicate of #288397, since this is for openjdk6-plugin while that is for sun-java6-plugin. How do you remove the duplicate status?

James Stansell (jamesstansell) wrote :

Sorry, I didn't word that quite that way I really meant to. If the bug was in the underlying JVM logic then in theory some bugs could be duplicated between the packages.

But in this case the /tmp question is definitely specific to the openjdk6-plugin implementation itself.

Adam Niedling (krychek) wrote :

Just click on the mark as duplicate button and remove whatever's inside the editbox. I removed the duplication, you're right about it.

Matthias Klose (doko) on 2008-11-11
Changed in openjdk-6:
importance: Undecided → Medium
status: New → Triaged
importance: Undecided → Medium
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openjdk-6 - 6b13~pre1-0ubuntu1

---------------
openjdk-6 (6b13~pre1-0ubuntu1) jaunty; urgency=low

  * New code drop (b13).
    - In the langtools area, besides a few miscellaneous bug fixes (6760834,
      6725036, 6657499), all the langtools regression tests now pass out of
      the box (6728697, 6707027) and if using the most recent version of
      jtreg, the langtools regression tests can be run in the much faster
      "same vm" mode of jtreg, enabled with the -s option (6749967, 6748541,
      6748546, 6748601, 6759775, 6759795, 6759796, 6759996, 6760805, 6760930).
    - Gervill update, including applying a patch from IcedTea (6758986,
      6748247, 6748251).
    - Publishing a few dozen additional existing regression tests as open
      source (6601457, 6759433, 6740185).
    - JMX and monitoring fixes (6651382, 6616825, 6756202, 6754672).
    - Man page updates (6757036, 6392810, 6504867, 6326773).
    - Assorted other fixes (6746055, 6621697, 6756569, 6356642, 6761678).
  * Update IcedTea build infrastructure (20081111).
    - Fix freeze in midi app, LP: #275672.
    - Fixes in the IcedTeaPlugin: LP: #282570, LP: #282570, LP: #285729,
      LP: #291377, LP: #37330, LP: #239533.
    - Fix vertical text metrics with freetype scaler. LP: #289784.
  * Build-depend on ecj-gcj instead of ecj on architectures using
    gij/gcj as the bootstrap system.

 -- Matthias Klose <email address hidden> Tue, 11 Nov 2008 12:39:16 +0100

Changed in openjdk-6:
status: Triaged → Fix Released
Adam Niedling (krychek) on 2008-11-14
Changed in openjdk-6:
status: Triaged → Invalid
status: Triaged → Fix Released
Changed in openjdk:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.