Uploading photos in Facebook does not work

Bug #258762 reported by Michael Green on 2008-08-17
44
This bug affects 6 people
Affects Status Importance Assigned to Milestone
openjdk-6 (Ubuntu)
Undecided
benske

Bug Description

When trying to upload photos via the photo uploader in Facebook the applet fails to initialize. You get the certificate up and can accept it but then the applet stalls. I'm using OpenJDK 6.

Steps to reproduce:

1. Go to www.facebook.com and log in.
2. Press Add Photos
3. Create and album and select upload photos

Some information about my system:

# update-java-alternatives -l
java-6-openjdk 1061 /usr/lib/jvm/java-6-openjdk
java-6-sun 63 /usr/lib/jvm/java-6-sun

# uname -a
Linux eowyn 2.6.24-19-generic #1 SMP Fri Jul 11 23:41:49 UTC 2008 i686 GNU/Linux

# lsb_release -rd
Description: Ubuntu 8.04.1
Release: 8.04

# cat /etc/jvm
/usr/lib/jvm/java-6-sun
/usr/lib/jvm/java-6-openjdk
/usr/lib/jvm/java-gcj
/usr/lib/jvm/ia32-java-1.5.0-sun
/usr/lib/jvm/java-1.5.0-sun
/usr

gmayer (gunther-mayer) wrote :

I can confirm this problem on my hardy system. This is on FF3.0.1 as bundled with Ubuntu 8.04, using openjdk-6-jre 6b11-2ubuntu2 and icedtea-gcjwebplugin 1.0-0ubuntu5.

When doing the steps above I also get the certificate trust screen, click on Run and nothing happens, just a grey rectangle with the FF status bar saying "Start: applet not initialized" at the bottom.

On closer inspection this could well be an issue with icedtea-gcjwebplugin though, not openjdk. See bug 199680 which is related to applets over an ssl connection and seems to be the same problem

Matthias Klose (doko) wrote :

needs a test case without using facebook. I don't have an account and I don't plan to create one.

Changed in openjdk-6:
status: New → Incomplete
gmayer (gunther-mayer) wrote :

I'd gladly create a testing account for you to try out. It will be 100% anonymous and be of no consequence whatsoever to anyone but the beneficiaries of this bug. Does that sound reasonable? I can't think of a better and more convenient test case than that.

Matthias Klose (doko) wrote :

please recheck with 6b12~pre2-0ubuntu2 in intrepid. is the ca-certificates-java package installed?

I can confirm this is still an issue in Intrepid.

#dpkg -l ca-certificates-java openjdk-6-jre
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii ca-certificate 20080712ubuntu Common CA certificates (JKS keystore)
ii openjdk-6-jre 6b12-0ubuntu6 OpenJDK Java runtime, using Hotspot JIT

#update-java-alternatives -l
java-6-openjdk 1061 /usr/lib/jvm/java-6-openjdk

#uname -a
Linux mourneblade.mossholder.com 2.6.27-7-generic #1 SMP Thu Oct 30 04:12:22 UTC 2008 x86_64 GNU/Linux

#lsb_release -rd
Description: Ubuntu 8.10
Release: 8.10

foucault (aag) wrote :

broken on my 8.04 machines here. java installed with "restricted-extras" package, updated proposed and backports, uptodate.

grumble grumble. ive always despised java. facebook useto have two uploaders, the legacy one which was the only one that worked in linux is no longer available... :(

foucault (aag) wrote :

The workaround is to install picasa and post to facebook from picassa.

http://picasa.google.com/linux/thanks-deb.html

foucault (aag) wrote :

oh yeah, just casue, you have to do this from the terminal,
picasa picasa://importbutton/?url=http://www.webkinesis.com/fbpicasa/facebook.pbf

foucault (aag) wrote :

nevermind, this didn't actually work for me. @#$#

Thelasko (stever530) wrote :

I confirm this as well. I'm using Hardy 64-bit with all of the updates. I thought this was a LiveConnect issue?

The legacy uploader appears to still be available to me, but I can only upload one photo at a time.

Thelasko (stever530) wrote :

The new plugin from Sun works for me on my 64-bit machine, so this is no longer a problem.

gmayer (gunther-mayer) wrote :

Thelasko, are you on Intrepid? We're still using hardy here for stability/LTS reasons and there is no "plugin from Sun" on my 64-bit installation... Just in case I checked and my openjdk version is exactly as I posted above, icedtea-gcjwebplugin is now 1.0-0ubuntu8 but it still doesn't work. Only thing that's different these days is that my FF3.0.5 now says "Stopped" on the status bar at the bottom left.

Thelasko (stever530) wrote :

Oops, I forgot to mention that I installed the sun Java that isn't officially supported buy Ubuntu. I am using Hardy Heron as well.
http://ubuntuforums.org/showthread.php?t=1032338
https://jdk6.dev.java.net/6uNea.html

I know this doesn't solve the OpenJDK bug, but it is a viable solution for people who just want Facebook to work.

Vincent Lönngren (bice77) wrote :

The facebook photo uploader still doesn't work in jaunty.

Kees Cook (kees) wrote :

Facebook photo uploader works fine for me in Karmic.

Changed in openjdk-6 (Ubuntu):
status: Incomplete → Invalid
Thelasko (stever530) wrote :

Invalid? I don't think it's invalid, I think the issue was resolved in Karmic.

benske (ben-beuster) on 2009-11-28
Changed in openjdk-6 (Ubuntu):
assignee: nobody → benske (ben-beuster)
status: Invalid → Confirmed
benske (ben-beuster) wrote :

Bug also exists in Karmic.

Gursel MUTLU (g-mutlu) wrote :

Still exists.

I'm not an Ubuntu user but it still crops up for me quite often on Fedora 11 and 12.

squiddy (squiddvault) wrote :

still there on lucid. crashing FF away

Theextendedname (tryme) wrote :

I also want to confirm this bug on lucid. Not a firefox crash but openJDK. Java spikes the cpu to 100%. I think that anyone saying facebook java uploader works for them doesn't have OpenJDK installed. I have seen this exact issue on 5 pc of different hardware config. The only thing they had in common was OpenJDK.

Installing sun-java-jre and sun-java6-plugin and removing OpenJDK fixes issue.
------------
sudo add-apt-repository "deb http://archive.canonical.com/ lucid partner"
sudo apt-get update
sudo apt-get install sun-java6-jre
sudo apt-get install sun-java6-plugin
-----------
then remember to remove OpenJDK.

sun-java reports a warning about running signed and unsigned code in facebook applet. So may be a bug in the way OpenJDK handles this.

Matthias Klose (doko) wrote :

please recheck with 6b18-1.8-4ubuntu3 in lucid

Changed in openjdk-6 (Ubuntu):
status: Confirmed → Incomplete
Lars (xlars) wrote :

I'm still seeing the issue on Lucid with 6b18-1.8-4ubuntu3.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers