The plugin does not properly start HP RiLOE II remote console

Bug #198093 reported by Pascal de Bruijn on 2008-03-03
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
openjdk-6 (Ubuntu)
Undecided
Unassigned

Bug Description

I have a java jar file, which is used by the HP RiLOE II remote console board. The applet is embedded into the web interface of the RiLOE like so:

<!-- Use jar based archive -->
document.writeln("<APPLET CODE = \"remcons.class\" ARCHIVE = \"remcons.jar\"");
document.writeln("width="+consoleWidth+" height="+consoleHeight+">");
document.writeln("<PARAM NAME = ARCHIVE VALUE = \"remcons.jar\" >");
document.writeln("<PARAM NAME=\"DUALCURSOR\" VALUE=\"false\">");

The applet only produces a gray square area, with so signs of any interactivity.

When the applet does work, using the official JDK, the applet displays a screen of my server, which I can use to remote control it.

Please note that on AMD64, I'm forced to using IcedTea as the official Sun JRE does not provide a web plugin!

Pascal de Bruijn (pmjdebruijn) wrote :
Pascal de Bruijn (pmjdebruijn) wrote :

I'm using the following version of IcedTea:

icedtea-java7-plugin 7~b24-1.5+20080118-1

Matti Lindell (mlind) wrote :

Can you reproduce this in Hardy, using icedtea-gcjwebplugin ?

Changed in icedtea-java7:
status: New → Incomplete
Pascal de Bruijn (pmjdebruijn) wrote :

When using the beta live cd, and installing openjdk6 and icedtea-gcjwebplugin on it, firefox just totally freezes up.

So the applet does not just fail, it takes firefox down with it.

Also, other applets seem to freeze up firefox as well:
http://www.java.com/en/download/help/testvm.xml

Pascal de Bruijn (pmjdebruijn) wrote :

This is still broken on Intrepid using
ii icedtea6-plugin 6b12-0ubuntu6

I got this when running firefox from a terminal:

pmjdebruijn@carnifex:~$ firefox
ICEDTEAPLUGIN_DEBUG = (null)
ICEDTEAPLUGIN_DEBUG = (null)
Initializing JVM...
NOT IMPLEMENTED: virtual nsresult IcedTeaPluginInstance::Start()
Jar string: remcons.jar
jars length: 1
JNLPRuntime already initialized
java.lang.NullPointerException
 at net.sourceforge.jnlp.tools.JarSigner.verifyJars(JarSigner.java:192)
 at net.sourceforge.jnlp.runtime.JNLPClassLoader.verifyJars(JNLPClassLoader.java:609)
 at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:302)
 at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:134)
 at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:191)
 at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:445)
 at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:418)
 at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:597)
netx: Initialization Error: Could not initialize applet. (net.sourceforge.jnlp.LaunchException Fatal: Initialization Error: A fatal error occurred while trying to verify jars.)
netx: Initialization Error: Could not initialize applet. (net.sourceforge.jnlp.LaunchException Fatal: Initialization Error: A fatal error occurred while trying to verify jars.)
net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: Could not initialize applet.
 at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:472)
 at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:418)
 at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:597)
Caused by: net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: A fatal error occurred while trying to verify jars.
 at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:308)
 at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:134)
 at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:191)
 at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:445)
 ... 2 more
Caused by:
net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: A fatal error occurred while trying to verify jars.
 at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:308)
 at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:134)
 at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:191)
 at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:445)
 at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:418)
 at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:597)
NOT IMPLEMENTED: virtual nsresult IcedTeaPluginInstance::Stop()
IcedTeaPlugin.cc:3809: Error: Failed to flush bytes to output channel: Broken pipe
pmjdebruijn@carnifex:~$

Christian Hofstaedtler (zeha) wrote :

This is also broken for me, with intrepid. Is there anything one can do to aid debugging?

Matthias Klose (doko) wrote :

please could you recheck with karmic and/or with updated packages at
https://edge.launchpad.net/~openjdk/+archive/ppa

Martin Meyer (elreydetodo) wrote :

That PPA doesn't seem to contain a plugin for Firefox.

I've installed the openjdk-7-jdk package and the plugin definitely seems to be missing. I don't see any other packages starting with 'openjdk' that look like they might provide that. Trying to switch my alternatives to use openjdk-7 gives this error:

$ sudo update-java-alternatives -s java-7-openjdk
update-java-alternatives: plugin alternative does not exist: /usr/lib/jvm/java-7-openjdk/jre/lib/i386/IcedTeaPlugin.so

Peter Veerman (pveerman) wrote :

I run the latest available versions and I have the same issue which make this issue fully reproducible. Mine also occurs when I open the page to my Compaq Remote Insight Lights-Out Edition

$ aptitude search icedtea openjdk -F "%V %v %p"
6b14-1.4.1 6b14-1.4.1 icedtea-6-jre-cacao
1.0-1ubunt <geen> icedtea-gcjwebplugin
<geen> <geen> icedtea6-jre-cacao
6b14-1.4.1 6b14-1.4.1 icedtea6-plugin
6b14-1.4.1 <geen> openjdk-6-dbg
6b14-1.4.1 <geen> openjdk-6-demo
6b14-1.4.1 <geen> openjdk-6-doc
6b14-1.4.1 6b14-1.4.1 openjdk-6-jdk
6b14-1.4.1 6b14-1.4.1 openjdk-6-jre
6b14-1.4.1 6b14-1.4.1 openjdk-6-jre-headless
6b14-1.4.1 6b14-1.4.1 openjdk-6-jre-lib
6b14-1.4.1 <geen> openjdk-6-jre-zero
6b14-1.4.1 <geen> openjdk-6-source
6b14-1.4.1 <geen> openjdk-6-source-files

Changed in openjdk-6 (Ubuntu):
status: Incomplete → Confirmed
Peter Veerman (pveerman) wrote :

Searching further lead me to: http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=177

This bug was resolved as invalid. Bug 177 was caused by a certification issue. Here comes in the logic. When I connect to my compaq device, firefox starts complaining about the fact that the certificate can't be verified with any of its know CA's. So I have to force firefox to accept the certificate. What now think based on the link above is that icedtea is unable to fetch the java files from my compaq device because it does not accept the certificate of the device.

Do I now think in the right direction or am I way off here?

A workaround for an issue like this is provided here:

http://muzso.hu/2008/08/12/how-to-overcome-a-certain-type-of-start-applet-not-initialized-error-with-an-ubuntu-firef

Peter Veerman (pveerman) wrote :

This is the output captured from the console when starting firefox from console

net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: Could not initialize applet.
 at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:495)
 at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:441)
 at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:620)
Caused by: java.lang.NullPointerException
 at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:481)
 ... 2 more
Caused by:
java.lang.NullPointerException
 at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:481)
 at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:441)
 at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:620)
java.lang.NullPointerException
 at net.sourceforge.jnlp.NetxPanel.runLoader(NetxPanel.java:102)
 at sun.applet.AppletPanel.run(AppletPanel.java:380)
 at java.lang.Thread.run(Thread.java:636)
java.lang.NullPointerException
 at sun.applet.AppletPanel.run(AppletPanel.java:430)
 at java.lang.Thread.run(Thread.java:636)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.