missing ipmi module

Bug #1309860 reported by Anthony Caiafa
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
openipmi (Ubuntu)
Fix Released
Undecided
Tim Gardner
Precise
Fix Released
Undecided
Tim Gardner
Trusty
Fix Released
Undecided
Tim Gardner
Utopic
Fix Released
Undecided
Tim Gardner

Bug Description

Currently upgraded from 12.04 to 14.04 and am experiencing issues with start openipmi via the init.d script. I did some digging around and it appears that the package

 linux-image-extra-3.13.0-24-generic

is missing the ipmi_msghandler.ko. It provides all other IPMI libraries but this one. for the 3.2.0 image the library and all of the others are provided in linux-image-3.2.0-60-generic. Please advise.
---
AlsaDevices:
 total 0
 crw-rw---- 1 root audio 116, 1 Apr 18 11:02 seq
 crw-rw---- 1 root audio 116, 33 Apr 18 11:02 timer
AplayDevices: Error: [Errno 2] No such file or directory
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
ArecordDevices: Error: [Errno 2] No such file or directory
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CRDA: Error: [Errno 2] No such file or directory
DistroRelease: Ubuntu 14.04
HibernationDevice: RESUME=UUID=22d5a085-fb47-4b25-acdc-61ad74a01746
IwConfig: Error: [Errno 2] No such file or directory
Lsusb:
 Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 003: ID 0557:2221 ATEN International Co., Ltd Winbond Hermon
 Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Supermicro X9SRW-F
Package: linux (not installed)
PciMultimedia:

ProcFB:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic root=UUID=83bbf6cb-5dd5-40bd-a89c-d4ad56112985 ro console=ttyS0,115200n8 biosdevname=0 nomdmonddf nomdmonisw
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-24-generic N/A
 linux-backports-modules-3.13.0-24-generic N/A
 linux-firmware 1.127
RfKill: Error: [Errno 2] No such file or directory
Tags: trusty
Uname: Linux 3.13.0-24-generic x86_64
UpgradeStatus: Upgraded to trusty on 2014-04-18 (0 days ago)
UserGroups:

WifiSyslog:

_MarkForUpload: True
dmi.bios.date: 07/05/2013
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 3.00
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: X9SRW-F
dmi.board.vendor: Supermicro
dmi.board.version: 0123456789
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: Supermicro
dmi.chassis.version: 0123456789
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr3.00:bd07/05/2013:svnSupermicro:pnX9SRW-F:pvr0123456789:rvnSupermicro:rnX9SRW-F:rvr0123456789:cvnSupermicro:ct3:cvr0123456789:
dmi.product.name: X9SRW-F
dmi.product.version: 0123456789
dmi.sys.vendor: Supermicro

Revision history for this message
Brad Figg (brad-figg) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1309860

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: precise
Revision history for this message
Anthony Caiafa (2600-ac) wrote : BootDmesg.txt

apport information

tags: added: apport-collected trusty
description: updated
Revision history for this message
Anthony Caiafa (2600-ac) wrote : CurrentDmesg.txt

apport information

Revision history for this message
Anthony Caiafa (2600-ac) wrote : Lspci.txt

apport information

Revision history for this message
Anthony Caiafa (2600-ac) wrote : ProcCpuinfo.txt

apport information

Revision history for this message
Anthony Caiafa (2600-ac) wrote : ProcEnviron.txt

apport information

Revision history for this message
Anthony Caiafa (2600-ac) wrote : ProcInterrupts.txt

apport information

Revision history for this message
Anthony Caiafa (2600-ac) wrote : ProcModules.txt

apport information

Revision history for this message
Anthony Caiafa (2600-ac) wrote : UdevDb.txt

apport information

Revision history for this message
Anthony Caiafa (2600-ac) wrote : UdevLog.txt

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Tim Gardner (timg-tpi) wrote :

ipmi_msghandler is now built into the Trusty kernel:

debian.master/config/config.common.ubuntu:CONFIG_IPMI_HANDLER=y

Looking at your current dmesg it also looks like your IPMI interface has initialized:

[77826.988711] ipmi device interface

You do have something else going on though. You shouldn't have that many messages suppressed in your dmesg (which start as soon as eth1 link comes up):

[ 18.912848] net_ratelimit: 108 callbacks suppressed

Are both ethernets plugged into the same switch ?

Changed in linux (Ubuntu Trusty):
assignee: nobody → Tim Gardner (timg-tpi)
status: Confirmed → Invalid
Revision history for this message
Anthony Caiafa (2600-ac) wrote :

hey ok so it looks like its an issue with the openipmi init.d script which calls for modprobe of the ipmi_msghandler in the start function. Since the file is no longer in the location the init.d script fails. I was able to rewrite it to avoid doing that so i wonder if we can have the maintainer update the package.

Revision history for this message
Tim Gardner (timg-tpi) wrote :

Please attach your patch and I'll see if it adheres to Ubuntu SRU policy.

affects: linux (Ubuntu Trusty) → openipmi (Ubuntu Trusty)
Changed in openipmi (Ubuntu Trusty):
status: Invalid → In Progress
Revision history for this message
Anthony Caiafa (2600-ac) wrote :

so basically its just removing the need to load ipmi_msghandler all together.

http://pastie.org/private/jree1yehzvcm6k7qjrh4iw

Revision history for this message
Tim Gardner (timg-tpi) wrote :

Just the diff please, e.g., 'diff -r -u original modified patch.txt'

Revision history for this message
Anthony Caiafa (2600-ac) wrote :

--- openipmi 2014-04-23 14:01:27.283366624 +0200
+++ openipmi_patch 2014-04-23 14:09:24.740122808 +0200
@@ -321,12 +321,9 @@
 load_ipmi_modules ()
 {
   local locdelay
- modprobe ipmi_msghandler > /dev/null 2>&1
- modules_loaded ipmi_msghandler
- [ ${OnePlusLoaded} -ne 1 ] && unload_all_ipmi_modules && RETVAL=$((RETVAL | 1)) && return
   load_hw_modules
   [ $((RETVAL & 1)) -eq 1 ] && unload_all_ipmi_modules && RETVAL=$((RETVAL | 1)) && return
-
+

   if [ "${DEV_IPMI}" = "yes" ]; then
     modprobe ipmi_devintf > /dev/null 2>&1

Revision history for this message
Anthony Caiafa (2600-ac) wrote :

I did not remove it from the script where its declared in

MODULES_BASE="ipmi_msghandler"
MODULES="${MODULES_INTERFACES} ${MODULES_FEATURES} ${MODULES_HW} ${MODULES_BASE}"

Revision history for this message
Tim Gardner (timg-tpi) wrote :

Rather then removing the module handling code, how about wrapping it with:

if ! grep ipmi_alloc_smi_msg /proc/kallsyms
then
  ...
fi

That way openipmi will continue to work with kernels where ipmi_msghandler is still modular.

Revision history for this message
Anthony Caiafa (2600-ac) wrote :

so i tested this exact script on an older system running 12.04 and it still successfully loads ipmi_msghandler so the script works across different platforms but fixes the issue on 14.04.

Revision history for this message
Ian Gordon (ian-gordon) wrote :

This is a patch to the bug. This is extracted from the current openipmi centos package.

It handles the fact the the IPMI modules may now be built into the kernel.

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "patch from centos" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Tim Gardner (timg-tpi)
Changed in openipmi (Ubuntu Utopic):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openipmi - 2.0.18-0ubuntu8

---------------
openipmi (2.0.18-0ubuntu8) utopic; urgency=medium

  * Detect that a module is built into the kernel.
    -LP: #1309860
 -- Tim Gardner <email address hidden> Tue, 20 May 2014 11:15:44 -0700

Changed in openipmi (Ubuntu Utopic):
status: Fix Committed → Fix Released
Tim Gardner (timg-tpi)
Changed in openipmi (Ubuntu Trusty):
status: In Progress → Fix Committed
Chris J Arges (arges)
Changed in openipmi (Ubuntu Trusty):
status: Fix Committed → In Progress
Revision history for this message
Tim Gardner (timg-tpi) wrote :

SRU Description:

openipmi won't start correctly because it does not detect that the ipmi module is built into the kernel.

Patch Description: Detect that the module name exists within the kernel namespace.

Revision history for this message
Chris J Arges (arges) wrote : Please test proposed package

Hello Anthony, or anyone else affected,

Accepted openipmi into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/openipmi/2.0.18-0ubuntu7.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in openipmi (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Revision history for this message
Ian Gordon (ian-gordon) wrote :

I can verify that openipmi_2.0.18-0ubuntu7.1 from trusty backports seems to fix the problem.

tag verification-done

tags: added: verification-done
removed: verification-needed
Revision history for this message
Chris J Arges (arges) wrote : Update Released

The verification of the Stable Release Update for openipmi has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openipmi - 2.0.18-0ubuntu7.1

---------------
openipmi (2.0.18-0ubuntu7.1) trusty; urgency=medium

  * Detect that a module is built into the kernel.
    Backported from Utopic.
    -LP: #1309860
 -- Tim Gardner <email address hidden> Tue, 20 May 2014 11:15:44 -0700

Changed in openipmi (Ubuntu Trusty):
status: Fix Committed → Fix Released
Revision history for this message
john Brooker (jeb-g) wrote :

This fix needs to be back ported to precise for users on the 3.13 kernel in that distribution.

Tim Gardner (timg-tpi)
Changed in openipmi (Ubuntu Precise):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Tim Gardner (timg-tpi)
Changed in openipmi (Ubuntu Precise):
status: In Progress → Fix Committed
Revision history for this message
Adam Conrad (adconrad) wrote : Please test proposed package

Hello Anthony, or anyone else affected,

Accepted openipmi into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/openipmi/2.0.18-0ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Revision history for this message
Kent Baxley (kentb) wrote :

Verified on precise with both the stock precise kernel as well as the hwe-Trusty kernel. In both cases the openipmi service started without issues.

Thanks!

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openipmi - 2.0.18-0ubuntu3.1

---------------
openipmi (2.0.18-0ubuntu3.1) precise; urgency=medium

  * Detect that a module is built into the kernel.
    Backported from Utopic.
    -LP: #1309860
 -- Tim Gardner <email address hidden> Tue, 24 Jun 2014 14:01:33 -0600

Changed in openipmi (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers