Sub Models field are not saved if we a new after modification

Bug #323363 reported by Steve Tousignant on 2009-01-30
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Odoo GTK Client (MOVED TO GITHUB)
Fix Released
Undecided
Unassigned
openerp-client (Ubuntu)
Undecided
Unassigned

Bug Description

This happen on stable version 4.2
== How to reproduce ==

1. Take a partner and change a field in his address.
2. After add a new address to the list of existing address.
3. Then save.
4. Take a look at the address you've just changed and it will be the same as before.

This is a common behavior when you work with partner with numerous contact. And this seem to not be the only place affected by this bug. All modules that uses a sub-modules in there form has chance to be affected by this bug. For example, you can do the same step to reproduce this bug in the account invoicing.

Related branches

Steve Tousignant (s-tousignant) wrote :

And here is my little patch to solve this.

description: updated

Thank you for the patch !

Changed in openobject-client:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: ubuntu → openerp-client (Ubuntu)
Changed in openerp-client (Ubuntu):
status: New → Confirmed
Dmitry Shachnev (mitya57) wrote :

Does the problem exist in the current stable version of Ubuntu? If not, please close this bug as "Fix Released".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers