opendkim-genkey generates invalid TXT record

Bug #1083503 reported by Markus Breitegger on 2012-11-27
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
opendkim (Ubuntu)
Undecided
Unassigned

Bug Description

[COMMAND]
opendkim-genkey -r -d yourdomin.tld
cat default.txt

WRONG
default._domainkey IN TXT "v=DKIM1;=rsa; p=MIGfMA0GC .... Q7GWwsbQIDAQAB"
RIGHT
default._domainkey IN TXT "v=DKIM1; k=rsa; p=MIGfMA0GC .... Q7GWwsbQIDAQAB"

[DISTRIBUTION]
Description: Ubuntu 12.04.1 LTS
Release: 12.04

[PACKAGE DETAILS]
opendkim:
  Installiert: 2.5.2+dfsg-1ubuntu3
  Kandidat: 2.5.2+dfsg-1ubuntu3
  Versionstabelle:
     2.6.8-0ubuntu1~ubuntu12.04.1 0
        100 http://de.archive.ubuntu.com/ubuntu/ precise-backports/universe amd64 Packages
 *** 2.5.2+dfsg-1ubuntu3 0
        500 http://de.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
        100 /var/lib/dpkg/status

Please try upgrading to the newer opendkim available in precise-backports and
see if you can replicate the problem with it.

error does not occour with this package

aptitude install -t precise-backports opendkim opendkim-tools

~# apt-cache policy opendkim
opendkim:
  Installiert: 2.6.8-0ubuntu1~ubuntu12.04.1
  Kandidat: 2.6.8-0ubuntu1~ubuntu12.04.1
  Versionstabelle:
 *** 2.6.8-0ubuntu1~ubuntu12.04.1 0
        100 http://de.archive.ubuntu.com/ubuntu/ precise-backports/universe amd64 Packages
        100 /var/lib/dpkg/status
     2.5.2+dfsg-1ubuntu3 0
        500 http://de.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages

thank you

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in opendkim (Ubuntu):
status: New → Confirmed
John Doe (m8r-bf9eg5) wrote :

confirming the bug affects me as well.

Scott Kitterman (kitterman) wrote :

This is fixed in the current development release. Precise users can get a fixed version from precise-backports.

Changed in opendkim (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers