FTBFS in natty

Bug #685500 reported by Matthias Klose on 2010-12-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ffmpeg (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
opencv (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

http://launchpadlibrarian.net/60081939/buildlog_ubuntu-natty-i386.opencv_2.1.0-3_FAILEDTOBUILD.txt.gz

needed to get python 2.7 support

cd /build/buildd/opencv-2.1.0/obj-i686-linux-gnu/src/highgui && /usr/bin/c++ -Dhighgui_EXPORTS -DHAVE_CONFIG_H -DHAVE_JPEG -DHAVE_PNG -DHAVE_TIFF -DHAVE_JASPER -DHIGHGUI_EXPORTS -DCVAPI_EXPORTS -g -O2 -Wall -pthread -march=i686 -ffunction-sections -O3 -DNDEBUG -fomit-frame-pointer -ffast-math -mfpmath=387 -DNDEBUG -fPIC -I/usr/lib/pymodules/python2.6/numpy/core/include -I/build/buildd/opencv-2.1.0/. -I/build/buildd/opencv-2.1.0/obj-i686-linux-gnu -I/build/buildd/opencv-2.1.0/include -I/build/buildd/opencv-2.1.0/include/opencv -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/build/buildd/opencv-2.1.0/src/highgui/../../include/opencv -I/build/buildd/opencv-2.1.0/src/highgui -I/build/buildd/opencv-2.1.0/obj-i686-linux-gnu/src/highgui -D PYTHON_USE_NUMPY=1 -include /build/buildd/opencv-2.1.0/obj-i686-linux-gnu/src/highgui/_highgui.h -Winvalid-pch -o CMakeFiles/highgui.dir/cvcap_ffmpeg.o -c /build/buildd/opencv-2.1.0/src/highgui/cvcap_ffmpeg.cpp
In file included from /usr/include/libavutil/avutil.h:81:0,
                 from /usr/include/libavcodec/avcodec.h:30,
                 from /usr/include/libavformat/avformat.h:56,
                 from /build/buildd/opencv-2.1.0/src/highgui/cvcap_ffmpeg.cpp:97:
/usr/include/libavutil/common.h: In function 'int32_t av_clipl_int32(int64_t)':
/usr/include/libavutil/common.h:154:47: error: 'UINT64_C' was not declared in this scope

Related branches

Revision history for this message
Matthias Klose (doko) wrote :

caused by an ffmpeg header?

Revision history for this message
Reinhard Tartler (siretart) wrote :

Not really. C++ Applications including FFmpeg Headers need to define
__STDC_LIMIT_MACROS before including libavutil headers.

Changed in ffmpeg (Ubuntu Natty):
status: New → Invalid
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package opencv - 2.1.0-3ubuntu1

---------------
opencv (2.1.0-3ubuntu1) natty; urgency=low

  * Adjust hack to re-included stdint.h for GCC-4.5. LP: #685500.
 -- Matthias Klose <email address hidden> Tue, 14 Dec 2010 14:34:19 +0100

Changed in opencv (Ubuntu Natty):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers