Update OpenCV version for 16.04

Bug #1540168 reported by combieone on 2016-01-31
78
This bug affects 16 people
Affects Status Importance Assigned to Milestone
opencv (Debian)
Fix Released
Unknown
opencv (Ubuntu)
Undecided
Unassigned

Bug Description

The Ubuntu 16.04 alpha still only contains OpenCV 2.4. It would be really good to update to OpenCV 3.1 for a distribution to be released in 2016, as the 2.4 series is getting quite old.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1540168/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → opencv (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in opencv (Ubuntu):
status: New → Confirmed
Arto Bendiken (artob) wrote :

Given that 16.04 (Xenial Xerus) is now feature-frozen, it seems unlikely this is going to happen for the present LTS release.

This is unfortunate, because the pressing problem with retaining the ancient OpenCV 2.4 in Xenial is that it doesn't include Python 3 bindings. The python-opencv package requires Python 2.7, which is not a good state of affairs going forward into a new LTS:

http://packages.ubuntu.com/xenial/python-opencv

Note also the related bug https://bugs.launchpad.net/ubuntu/+source/opencv/+bug/1516985 for upgrading to OpenCV 3.x.

Arto Bendiken (artob) wrote :

FYI, I opened bug #1556156 just now for the specific issue of the currently-shipped OpenCV version lacking Python 3 support altogether. As that issue is contingent on first shipping OpenCV 3.0, and the implications of failing to do so for the next LTS are not limited to merely the question of Python support, I am copying the full ticket description here:

https://bugs.launchpad.net/debian/+source/opencv/+bug/1556156

Because the packaged OpenCV remains at the obsolete 2.4 release even
still in 16.04 (Xenial Xerus), which is already in feature freeze, it is
looking as though 2018 is the earliest that an Ubuntu LTS release will
package OpenCV 3.x, which at that point will be already some 4 years
old. (And the currently-shipped OpenCV 2.x branch will be going on 9
years.) See bugs #1516985 and #1540168.

This is not a great state of affairs for such an important package, but
what exacerbates the situation is that OpenCV in Ubuntu (and in Debian)
currently altogether lacks Python 3 support. Namely, the current OpenCV
2.4 packages support only Python 2.7, since Python 3 support was
introduced only in OpenCV 3.0 [1], which was only packaged in Debian
(experimental) last December.

This has already been a pain point for OpenCV users (and some packages
requiring OpenCV) and is likely to become a burning problem over the
course of this LTS release's lifecycle. The robotics community (e.g. ROS
users), in particular, rely on Ubuntu LTS as a platform, and are going
to be rather rudely surprised both by Xenial's old OpenCV release and
still more by its lack of Python 3 support.

The relevant upstream Debian bugs are 799262 [2] and 792677 [3]. As
mentioned, OpenCV 3.0 has already been packaged in Debian (packages
libopencv-*3.0) and could be imported to Ubuntu. The Python bindings
(python-opencv) still remain with a Python 2.7 requirement, however,
which needs work upstream.

What can be done here? Would there be any prospect at all for a feature
freeze exception so as to ship OpenCV 3 for Xenial? Once the base
libraries are available, the Python 3 packaging is a much lesser problem
and could even be done via PyPI.

[1] http://opencv.org/opencv-3-0-alpha.html
[2] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=799262
[3] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=792677

Changed in opencv (Debian):
status: Unknown → Fix Released
Mike Gogulski (mi2e) wrote :

Subscribing, this affects me too.

Stephen Birch (sgbirch) wrote :

I have just started using xenial to prep our own software for the release. I was shocked that CV 3.0 is not installed. Surely this should be an exception to the feature freeze as already suggested, having to keep installing from source would be a huge pain.

Mike Gogulski (mi2e) wrote :

The final beta freeze for Xenial is coming up on the 24th according to https://wiki.ubuntu.com/XenialXerus/ReleaseSchedule

*prays that someone picks this up and champions an exception*

gje (gertjan-e) wrote :

FYI, it's probably too late to get into Xenial but currently there's a debian package for 3.0.0 on their experimental branch: https://tracker.debian.org/pkg/opencv

combieone (u9yo1ovjgfwe28r1) wrote :

Wow, this is outrageous, it needs to be fixed immediately. This fucks up everybody working in computer vision. This is a huge amount of people. OpenCV 2.4.9 is from 2014 and not even the bugfix releases up to 2.4.12 have made it into Ubuntu. 3.0 came out in 2015... and 3.1 in January this year. Come on. Compiling from source creates a huge hassle for everybody when you want to distribute your software or code. 99% of the people running our stuff are not nerds like us experienced developers that can compile OpenCV with CMake in 15mins. Ubuntu, you can do better than that. Not having 3.0/3.1 in 16.04 is a horrendous disappointment. This cannot happen.

100% agree. This is a disaster for Ubuntu. OpenCV is hugely important to
a ton of people.

On Fri, Apr 8, 2016 at 4:29 PM, combieone <email address hidden>
wrote:

> Wow, this is outrageous, it needs to be fixed immediately. This fucks up
> everybody working in computer vision. This is a huge amount of people.
> OpenCV 2.4.9 is from 2014 and not even the bugfix releases up to 2.4.12
> have made it into Ubuntu. 3.0 came out in 2015... and 3.1 in January
> this year. Come on. Compiling from source creates a huge hassle for
> everybody when you want to distribute your software or code. 99% of the
> people running our stuff are not nerds like us experienced developers
> that can compile OpenCV with CMake in 15mins. Ubuntu, you can do better
> than that. Not having 3.0/3.1 in 16.04 is a horrendous disappointment.
> This cannot happen.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1540168
>
> Title:
> Update OpenCV version for 16.04
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/opencv/+bug/1540168/+subscriptions
>

Raymond Liu (raaaaaymond) wrote :

There is another pressing issue. When I tried to compile OpenCV 3.1.0 from source, it complains that GCC versions later than 4.9 are not supported. The version of GCC that ships with Ubuntu 16.04 is 5.3.1 I think, which is nice. So the fact that OpenCV doesn't support it is a real shame. I desperately need OpenCV 3.x for my work and this is a massive setback.

Raymond Liu (raaaaaymond) wrote :

UPDATE, it's not directly OpenCV's fault that GCC versions later than 4.9 are not supported. It's actually CUDA 7.5 that doesn't support GCC versions later than 4.9. There is a proposed solution at https://gist.github.com/wangruohui/679b05fcd1466bb0937f but I haven't tried it yet.

Mattia Rizzolo (mapreri) wrote :

As several people explained, that's not going to happen.
Libraries like this don't get updated in stable releases, much less when they are not even yet in the current development release... (it will be for zesty+1 though, I intend to make sure of it...)

Changed in opencv (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.