cliparts are not in gallery-path of openoffice 3.0

Bug #363712 reported by fx5 on 2009-04-19
60
This bug affects 9 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
openclipart (Ubuntu)
Medium
Unassigned
Jaunty
Medium
Unassigned
Karmic
Medium
Unassigned

Bug Description

Binary package hint: openclipart

Hi!

Using fully updated jaunty installation, openclipart-openoffice.org installs to directory "/usr/lib/openoffice/share/gallery/", but I don't see any of them in openoffice 3.0.

I can fix this by adding the path to gallery-search-path manually or by copying them to "/usr/lib/openoffice/basis3.0/share/gallery/". Maybe they should be copied to this path?

Nick B. (futurepilot) wrote :

I ran into the problem myself. After installing the openclipart-openoffice.org package none of the images were showing up in the openoffice gallery. It appears to me that a lot of openoffice stuff got moved into this basis3.0 directory including the gallery stuff. If that is the case then it should be as simple as changing the install directory for the openclipart-openoffice.org package to put the theme files in /usr/lib/openoffice/basis3.0/share/gallery instead of /usr/lib/openoffice/share/gallery which is what this attached patch does that I made. I've built new openclipart packages in my PPA with these changes and tested to see if they fix the problem, and as far as I can see they do.

Changed in openclipart (Ubuntu):
status: New → Confirmed
Jordan Erickson (lns) wrote :

Just to confirm, I'm also seeing this via OOo 3.x PPA packages from openoffice-scribblers ( https://launchpad.net/~openoffice-pkgs/+archive/ppa ) when installing on 8.04LTS with normal openclipart* packages.

Jordan Erickson (lns) wrote :

Awesome. I can also confirm Nick B's workaround - I simply symlinked the original dir, opened OOo 3.1 and my openclipart appeared in the gallery!

---
root@Fibonacci:/usr/lib/openoffice/basis3.1/share# ln -s ../../share/gallery/ gallery
---

Thanks for the help!

Jordan Erickson (lns) wrote :

(after renaming the original 'gallery' dir to 'gallery.orig' of course, sorry)

Matthias Klose (doko) on 2009-05-17
Changed in openclipart (Ubuntu Jaunty):
importance: Undecided → Medium
milestone: none → jaunty-updates
status: New → Triaged
Changed in openclipart (Ubuntu Karmic):
importance: Undecided → Medium
milestone: none → karmic-alpha-3
Colin Watson (cjwatson) on 2009-06-19
Changed in openclipart (Ubuntu Karmic):
assignee: nobody → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

Hmm, I went to reproduce this before fixing it in Karmic only to find that it's already been fixed there, thanks to a sync from Debian:

openclipart (0.18+dfsg-8) unstable; urgency=low

  * rebuild for OOo 3.1
  * add conflicts against openoffice.org-commons newer than the basis we
    build against (( >= ${basis-version}.99) )
  * stop using Xvfb and rely on the headless mode of OOo/VCL. Makes the build
    not fail on sid due to Xvfb crashing...

 -- Rene Engelhard <email address hidden> Thu, 07 May 2009 17:16:39 +0200

openclipart (0.18+dfsg-7) unstable; urgency=low

  * upload to unstable

 -- Rene Engelhard <email address hidden> Fri, 20 Feb 2009 00:31:54 +0100

openclipart (0.18+dfsg-6) experimental; urgency=low

  * update for 3-layer OOo (basis-link)
  * move Homepage from description to Homepage:
  * remove bashisms (closes: #459115)

 -- Rene Engelhard <email address hidden> Thu, 08 Jan 2009 08:45:16 +0100

So I think it's just Jaunty.

Changed in openclipart (Ubuntu Karmic):
assignee: Colin Watson (cjwatson) → nobody
status: Confirmed → Fix Released
Steve Langasek (vorlon) on 2009-06-26
Changed in hundredpapercuts:
status: New → Fix Released
Michael Wild (themiwi) wrote :

For all those who suffer from this on Jaunty:

for f in /usr/lib/openoffice/share/gallery/sg*;
  do sudo dpkg-divert --add --rename --divert /usr/lib/openoffice/basis3.0/share/gallery/$(basename $f) $f;
done;

This solved it for me. Once Karmic hits the mirrors, you probably should remove those diversions (use "dpkg-divert --list" for that) before upgrading.

Changed in hundredpapercuts:
milestone: none → round-10
Changed in hundredpapercuts:
milestone: round-10 → round-8
Martin Pitt (pitti) on 2010-02-04
Changed in openclipart (Ubuntu Jaunty):
status: Triaged → Won't Fix
milestone: jaunty-updates → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions