Categories are unintelligible (or useless)

Bug #1013908 reported by leoperbo
60
This bug affects 9 people
Affects Status Importance Assigned to Milestone
openclipart (Ubuntu)
Undecided
Unassigned

Bug Description

Since Ubuntu 12.04 (package "openclipart-libreoffice 2.0-1ubuntu1") categories of openclipart listed in Libreoffice's gallery are unintelligible, or useless, because their names doesn't have a meaning associated with the draws.

Release of Ubuntu: 12.04
Version of the package: openclipart-libreoffice 2.0-1ubuntu1

I expected to happen:
Like previous versions, when I'm looking for a draw in the Libreoffice's gallery, categories of openclipart have significant names, associated with the draws: "Animals", "People", "Buildings", "Computer"...

What are happening:
When I'm looking for a draw in the Libreoffice's gallery, categories of openclipart have meaningless names, like "TilzaeL", "1in9ui5t", "A sanyayl 59", "Aaha" and so on. I don't have any idea where to look an specific draw.

Revision history for this message
leoperbo (leoperbo) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openclipart (Ubuntu):
status: New → Confirmed
Revision history for this message
Serge SMEESTERS (sergesmeesters) wrote :

Je trouve plus important d’éviter ce genre de régression, plutôt que d’ajouter de nouvelles fonctionnalités funs.

Comment ce genre de régression est-elle possible ?

L’équipe responsable du paquetage est-elle d’accord avec la considération d’un bogue ?
Je pose la question car le tri selon les auteurs peut se défendre... par exemple par les auteurs eux-mêmes. Je l’imagine car c’est le cas dans l’archive de openclipart que l’on peut (ou pouvait) télécharger pour le Windows. J’étais très fière de pouvoir récupérer le classement utilisable sous Ubuntu et l’offire aux malheureux utilisateurs du Windows. Pour l’instant, ces même utilisateurs du Windows rigole de moi :(

Donc, j’aimerais insister et donner mon avis favorable au classement par thèmes et défavorable au classement par auteurs. Je pense sincèrement que nous sommes majoritaire dans ce sens. Si la licence le permet, bien entendu...

Finalement, j’espère qu’une simple mise à jour, sous 12,04, suffira à régler le problème et qu’il ne faudra pas attendre la prochaine LTS.

******

I find more important to avoid this kind of regression, rather than adding new "fun features".

How are this kind of regression possible?

The team responsible for the package is she agree with the consideration of a bug?
I'm asking that because the sorting according to the authors can defend itself ... eg by the authors themselves. I imagine because it is (or was) the case in the archive openclipart that can download for Windows. I was very proud to be able to recover the classification used in Ubuntu and offire to the unfortunate Windows users. For now, these same Windows users kidding me: (

So I would like to emphasize and give my opinion favorable to the classification by themes and unfavorable ranking authors. I sincerely believe that we are the majority in this direction. If the license allows it, of course ...

Finally, I hope that a simple upgrade, in 12.04, enough to fix the problem and it will not wait for the next LTS.

Revision history for this message
Dean Montgomery (dmonty) wrote :

This clipart package is not only in poor order but I'm also being forced to remove adult and offensive content. We are trying to roll out ubuntu/libreoffice into elementary and secondary schools and some of these clips will defiantly cause a commotion. Here is a sample of some of the poor images in the openclipart package:

gustavorezende*
juanmontoya_lingerie_(see_png).png
gopher_Pink_anime_girl_(beta_).png
DooFi_Turd.png
grimgiant_*
kaeso*
molumen*
nicubunu*
radioflyer*
raemi*
Romanov*
stefann*
witchlines*
www_Sticker*

If Ubuntu & Openclipart want to maintain a professional image - then they need to literally clean up their images!!!

Revision history for this message
Ryan Tandy (rtandy) wrote :

In my opinion, this bug is fixed in quantal and newer, because the old openclipart package has been reinstated and the new collection has been renamed to openclipart2.

I doubt this change can be SRUed into precise, but luckily the binaries don't have any versioned dependencies and can be installed on any LibreOffice system all the way back to lucid.

Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :

closing as fix releases as per comment 5.

Changed in openclipart (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers