New UVFe to openbve 1.0.2.0 (universe+bugfix only)

Bug #356344 reported by Paul Sladen
2
Affects Status Importance Assigned to Milestone
openbve (Ubuntu)
Fix Released
Low
Paul Sladen
openbve-data (Ubuntu)
Fix Released
Low
Paul Sladen

Bug Description

Binary package hint: openbve

OpenBVE has gone 1.0 during feature fix, with a series of incremental bugfix releases. This also allows dropping several Linux/Mono patches that were being carried as a delta and reduces the patch load.

A couple of small cosmetic regressions have appeared, but the bugfixes brought in outweigh the side-effects. Upstream changelog follows:

  v1.0.2.0 (2009-04-05)
  * If a train does not explicitly specify the operating pressure of
    the brake pipe, it is now assumed to be 490 kPa if applicable. The
    train.dat documentation describes this in more detail.
  * Bugfix: PNG and GIF textures are now synchronously loaded in order
    to prevent them from ending up in the alpha rendering list where
    applicable (which is more expensive to render and can cause visual
    glitches if too heavily populated due to the use of depth sorting).
  * Bugfix: The RefreshRate parameter in animated objects was not
    applied if the animated object was used as a train exterior object.
  * Bugfix: Beacons which appeared before the starting position were
    not triggered, causing some trains to operate incorrectly on some
    routes.

  v1.0.1.0 (2009-03-29)
  * The stop indicator previously showed in Expert mode, which was not
    intended. It is now displayed only in Arcade and Normal modes.
    Additionally, the debug output is now unavailable in Expert mode.
  * Camera settings are now preserved when changing interior, exterior
    and track views. The zoom is reset though when switching the views.
  * The scrolling speed inside the cab has been made slightly slower.
  * Some compatibility graphics (needles) have been resaved as 8-bit
    per channel RGBA in order to appear correctly on Linux.
  * The code that applied transparency to the SDL window icon is now
    only executed on Windows. It could previously crash the program on
    Linux.
  * Warning messages are now shown again in openBVE. However, both
    warning and error messages can now be invidually disabled in the
    Options menu. Developers are strictly encouraged to leave these
    settings enabled, though.
  * Track positions in RW and CSV routes now require to adhere to the
    Strict number format. Previously, they were interpreted as Loose, which
    could mess up the route too much if an invalid statement was
    interpreted as a track position.
  * A default set of points of interests is now included for every
    station if the route does not define any points of interest itself.
  * The sound subsystem can now be deactivated in the options.cfg.
  * OpenBve64.exe is now available. It can be used on 64-bit systems
    that also provide 64-bit versions of the dependencies.
  * Bugfix: Entering the Jump to station menu previously crashed the
    program with an Index was outside the bounds of the array when the
    route did not have any stations. The menu entry is not displayed any
    longer.
  * Bugfix: In animated objects, the leftdoorstarget and
    rightdoorstarget variables could previously crash the program with an
    Index was outside the bounds of the array message, or these variables
    simply didn't work correctly.
  * Bugfix: In animated objects, texture clamping was disabled and
    could lead to visual artifacts at the edges of some textures.

  v1.0.0.0 (2009-03-23)
  * Fixed a bug that made the train topple and derail to the wrong
    side when driving backward.
  * Messages about missing support for Windows-only DLL plugins on
    Linux/Mac are now only generated if the train actually uses a plugin.
  * If an exception (runtime error) occurs inside a plugin, openBVE
    now crashes with the name of the plugin being reported.

0.9 series (development)

  v0.9.7.0
  * Fixed a bug that made digital gauges (LEDs) appear incorrectly
    since 0.9.6.0.
  * Modified some of the ingame-displays, including bringing back old
    stop indicator and repositioning fps/clock/speed indicators.
  * The A.I. now drives at 80%-100% of the route speed, depending on a
    random initial choice. This adds some slight variation to the preceding
    train.

  v0.9.6.0
  * The in-game displays have been redrawn to result in a hopefully
    more professional look.
  * Cant (superelevation) is now interpolated between blocks to give a
    smoother ride.
  * The built-in security systems now cut off power when the doors are
    not fully closed.
  * The volume of flange sounds has been slightly adjusted.
  * Fixed a bug that caused a crash when colliding backward with
    buffer stop.
  * Fixed a design flaw in the sound manager that could randomly
    prevent sounds from playing on some sound cards.

Paul Sladen (sladen)
Changed in openbve (Ubuntu):
assignee: nobody → sladen
importance: Undecided → Low
status: New → In Progress
Changed in openbve-data (Ubuntu):
assignee: nobody → sladen
importance: Undecided → Low
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openbve - 1.0.2.0-0ubuntu1

---------------
openbve (1.0.2.0-0ubuntu1) jaunty; urgency=low

  * New upstream version (bugfix release) (LP: #356344)
  * debian/rules: tweak to allow easy building of Debug or Release target
  * pass '/fhs' from the mono wrapper instead of hardcoding
  * overload GetSettingsFolder() to create the config directory before return it
  * Load first-use Keyboard mapping from GetDataFolder("Controls") not ~/
  * Default first-use game data from /usr/share/games/bve/{Railway/Route,Train}
  * Update 'openbve-data' Depends: >= 1.0.2.0+dfsg
  * Load timetables relative to route directory, not trainpath
  + disable spurious Train folder warning, as existance is not required later
  * Don't display hidden .files and .folders in ListViews
  * Include 'changelog.html' and 'releasenotes.html' downloaded from the website
  * Fix case in manpage documentation for '~/.config/OpenBve/'
  * Add README.Debian covering Debian-centric patches
  * Update 'known-issues.txt'
  * Print + try...except{} around path used in LoadOptions() (debugging)
  * Pacify lintian checker
  * Leave fullscreen before deinitialisation to reduce risk of leaving a mess

 -- Paul Sladen <email address hidden> Sun, 05 Apr 2009 12:33:10 +0000

Changed in openbve (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openbve-data - 1.0.2.0+dfsg-0ubuntu1

---------------
openbve-data (1.0.2.0+dfsg-0ubuntu1) jaunty; urgency=low

  * New upstream release 1.0.2.0 (2009-04-05) (LP: #356344)
  * Rename 'en-UK.cfg'->'en-GB.cfg'; and 'UK.png'->'GB.png'
  * Remove Recommends: openbve-data-icons; equivalents are now shipped upstream

 -- Paul Sladen <email address hidden> Mon, 06 Apr 2009 16:52:31 +0000

Changed in openbve-data (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers