package openbravo-erp 2.50-1 failed to install/upgrade: el subproceso post-installation script fue terminado por la señal (Interrupción)

Bug #410182 reported by Nelo on 2009-08-07
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
openbravo-erp (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by caligari
Nominated for Karmic by caligari

Bug Description

Binary package hint: openbravo-erp

I cannot install it.

ProblemType: Package
Architecture: amd64
DistroRelease: Ubuntu 9.04
ErrorMessage: el subproceso post-installation script fue terminado por la señal (Interrupción)
NonfreeKernelModules: nvidia
Package: openbravo-erp 2.50-1
SourcePackage: openbravo-erp
Title: package openbravo-erp 2.50-1 failed to install/upgrade: el subproceso post-installation script fue terminado por la señal (Interrupción)
Uname: Linux 2.6.28-14-generic x86_64

Nelo (nelo) wrote :
caligari (rafacouto) wrote :

There are errors in the init scripts, causing the startup and shutdown fail in environments configured with i18n (wrong grep expresion waiting for 'LISTEN' from netstat, which is localized and produces 'ESCUCHA', spanish). I have solved using -l parameter in 'netstat' and removing the 'grep' pipe.

While you wait for a new release of package, you can solve this bug by executing this from the console:

    sudo sed -i "s/netstat -vatn|grep LISTEN|/netstat -vatnl|/g" /etc/init.d/openbravo-erp-*

And restart openbravo:

    sudo dpkg-reconfigure openbravo-erp

Good bravo!

Brian Thomason (brian-thomason) wrote :

Thanks for the info - I'll pass this along to the developers at openbravo and we'll be sure to issue a fix in the next release. Sorry for any inconvenience.

Best regards,

Brian

gnuyoga (gnuyoga) wrote :

funny and interesting BUG :)

Juan Pablo Aroztegi (jpabloae) wrote :

@caligari: thank you for the bug report. Indeed there is a problem when the system has a non-english or non-C locale. However using "netstat -vatnl" does not provide the same output as we expect with the grep. With "-a" with include all and with "-l" only the ones that are listening. If we include both, "-a" wins. So "netstat -vtnl" is what we want.

Additionally we could export the es_US locale in the script, to make sure we don't have similar issues in the future.

@Brian: what do you think about this last proposal? Do you see any problems with that?

Juan Pablo

caligari (rafacouto) wrote :

@Juan Pablo: You are right, since -a involve all connections. So, the properly first 'sed' must be:

  sudo sed -i "s/netstat -vatn|grep LISTEN|/netstat -vtnl|/g" /etc/init.d/openbravo-erp-*

floral (floral684) wrote :

I have the same problem with https://bugs.launchpad.net/ubuntu/+source/openbravo-erp/+bug/435412
The code
 sudo sed -i "s/netstat -vatn|grep LISTEN|/netstat -vtnl|/g" /etc/init.d/openbravo-erp-*
 doesn't work in my pc
I still get the black screen right before the ''username and password'' step
In terminal I get :
''
 * Stopping openbravo-erp-tomcat [ OK ]
 * Stopping openbravo-erp-postgresql [ OK ]
 * Starting openbravo-erp-postgresql [ OK ]
 * Starting openbravo-erp-tomcat [ OK ]
Installation is now complete! Please point your browser to http://localhost:8880/openbravo ''

Gorka Gil (gorka.gil) wrote :

Hi floral,

As I see in you log, the installation ends successfully so I think the workaround works for you.

What do you mind with "in my applications" ? Openbravo ERP will not appear in any menu.
Have you tried to point your browser to http://localhost:8880/openbravo ?

What do you mind with "black screen right before the ''username and password'' step" ?

Note: It isn't necessary to change the language settings.

Regards,
Gorka

floral (floral684) wrote :

Thank your for your response Gorka Gil
The browser does respond to http://localhost:8880/openbravo
Still, there is a black screen when the computer starts just before it asks for username and password
This takes a while and it makes the starting longer
In the black screen there is a list of programs I have installed and an [ok] on the right

Gorka Gil (gorka.gil) wrote :

Ahhh this was the mysterious black screen :)

Great to see that are working your Openbravo ERP installation.

Yes, your are right the openbravo-erp-tomcat, has a difference with the standard tomcat:

The standard show in seconds that has started correctly, but in really it continues loading the contexts in background. The openbravo-erp-tomcat only shows that has started correctly when the Openbravo ERP context in completely loaded. This avoid that you start openbravo-erp and says that is successfully started and the you go to your browser and shows an error because the context is not really loaded.

If this behavior is annoying to you, you can follow this guide to not start openbravo-erp at boot time:
http://wiki.openbravo.com/wiki/ERP/2.50/Openbravo_ERP_Installation#Start_at_boot_time

Best regards,
Gorka

Gorka Gil (gorka.gil) wrote :

This affects only to Jaunty (9.04) package, in Karmic (9.10) is solved.

The workaround for Jaunty is execute this:
    sudo sed -i "s/netstat -vatn|grep LISTEN|/netstat -vtnl|/g" /etc/init.d/openbravo-erp-*
    sudo dpkg-reconfigure openbravo-erp

Changed in openbravo-erp (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers