openbox/Gnome wont launch from gdm

Bug #272418 reported by Kevin Tew
78
This bug affects 11 people
Affects Status Importance Assigned to Milestone
openbox (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Doug Schaapveld
Nominated for Karmic by Neil Perry

Bug Description

Binary package hint: openbox

Intrepid
openbox:
  Installed: 3.4.7.2-2
  Candidate: 3.4.7.2-2

In intrepid I had to comment out the default line and replace it with the following in /usr/bin/openbox-gnome-session

#exec gnome-session --choose-session=openbox-session "$@"
exec gnome-session "$@"

to avoid the following error.

gnome-session when launched from gdm was dying saying
** (gnome-session:24086): WARNING **: Unknown option --choose-session=openbox-session

Revision history for this message
Alexander Karlstad (alexander.karlstad) wrote :

Had the same problem. Removing the "--choose-session=openbox" argument fixed it.

Revision history for this message
SquarePulse (squarepulse) wrote :

I can confirm this, too. Actually, it's not a bug in openbox but in gnome-session. The parameter --choose-session is not supported (anymore) there.

Revision history for this message
Brent Newland (brent-newland) wrote :

Also confirmed here.

Revision history for this message
Spider (spider-alternating) wrote :

Verifying as well, it broke my upgrade path.

Please note that the manpage of gnome-session still documents --choose-session and --choosesession as valid options.

Waves% gnome-session --choose-session openbox
** (gnome-session:7119): WARNING **: Unknown option --choose-session

Waves% gnome-session --choosesession openbox
** (gnome-session:7120): WARNING **: Unknown option --choosesession

Revision history for this message
brian mcgee (justinisnt) wrote :

confirmed. solution worked for me too

Revision history for this message
Tom John (tomcjohn) wrote :

Confirmed. Solution worked for me also.

Revision history for this message
molave (molavec) wrote :

Confirmed. Solution worked for me also.

Revision history for this message
Jamie Bainbridge (superjamie) wrote :

solution works here also

Revision history for this message
Doug Schaapveld (djschaap) wrote :

Removing the "--choose-session=openbox-session" argument from /usr/bin/openbox-gnome-session fixed several computers of mine.

I've attached a very, very simple patch. How do we get this into -updates?

Revision history for this message
Steven Harms (sharms) wrote :

I can confirm this on Ubuntu 8.10

Changed in openbox:
status: New → Confirmed
Revision history for this message
Dilomo (ankere) wrote :

I can confirm it too in my Ibex 32bit

Revision history for this message
Shawn Dellysse (sdellysse) wrote :

I can confirm session bug on intrepid 64bit, updated fully today
Doug Schaapveld's patch worked for me.

Revision history for this message
Ivan Chen(西滨) (ivan4u) wrote :

Removing the "--choose-session=openbox-session" argument from /usr/bin/openbox-gnome-session doesn't work in Ubuntu 9.04

Revision history for this message
KLoK (klokane) wrote :

There is fast fix in jaunty:

klok@klok-laptop:~$ cat .xsession
#!/bin/bash
/usr/bin/openbox&
/usr/bin/gnome-session

(and you need to set Xclient as default session)

But troubles are there still (in .xsession-errors):
gnome-session[13754]: WARNING: Unable to find provider 'openbox' of required component 'windowmanager'

I tried to fix file '/usr/share/gnome/wm-properties/openbox.de', but i didn't get sucess.

Revision history for this message
Abhishek Mukherjee (linkinpark342) wrote :

Removing the argument worked for me in Jaunty. I attached the exact diff i applied in case it helps any.

Revision history for this message
Adam (adam-rogalski) wrote :

Removing "--choose-session=openbox-session" doesn't work for me in 9.04. After login gnome starts metacity (or compiz) as window manager.
This solution worked for me in 8.10.

Revision history for this message
Jamie Bainbridge (superjamie) wrote :

Same here.

However, KLoK's .xsession script does function as intended. It also launches the desktop environment alot quicker.

Revision history for this message
merrymenvn (merrymenvn) wrote :

Try "openbox --replace" :)

Revision history for this message
Ivan Chen(西滨) (ivan4u) wrote : Re: [Bug 272418] Re: openbox/Gnome wont launch from gdm

"openbox --replace" works for me. Thanks!

--
陈锡彬(Ivan Chen)
Blog | make life easier
http://ivan.javaeye.com/
Java Knowledge Base
http://groups.google.com/group/javakb

Revision history for this message
Jamie Bainbridge (superjamie) wrote :

Good thinking. I would say "openbox --replace" is probably alot cleaner than the .xsession script, as the script seems to fill up ~/.xsession-errors with messages. You could even put "openbox --replace" in Gnome's "Startup Applications" and just launch a normal Gnome session. Thanks!

Revision history for this message
hunterthomson (darden-tyler) wrote :

Did not work for me in 9.04. Gnome just took forever to load and then uses metacity.
Ubuntu hides the stdout I have know idea why.
I hate Ubuntu ... I miss Archlinux :( Darn ATI and there crappy drivers.

Revision history for this message
hunterthomson (darden-tyler) wrote :

OK I just added

openbox --replace

To gnome's startup applications and it works grate :)

Revision history for this message
Antti Kaihola (akaihola) wrote :

I've experienced this on Ubuntu Netboox Remix 9.04.

After installing the openbox packages, selecting the Openbox/GNOME session used Metacity instead of Openbox as the window manager.

I removed the --choose-session argument, and it fixed the issue until I turned Compiz on and back off from the System menu. I wouldn't get any window manager with GNOME and got this in .xsession-errors:

    gnome-session[13754]: WARNING: Unable to find provider 'openbox' of required component 'windowmanager'

These are the steps I took to fix the issue:

1. applied this patch to /usr/bin/openbox-gnome-session:
   http://bugs.frugalware.org/task/3498?getfile=657

2. gconftool-2 -s -t string /desktop/gnome/session/required_components/windowmanager openbox

3. sudo ln -s /usr/share/gnome/wm-properties/openbox.desktop /usr/share/applications/

Revision history for this message
Alexander Karlstad (alexander.karlstad) wrote :

Seems to me that things are finally starting to work again in Karmic. I "just" have to edit the /usr/bin/openbox-gnome-session and remove the "--choose-session" argument.

Still, the whole damn think should work right after "apt-get install openbox" without having to edit the script.

Revision history for this message
Caspar Clemens Mierau (leitmedium) wrote :

For me on Ubuntu Karmic Gnome/Openbox does not work on an unchanged -session file so far.

Revision history for this message
Iakov Davydov (iakov-davydov) wrote :

This bug affects me on karmic.

Revision history for this message
Kimec (kimeckun) wrote :

I just manually launch openbox in background. Metacity/Compiz won't start this way. So far it seems to work. I know it is dirty :D.

My openbox-gnome-session file:

#!/bin/sh

if test -n "$1"; then
    echo "Syntax: openbox-gnome-session"
    echo
    echo "See the openbox-gnome-session(1) manpage for help."
  exit
fi

# Run GNOME with Openbox as its window manager
export WINDOW_MANAGER="/usr/bin/openbox"
#exec gnome-session --choose-session=openbox-session "$@"
openbox&
exec gnome-session "$@"

Revision history for this message
KLoK (klokane) wrote :

Hi there again, on Koala I found clear solution which is working correctly:

Look comment at /usr/bin/gnome-wm

---cut---
... Please have your window manager install
# a desktop file and change the gconf key
# /desktop/gnome/session/required_components/windowmanager
---cut---

It looks it's working correctly if you set

Key:
/desktop/gnome/session/required_components/windowmanager

To value:
openbox

Enjoy

Revision history for this message
Eugene Arshinov (earshinov) wrote :

#28: When I modify the GConf key you mentioned and try to login into GNOME session, I get *one* workspace in workspace switcher applet instead of *four* as I set in ~/.config/openbox/rc.xml. Don't you have the same problem?

P.S. I've already discovered a workaround: run obconf and change number of desktop to 3 and back to 4. But you have to do this every time after login…

Revision history for this message
Eugene Arshinov (earshinov) wrote :

#29: Sorry, there is a separate bug report about the number-of-workspaces issue I mentioned:

https://bugs.launchpad.net/ubuntu/+bug/400301 number of workspaces in workspace switcher

Revision history for this message
Spider (spider-alternating) wrote :

#29: That is a workaround to use Openbox, it doesn't fix/make openbox a session of it's own, which is what the original report still is about.

Revision history for this message
KLoK (klokane) wrote :

[#29] confirm, after reboot I've same troubles, but other things (obMenu, obKeys) are working correcty

Revision history for this message
karl (karl-sebastian-liebich) wrote :

Confirmed for 9.10/32

Revision history for this message
YannUbuntu (yannubuntu) wrote :

Hello
I don't know if it is the same bug or just related one, but in Ubuntu 10.04, I did the following:
- install openbox (packages: paquets openbox obconf obmenu )
- on GDM, log with « GNOME/Openbox »
- Result (and problem): Openbox is not taken into account, I still have Compiz activated

On "Using Openbox in Gnome" wiki (http://openbox.org/wiki/Help:Using_Openbox_in_GNOME) I saw the following command:
openbox --replace
That worked for me.

Hope this helps.

Revision history for this message
David Futcher (bobbo) wrote :

I can't seem to reproduce this in Maverick dev branch. Opening a GNOME/Openbox session works with no issues (I'm writing to you from one right now). Could another Maverick tester please check whether this is an issue for them still?

Felix Geyer (debfx)
Changed in openbox (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for openbox (Ubuntu) because there has been no activity for 60 days.]

Changed in openbox (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers