Application Startup Notify fully ignored

Bug #1336521 reported by Lorenzo Ancora on 2014-07-01
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
openbox (Debian)
New
Unknown
openbox (Ubuntu)
Medium
Unassigned
Trusty
Medium
Simon Quigley
Xenial
Medium
Simon Quigley

Bug Description

[Impact]

Without this change, Lubuntu users with slow systems have no indication that a program has been started once the executable has been launched, so they might end up trying to go through diagnostics of some sort when in reality the program is just taking a while.

[Test Case]

 1. Start a program on a slow system, or just make sure the program is large.
 2. There should be an indication on the cursor that the program is starting up.

[Regression Potential]

The regression potential is fairly low because this dependency has been included in Debian and Ubuntu for over a year now. Where a regression could occur is if an update to libxcursor-dev is issued that is incompatible with openbox in a breaking way, and this is very unlikely in a stable release.

[Original Description]

Application Startup Notify option doesn't work and is apparently ignored: after starting any application there is no loading cursor or visual advice to tell if the application is really starting. Adding StartupNotify=true to the .desktop entry is useless, the parameter is just ignored.
This is very annoying when you use a touchpad because there is no feedback at all.

NOTES: libstartup-notification0 and notification-daemon are installed.

LStranger (andrej-rep) wrote :

It isn't problem of pcmanfm as libfm (and pcmanfm in turn) correctly prepares notification, but Openbox fails to change cursor, it's why startup notification doesn't work from any application running in Openbox. That issue was fixed in some version of Openbox, you have to upgrade or patch it. Thank you.

Lorenzo Ancora (lorenzo.ancora) wrote :

I use Openbox 3.5.2-3 (the latest version in Lubuntu) and the startup notification is missing.
I noticed that in Openbox for Ubuntu the issue was patched (https://launchpad.net/ubuntu/+source/openbox/3.5.2-4) and re-patched.
What should I do?

Mateusz Łukasik (mati75) wrote :

Yours Lubuntu version is unsupported. Please update to latest stable version.

jerrylamos (jerrylamos) wrote :

I'm running utopic Lubuntu 3.16.0-14 O.K. on Compaq Presario.

During development when the desktop isn't running right, I do a Ctrl-Alt-F1, on command line log in, then
sudo apt-get update
sudo apt-get dist-upgrade
y
sudo reboot

Widescreen monitor so I put the panel including startup etc. on the left side adjust the applet sizes looks much like Unity except I get one more horizontal text line. I choose panel background transparent so the applets look like they are floating above the background, an Australian beach scene with my wife in a bathing suit.

Changed in openbox (Ubuntu):
status: New → Incomplete
status: Incomplete → Fix Released
Changed in pcmanfm (Ubuntu):
status: New → Fix Released
Usuarioh Redeh (trabalhocal1a) wrote :

NOT FIXED AT ALL!!! No one single Debian or Ubuntu spin-off distro using LXDE+OPENBOX has "Startup Notification" working!! Neither the fresh news Lubuntu 16.04.1 or LXLE 16.04.1.
I won't listen any lame suggestion about replacing openbox with Kwin or Metacity as window manager, because if I wanted a BLOATED HEAVY system, I woul choose WINDOWS 10, which is much more beautiful than any linux distro, although is BLOATED and requires 2GB RAM.

Walter Lapchynski (wxl) wrote :

If changing the window manager fixes this (does it?), then the bug needs to be refiled to OpenBox. If someone can confirm a new version of OpenBox fixes this, a version number would help. Calling it fixed with no details is problematic.

Oh, and Usuarioh, if it's a window manager problem, there are plenty of lightweight ones out there. FluxBox might be worth a shot.

Changed in openbox (Ubuntu):
status: Fix Released → Incomplete
Changed in pcmanfm (Ubuntu):
status: Fix Released → Incomplete
Usuarioh Redeh (trabalhocal1a) wrote :

Walter Lapchynski,

-“If changing the window manager fixes this (does it?), then the bug needs to be refiled to OpenBox.”
This is not only an OpenBonx issue, because Fedora 24 LXDE+openbox has a fully functional working “Startup Notification”, so it’s an Ubuntu+Debian+all_its_spin-off_distros using LXDE+openbox or openbox issue.

-”If someone can confirm a new version of OpenBox fixes this, a version number would help. Calling it fixed with no details is problematic.”
This is what is happening sometimes: some moron saying that the OpenBox version number xxx.yyy fixed the problem, when in reality didn't fix anything

-”Oh, and Usuarioh, if it's a window manager problem, there are plenty of lightweight ones out there. FluxBox might be worth a shot.”
If you know any desktop+window_manager with memory footprint under 150 MB and a FULLY FUNCTIONAL STARTUP NOTIFICATION WORKING (this is not the Flux Box case!), be my guest and show me.

tags: added: gui
tags: added: openbox startup
Changed in openbox (Ubuntu):
status: Incomplete → Confirmed
Changed in pcmanfm (Ubuntu):
status: Incomplete → Confirmed
LStranger (andrej-rep) wrote :

The problem is a missing build dependency in openbox package - libxcursor-dev.
Fix it ASAP, please, for both currently used LTS distros. Thank you.

Changed in openbox (Debian):
status: Unknown → New
Usuarioh Redeh (trabalhocal1a) wrote :

"LStranger (andrej-rep) wrote on 2016-09-19: The problem is a missing build dependency in openbox package - libxcursor-dev."

I am using LXLE 16.04 (Lubuntu 16.04 LTS based), I built and installed openbox following the above instruction (adding libxcursor-dev parameter in /debian/control file to be built), but no luck, no "Startup Notification", it didn't work. Please, before any moron (and make me waste my time) post any message talking about "simple way to fix the problem", must be sure and/or give a sample or example that it really works.

LStranger (andrej-rep) wrote :

You make call me any way you want but in fact, it worked in both 14.04 and 16.04, otherwise I would not write such thing. It may not work for you, though, if your cursor theme does not support "waiting" cursor, but openbox package properly rebuilt with libxcursor-dev as a build dependency supports startup notification.
dixi

Changed in openbox (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openbox - 3.6.1-4

---------------
openbox (3.6.1-4) unstable; urgency=medium

  [ Bruno Pennati ]
  * Update manpage. (Closes: #800669)

  [ Mateusz Łukasik ]
  * debian/control:
    + Add plasma-workspace to openbox-kde-session depends. (Closes: #845386)
  * debian/patches:
    + Add fix-spelling-error-in-binary.patch.

 -- Mateusz Łukasik <email address hidden> Thu, 24 Nov 2016 09:51:09 +0100

Changed in openbox (Ubuntu):
status: Confirmed → Fix Released
Simon Quigley (tsimonq2) wrote :

I'll get to this ASAP, but it doesn't look like a pcmanfm problem.

Thanks.

Changed in openbox (Ubuntu Trusty):
status: New → Fix Released
Changed in openbox (Ubuntu Xenial):
status: New → Fix Released
Changed in openbox (Ubuntu Trusty):
status: Fix Released → Confirmed
Changed in openbox (Ubuntu Xenial):
status: Fix Released → Confirmed
Changed in pcmanfm (Ubuntu):
status: Confirmed → Incomplete
Changed in pcmanfm (Ubuntu Trusty):
status: New → Incomplete
Changed in pcmanfm (Ubuntu Xenial):
status: New → Incomplete
Changed in openbox (Ubuntu Trusty):
assignee: nobody → Simon Quigley (tsimonq2)
Changed in openbox (Ubuntu Xenial):
assignee: nobody → Simon Quigley (tsimonq2)
Simon Quigley (tsimonq2) on 2018-01-20
Changed in openbox (Ubuntu Trusty):
importance: Undecided → Medium
Changed in openbox (Ubuntu Xenial):
importance: Undecided → Medium
Simon Quigley (tsimonq2) on 2018-01-21
no longer affects: pcmanfm (Ubuntu)
no longer affects: pcmanfm (Ubuntu Trusty)
no longer affects: pcmanfm (Ubuntu Xenial)
Simon Quigley (tsimonq2) on 2018-01-21
description: updated

Hello Lorenzo, or anyone else affected,

Accepted openbox into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/openbox/3.6.1-1ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in openbox (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-xenial
Changed in openbox (Ubuntu Trusty):
status: Confirmed → Fix Committed
tags: added: verification-needed-trusty
Chris J Arges (arges) wrote :

Hello Lorenzo, or anyone else affected,

Accepted openbox into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/openbox/3.5.2-6ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Simon Quigley (tsimonq2) on 2018-01-25
Changed in openbox (Ubuntu):
importance: Undecided → Medium

Chris J Arges,
4 years have passed but thank you for your support. :-)

The startup notification now works but has some big flaws.
Since this is a patch to openbox I will do the tests in a stable and standard-compliant environment to see if the bug persists or not.

Environment: Debian GNU/Linux 9 (stretch) with XFCE 4 + Openbox 3.6.1-4 + notification-daemon installed
Hardware: Core i5, 8Gb RAM

CHANGELOG:
openbox (3.6.1-3) unstable; urgency=medium

  * debian/control:
    + Bump Standards-Version to 3.9.8.
    + Use secured links for VCS.
    + Add libxcursor-dev to B-D. (Closes: #838326, LP: #1336521)

NOTE: "LP: #1336521" is *this* bug in notifications.

Tests:

[Test Case 1]

 0. Started cpulimit to limit the execution to 3% of the total CPU power.
 1. Started Cheese 3.22.1 with startup notifications enabled (manually enabled from desktop file) from a desktop file.
 2. No spinning cursor at all.

Failed.

[Test Case 2]

 0. Started cpulimit to limit the execution to 10% of the total CPU power.
 1. Started Cheese 3.22.1 with startup notifications enabled (manually enabled from desktop file) from a desktop file.
 2. No spinning cursor at all.

Failed.

[Test Case 3]

 1. Started IDLE 3.5.3 with startup notifications enabled (default) from a desktop file.
 2. The spinning cursor appears only on the window and lasts for many seconds. The application has been started and the user can already work... but the cursor keeps spinning.

Failed?

[...many other tests with similar results, sometimes it works, other times does not]

I do not know where the problem is (changelog says the issue was closed...) but I cannot say that the startup notification is correctly supported.

Still, I am grateful for your efforts.

Regards,
Lorenzo

Changed in openbox (Debian):
status: Fix Released → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.