libopenblas-dev does not include lapacke.h

Bug #1728068 reported by Florian Franzen
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
openblas (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

On xenial (16.04) lapacke.h is not included with the development headers. Not sure why, as it includes "liblapack.so" never the less.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openblas (Ubuntu):
status: New → Confirmed
Revision history for this message
Florian Franzen (florianfranzen) wrote :

It this bug tracker being reviewed by any maintainers?

Is there a better way to contact the package maintainers about this issue than through launchpad?

Revision history for this message
Oliver (owlas) wrote :

I'm also waiting for a fix. I might try and patch in the next couple of weeks. Do you have any experience of that?

Revision history for this message
Matthew Arnold (matthew-arnold-1) wrote :

Also affects Bionic (latest LTS).
LAPACKE symbols are not exported by the so.

Revision history for this message
Matthew Arnold (matthew-arnold-1) wrote :

Missing header also affects Eoan (latest current). Given the absence of LAPACKE in Bionic, the most likely explanation is that it was built with non-standard NOLAPACKE. Worth noting that the Bionic build of lapacke appears to link to openblas, but also links to reference blas & lapack, so it's not clear if the optimized routines are used or not (or if this makes a difference).

Revision history for this message
Sébastien Villemot (sebastien-villemot) wrote :

The lapacke.h header is already provided by the liblapacke-dev package. No need to duplicate it in OpenBLAS packages.

Revision history for this message
Sébastien Villemot (sebastien-villemot) wrote :

As the Debian maintainer, I also confirm that the optimized LAPACK routines will be used by LAPACKE if you install the liblapacke-dev package along OpenBLAS packages (provided the alternatives are correctly set).

Revision history for this message
Sébastien Villemot (sebastien-villemot) wrote :
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers