Bots don't load due to bad file names

Bug #554748 reported by Cableless on 2010-04-03
96
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Quake 3
Fix Released
Undecided
Unassigned
openarena (Ubuntu)
Medium
Unassigned
quake3 (Fedora)
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: openarena

Due to incorrect use strcpy for the overlapping regions no bots are loaded (a specific errors at the bottom). This makes the whole single-player mode useless.

Bug has been solved in the development branch in version 0.8.1-7 by replacing incorrect strcpy uses with memmove function. The bug is contained within openarena package only (openarena-data is correct).

-----------------------------------
^1Error: file bots/default_c.c, line 24: file charsh" not found
^3Warning: couldn't find skill 1 in bots/default_c.c
^1Error: file bots/default_c.c, line 24: file charsh" not found
^1Error: file bots/default_c.c, line 24: file charsh" not found
^1Error: file bots/default_c.c, line 24: file charsh" not found
^3Warning: couldn't load any skill from bots/default_c.c
^1Error: file bots/sarge_c.c, line 24: file charsh" not found
^3Warning: couldn't find skill 1 in bots/sarge_c.c
^1Error: file bots/default_c.c, line 24: file charsh" not found

Related branches

Changed in openarena (Ubuntu):
status: New → Fix Released
status: Fix Released → New
Changed in openarena (Ubuntu):
status: New → Confirmed
Revision history for this message
madbiologist (me-again) wrote :

Fix committed in redhat bug.

Changed in openarena (Ubuntu):
status: Confirmed → Fix Committed
Changed in openarena (Ubuntu):
status: Fix Committed → Confirmed
Revision history for this message
Michał Gołębiowski-Owczarek (mgol) wrote :

I removed watches as they seem not to work - in both cases bug is resolved and here we still see unknown

Changed in quake3:
importance: Unknown → Undecided
status: Unknown → New
status: New → Fix Released
Changed in quake3 (Fedora):
importance: Unknown → Undecided
status: Unknown → New
status: New → Fix Released
Revision history for this message
Michał Gołębiowski-Owczarek (mgol) wrote :

Since it has been fixed in both icculus:
http://bugzilla.icculus.org/show_bug.cgi?id=4331
and RedHat:
https://bugzilla.redhat.com/show_bug.cgi?id=526338
maybe sb would port the fix here? :)

P.S. Why bug statuses hasn't been being updated automatically?

description: updated
description: updated
Revision history for this message
pioruns (pioruns) wrote :

When fix will be in ubuntu 10.04 repository?

madbiologist (me-again) on 2010-05-18
Changed in openarena (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
amano (jyaku) wrote :

Please don't set the Ubuntu status to Fix Commited, when it obviously isn't (you are free to link to the commit though)!

Changed in openarena (Ubuntu):
status: Fix Committed → Confirmed
Revision history for this message
madbiologist (me-again) wrote :

Fix Committed indicates that a fix is available upstream, and lets the Ubuntu package maintainer/s know that they need to evaluate it for possible inclusion in Ubuntu as an SRU. Once it moves out of Ubuntu-proposed to Ubuntu-updates we set the bug status to Fix Released.

But whatever. I'm not affected by this bug so I don't care what you do. Set the status to whatever you want.

Revision history for this message
Michał Gołębiowski-Owczarek (mgol) wrote :

I attach a debdiff solving the issue. This fix is credited to Andreas Bierfert (andreas.bierfert/at/lowlatency.de).

Revision history for this message
Michał Gołębiowski-Owczarek (mgol) wrote :

For potential testers I attach also updated deb file for openarena package. I confirmed that it solves the issue for me.

Deb is only for amd64 players but i386 ones are unaffected anyways.

Changed in openarena (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Michał Gołębiowski-Owczarek (mgol) wrote :

Sorry for the third post, but... could sb review attached patch and upload it to the repo?

Changed in openarena (Ubuntu):
status: Fix Committed → Confirmed
Revision history for this message
Ansgar Burchardt (aburch) wrote :

eglibc in Debian has been updated and the same problem is present. I will look into preparing an update in Debian which can then be synced to Ubuntu.

Changed in openarena (Ubuntu):
assignee: nobody → Ansgar Burchardt (ansgar-43-1)
importance: Undecided → Medium
status: Confirmed → In Progress
Revision history for this message
amano (jyaku) wrote :

Is there any chance to get this patch backported to Lucid? Without it, Open Arena is completely useless.

Revision history for this message
Michał Gołębiowski-Owczarek (mgol) wrote :

@amano
I agree it should be backported. Anyway, in the meantime You can check my build from the comment #8, for me it solved the issue.

Revision history for this message
Alexander Bazo (alexanderbazo) wrote :

can confirm that the patch attached by michal did solve the problem for me on lucid

tags: added: patch
Revision history for this message
radek.kaba (radek.kaba) wrote :

I confirm this patch from Michał works very well.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openarena - 0.8.1-7

---------------
openarena (0.8.1-7) unstable; urgency=low

  * Use memmove instead of strcpy for overlapping memory regions.
    (LP: #554748)
    + new patch: memmove.patch
  * Fix spelling error.
    + new patch: spelling.patch
  * debian/control: Add ${misc:Depends} to binary package dependencies.
  * Bump Standards-Version to 3.8.4 (no changes).
 -- Ubuntu Archive Auto-Sync <email address hidden> Mon, 14 Jun 2010 09:49:40 +0100

Changed in openarena (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Michał Gołębiowski-Owczarek (mgol) wrote :

Excuse me, could it be pulled into the Lucid repositories? It's still broken there and the fix already has more than two months...

Revision history for this message
Ansgar Burchardt (aburch) wrote : Re: [Bug 554748] Re: Bots don't load due to bad file names

Hi,

Michał Gołębiowski writes:
> Excuse me, could it be pulled into the Lucid repositories? It's still
> broken there and the fix already has more than two months...

Please follow the stable release update procedure [1]. I think your
debdiff [2] needs at least two changes:

 · Add "(LP: #554748)" to the changelog entry so the bug is referenced,
 · the distribution in d/changelog should be "lucid-proposed" and the
 · version number should be 0.8.1-6ubuntu0.1 as explained on [3],
 · the patch in debian/patches could have a nicer name and include more
   meta-information in the header (see the one in Debian [4]).

Regards,
Ansgar

[1] <https://wiki.ubuntu.com/StableReleaseUpdates#Procedure>
[2] <http://launchpadlibrarian.net/49794196/openarena_0.8.1-6ubuntu1.debdiff>
[3] <https://wiki.ubuntu.com/SecurityTeam/UpdatePreparation#Update%20the%20packaging>
[4] <http://git.debian.org/?p=pkg-games/openarena.git;a=blob;f=debian/patches/memmove.patch;h=13b0d7bb40f01d1c90deabba0a7bc45c92a480dc;hb=db9676b9ebdf055990a402316df9362d9f71c3fe>

 assignee nobody

Changed in openarena (Ubuntu):
assignee: Ansgar Burchardt (aburch) → nobody
Revision history for this message
Michał Gołębiowski-Owczarek (mgol) wrote :

A corrected debdiff attached.

description: updated
Revision history for this message
Michał Gołębiowski-Owczarek (mgol) wrote :

I don't know how to nominate it for Lucid, I don't see any link here.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.