openarena makes strange noise

Bug #358465 reported by lanig on 2009-04-09
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openarena (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openarena

Openarena makes strange noise at the beginning of the game (like when you plug/unplug a line in a turned on stereo) and the screen flickers a lot during the presentation of the logo until the menu. At the beginning of the game, it is really slow, with stange noise and gets better after. Overall, performance seems to be far poorer than it was in hardy with the same computer.

00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0d.0 VGA compatible controller: nVidia Corporation GeForce 6150SE nForce 430 (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control

ii x11-xserver-utils 7.4+1 X server utilities
ii xserver-common 2:1.6.0-0ubuntu12 common files used by various X servers
ii xserver-xorg 1:7.4~5ubuntu18 the X.Org X server
ii xserver-xorg-core 2:1.6.0-0ubuntu12 Xorg X server - core server
ii xserver-xorg-input-all 1:7.4~5ubuntu18 the X.Org X server -- input driver metapackage
ii xserver-xorg-input-evdev 1:2.1.1-1ubuntu4 X.Org X server -- evdev input driver
ii xserver-xorg-input-kbd 1:1.3.1-2ubuntu1 X.Org X server -- keyboard input driver
ii xserver-xorg-input-mouse 1:1.4.0-1 X.Org X server -- mouse input driver
ii xserver-xorg-input-synaptics 0.99.3-2ubuntu4 Synaptics TouchPad driver for X.Org/XFree86 server
ii xserver-xorg-input-vmmouse 1:12.5.1-4ubuntu4 X.Org X server -- VMMouse input driver to use with VMWare
ii xserver-xorg-input-wacom 1:0.8.2.2-0ubuntu2 X.Org X server -- Wacom input driver
ii xserver-xorg-video-all 1:7.4~5ubuntu18 the X.Org X server -- output driver metapackage
ii xserver-xorg-video-amd 2.11.1-1 Geode GX2/LX display driver (dummy transitional package)
ii xserver-xorg-video-apm 1:1.2.1-1 X.Org X server -- APM display driver
ii xserver-xorg-video-ark 1:0.7.1-1 X.Org X server -- ark display driver
ii xserver-xorg-video-ati 1:6.12.1-0ubuntu2 X.Org X server -- ATI display driver wrapper
ii xserver-xorg-video-chips 1:1.2.1-1 X.Org X server -- Chips display driver
ii xserver-xorg-video-cirrus 1:1.2.1-3 X.Org X server -- Cirrus display driver
ii xserver-xorg-video-dummy 1:0.3.1-1 X.Org X server -- dummy display driver
ii xserver-xorg-video-fbdev 1:0.4.0-3 X.Org X server -- fbdev display driver
ii xserver-xorg-video-geode 2.11.1-1 X.Org server -- Geode GX2/LX display driver
ii xserver-xorg-video-glint 1:1.2.2-1 X.Org X server -- Glint display driver
ii xserver-xorg-video-i128 1:1.3.1-2ubuntu1 X.Org X server -- i128 display driver
ii xserver-xorg-video-i740 1:1.2.0-2 X.Org X server -- i740 display driver
ii xserver-xorg-video-i810 2:2.4.1-1ubuntu10.4 X.Org X server -- Intel i8xx, i9xx display driver
ii xserver-xorg-video-intel 2:2.6.3-0ubuntu8 X.Org X server -- Intel i8xx, i9xx display driver
ii xserver-xorg-video-mach64 6.8.0-3 X.Org X server -- ATI Mach64 display driver
ii xserver-xorg-video-mga 1:1.4.9.dfsg-3 X.Org X server -- MGA display driver
ii xserver-xorg-video-neomagic 1:1.2.2-1 X.Org X server -- Neomagic display driver
ii xserver-xorg-video-nv 1:2.1.12-1ubuntu5 X.Org X server -- NV display driver
ii xserver-xorg-video-openchrome 1:0.2.903+svn713-1ubuntu1 X.Org X server -- VIA display driver
ii xserver-xorg-video-r128 6.8.0+git20090201.08d56c88-1 X.Org X server -- ATI r128 display driver
ii xserver-xorg-video-radeon 1:6.12.1-0ubuntu2 X.Org X server -- ATI Radeon display driver
ii xserver-xorg-video-rendition 1:4.2.0.dfsg.1-2ubuntu1 X.Org X server -- Rendition display driver
ii xserver-xorg-video-s3 1:0.6.1-1 X.Org X server -- legacy S3 display driver
ii xserver-xorg-video-s3virge 1:1.10.2-1 X.Org X server -- S3 ViRGE display driver
ii xserver-xorg-video-savage 1:2.2.1-4ubuntu2 X.Org X server -- Savage display driver
ii xserver-xorg-video-siliconmotion 1:1.7.0-1 X.Org X server -- SiliconMotion display driver
ii xserver-xorg-video-sis 1:0.10.1-1 X.Org X server -- SiS display driver
ii xserver-xorg-video-sisusb 1:0.9.0-4 X.Org X server -- SiS USB display driver
ii xserver-xorg-video-tdfx 1:1.4.0-2 X.Org X server -- tdfx display driver
ii xserver-xorg-video-trident 1:1.3.0-1ubuntu1 X.Org X server -- Trident display driver
ii xserver-xorg-video-tseng 1:1.2.0-1ubuntu1 X.Org X server -- Tseng display driver
ii xserver-xorg-video-v4l 1:0.2.0-1ubuntu5 X.Org X server -- Video 4 Linux display driver
ii xserver-xorg-video-vesa 1:2.0.0-1ubuntu6 X.Org X server -- VESA display driver
rc xserver-xorg-video-via 1:0.2.2-5 X.Org X server -- VIA display driver
ii xserver-xorg-video-vmware 1:10.16.5-2 X.Org X server -- VMware display driver
ii xserver-xorg-video-voodoo 1:1.2.0-1ubuntu1 X.Org X server -- Voodoo display driver

I use the proprietary drivers rev 180. Desktop effects are not enables.

Daniel (hackie) wrote :

Also have strange sound here. But during the whole game while having Rhythmbox playing music at the same time. I think it has to do with the sound subsystem when mixing different sound sources. Can you check if you can reproduce that (playing music while playing)?

Changed in openarena (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers