Ubuntu

libopenal needs replacement

Reported by Robin on 2008-02-24
38
This bug affects 4 people
Affects Status Importance Assigned to Milestone
openal (Debian)
Fix Released
Unknown
openal (Ubuntu)
High
Unassigned
Nominated for Hardy by Robin
Nominated for Intrepid by Robin
Nominated for Karmic by Konrad

Bug Description

Binary package hint: libopenal0

libopenal needs replacement

Applications using this old OpenAL implementation (all versions) makes horrible sound output errors and should be replaced
with the new implementation of OpenAL, OpenAL Soft, which can be found at http://kcat.strangesoft.net/openal.html

With OpenAL Soft I get the most crystal clear sound I have ever heard in any 3d game with Ubuntu.

The Fiddler (stapostol) wrote :

I agree, OpenAL soft will officially replace the outdated and buggy sample implementation. Unlike the SI, OpenAL soft actually conforms to the OpenAL specs.

Some maintainer *please* look into that, it will be a shame to ship Hardy with so obviously and horribly broken OpenAL support.

Rob van der Linde (robvdl) wrote :

I agree with this as well, at the moment many games make horrible crackly sound on anything but Creative Labs sound cards, at the moment there are two workarounds:

 - Get a Creative sound card (But not the X-Fi which isn't Linux compatible yet)

 - Manually compile the OpenAL software drivers, and stick with your previous sound card

OpenAL has been broken like this for a few releases of Ubuntu now, it's been like this far too long, com'on let's fix this issue :)

Cristian KLEIN (cristiklein) wrote :

I also advocate this change. Both supertux and FreeSpace 2 Open sound cracky with the Ubuntu-shipped version. Then compiling and using OpenAL Soft, sound works perfectly.

Cristian KLEIN (cristiklein) wrote :

Anybody cares to test my version of the solution?

I created a new package called libopenal0a-soft, with the latest version of OpenAL. I renamed the old package libopenal0a to libopenal0a-creative, and created a metapackage libopenal0a which depends on either one of them. Thus, no Ubuntu packages have to be recompiled.

The debs can be downloaded from http://cristiklein.c7obs.net/public/kiwi/openal/. There is also a textfile http://cristiklein.c7obs.net/public/kiwi/openal/test-openal.txt, which shows how to download / install / test (using supertux) both versions (creative and soft). You should notice that the first invocation of supertux has croppy sound, while the second one does not.

Thanks.

Cristian KLEIN <email address hidden> writes:

> I created a new package called libopenal0a-soft, with the latest version
> of OpenAL. I renamed the old package libopenal0a to libopenal0a-
> creative, and created a metapackage libopenal0a which depends on either
> one of them. Thus, no Ubuntu packages have to be recompiled.

Ah, thanks for that, I was asking earlier for someone to do that.

The following package currently link against libopenal0a (not counting
possible indirect dependencies):

  tremulous
  mplayer-nogui
  mplayer
  glest
  funguloids
  xpilot-ng-client-x11
  xpilot-ng-client-sdl
  warzone2100
  vegastrike
  trigger
  torcs
  supertuxkart
  supertux
  scorched3d
  python-soya
  python-openal
  openarena
  libosgal1
  libhugs-openal-bundled
  libcoin40c2
  flightgear
  chromium
  btanks
  boson
  antigravitaattori
  rss-glx

I'd really like to see a test with schorced3d (which has a history with
openal in the past), openarena and chromium.

I see if I can allocate some time this weekend for this. If someone
comes to that sooner, go for it!

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Cristian KLEIN (cristiklein) wrote :

Reinhard Tartler wrote:
> Cristian KLEIN <email address hidden> writes:
>
>> I created a new package called libopenal0a-soft, with the latest version
>> of OpenAL. I renamed the old package libopenal0a to libopenal0a-
>> creative, and created a metapackage libopenal0a which depends on either
>> one of them. Thus, no Ubuntu packages have to be recompiled.
>
> Ah, thanks for that, I was asking earlier for someone to do that.
>
> The following package currently link against libopenal0a (not counting
> possible indirect dependencies):
>
> tremulous
> mplayer-nogui
> mplayer
> glest
> funguloids
> xpilot-ng-client-x11
> xpilot-ng-client-sdl
> warzone2100
> vegastrike
> trigger
> torcs
> supertuxkart
> supertux
> scorched3d
> python-soya
> python-openal
> openarena
> libosgal1
> libhugs-openal-bundled
> libcoin40c2
> flightgear
> chromium
> btanks
> boson
> antigravitaattori
> rss-glx
>
> I'd really like to see a test with schorced3d (which has a history with
> openal in the past), openarena and chromium.

I tested openarena, chromium and supertux, they definitely work better with the
openal-soft version.

>
> I see if I can allocate some time this weekend for this. If someone
> comes to that sooner, go for it!
>

Robin (mobileforces) wrote :

There's no need to test any more games, they all use the same version and
the difference is obvious. Just replace it already.

Reinhard Tartler (siretart) wrote :

dear motu-release team,

I didn't check that myself thourougly, but contributors in this bug have tested the new openal and claim that it works way better than the old openal version. I'm asking for your opinion here.

Cesare Tirabassi (norsetto) wrote :

What use would our opinion be for an application in main?

StefanPotyra (sistpoty) wrote :

Yes, looks like you'll need input from ubuntu-release instead ;).

Side note, didn't openal sometimes silently introduce ABI breakage? Would be worth checking imho.

StefanPotyra (sistpoty) wrote :

(unsubscribing motu-release)

Reinhard Tartler (siretart) wrote :

oh, indeed, I forgot that openal is in main. (OTR, I think it shouldn't be, but anyways).

I think it is way to late to replace a library in main at this point of the cycle. I'd furthermore suggest to get it updated in debian first. there is not much point in creating that diversion here, since the debian games team is open for suggestions and help.

StefanPotyra (sistpoty) wrote :

Resubscribing motu-release, as this is about including a new package, not updating the existing one.

StefanPotyra (sistpoty) wrote :

Ok, I've taken a look at the package now.

I'm inclined to reject this bug for the following reasons: Modifying openal to depend on the openal library package or openal-soft is a gross hack which contradicts everything library packages should adhere to. The only way to make packages use of the openal-soft library is hence to rebuild these against it. And I'm not really in favour of doing this that late in the cycle. However only having the new library in hardy, with no package using it seems not to provide anything useful to me.

Cristian KLEIN (cristiklein) wrote :

StefanPotyra wrote:
> Ok, I've taken a look at the package now.
>
> I'm inclined to reject this bug for the following reasons: Modifying
> openal to depend on the openal library package or openal-soft is a gross
> hack which contradicts everything library packages should adhere to. The
> only way to make packages use of the openal-soft library is hence to
> rebuild these against it. And I'm not really in favour of doing this
> that late in the cycle. However only having the new library in hardy,
> with no package using it seems not to provide anything useful to me.

Hello,

I know it is a gross hack, but I was 100% sure that ubuntu-release would not
like to change to a new package this late in the release cycle. Therefore, I
have resorted to this solution which would:

a) basically not default to the not-so-tested package in Hardy
b) would allow beginners to have proper openal support in Hardy using a single
command
c) would allow more people to test the new package
d) hopefully make the shift to the new package more acceptable for the next
Ubuntu release

Reinhard Tartler (siretart) wrote :

Cristian KLEIN <email address hidden> writes:

> I know it is a gross hack, but I was 100% sure that ubuntu-release would not
> like to change to a new package this late in the release cycle. Therefore, I
> have resorted to this solution which would:

So how about providing it in a PPA?

> d) hopefully make the shift to the new package more acceptable for the
> next Ubuntu release

Please work in/with the Debian Games Team to get OpenAL Soft accepted
into debian. I don't think we should nor need diverge with Debian here.

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Scott Kitterman (kitterman) wrote :

N'ack for Hardy. As suggested please work through Debian and Ubuntu will get it for Ibex automatically.

Changed in openal:
status: New → Invalid
Robin (mobileforces) wrote :

This is the kind of decision that makes people go back to Windows.

Scott Kitterman (kitterman) wrote :

People often say things like that thinking it will motivate developers to
do something. In truth it's rather more likely to have the opposite effect.

Each Ubuntu release requires a balance between new features and risk. We
are currently dealing with an unfortunate volume of late toolchain and
library changes. We are already overloaded and unable to take on more.

I encourage you to take your passion to Debian and get it done there so
both distros benifit. We can facilitate that if needed.

Cristian KLEIN (cristiklein) wrote :

Scott Kitterman wrote:
> I encourage you to take your passion to Debian and get it done there so
> both distros benifit. We can facilitate that if needed.

Please do. Nobody responded to my mail to pkg-games-devel@ since 25 march.

Reinhard Tartler (siretart) wrote :

Cristian KLEIN <email address hidden> writes:

> Please do. Nobody responded to my mail to pkg-games-devel@ since 25
> march.

I had a private talk about this with a member of the games team. The
decision is not that easy, so nobody had enough courage up to now to
talk about this in public, but there is action behind the scenes...

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Cristian KLEIN (cristiklein) wrote :

Reinhard Tartler wrote:
> Cristian KLEIN <email address hidden> writes:
>
>> Please do. Nobody responded to my mail to pkg-games-devel@ since 25
>> march.
>
> I had a private talk about this with a member of the games team. The
> decision is not that easy, so nobody had enough courage up to now to
> talk about this in public, but there is action behind the scenes...

„The decision is not that easy” is a lame excuse IMHO. Why exactly do they have
„unstable” and „experimental” if not to test decisions. If everybody just
cowardly rejects openal-soft, then I foresee the following:

1) OpenAL-soft upstream won't get enough attention, upstream won't maintain it
anymore.
2) Linux won't stand a chance as a gaming platform, due to bad 3D sound libraries.

I don't know what Canonical's future plans are, but if they want to gain market
share, they will have to make Ubuntu a more attractive gaming platform.

Robin (mobileforces) wrote :
  • unnamed Edit (33 bytes, text/html; charset=ISO-8859-1)

That's the truth right there

Scott Kitterman (kitterman) wrote :

Unsubscribing motu-release and setting back to confirmed since this is no longer an FFe for Hardy.

Changed in openal:
status: Invalid → Confirmed
Reinhard Tartler (siretart) wrote :

Cristian KLEIN <email address hidden> writes:

> Why exactly do they have „unstable” and „experimental” if not to test
> decisions. If everybody just cowardly rejects openal-soft

Nobody rejects openal-soft. It will be included in ubuntu, but it is way
to late for hardy. Since we are working tightly together with debian
here, we'll publish the package there first. See the ubuntu developer
documentation for details on our processes.

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Changed in openal:
importance: Undecided → High
status: Confirmed → Invalid
status: Invalid → Confirmed
Changed in openal:
status: Unknown → New
Andres Mejia (amejia1) wrote :

Just so you know, this is being worked on in Debian. I'm waiting for someone to upload the openal-soft packages to the archive. You can try them out yourself.
- dget http://mentors.debian.net/debian/pool/main/o/openal-soft/openal-soft_1.3.253-1~experimental0.dsc

Since the openal SI upstream are considering the SI deprecated in favor of OpenAL Soft, the openal-soft packages will probably end up in Debian unstable soon afterwards.
http://opensource.creative.com/pipermail/openal-devel/2007-December/004977.html
http://opensource.creative.com/pipermail/openal/2008-February/010981.html
http://opensource.creative.com/pipermail/openal/2008-March/011019.html
http://opensource.creative.com/pipermail/openal/2008-April/011073.html

Either way, Ubuntu could sync from experimental or unstable.

Here's a few threads which have discussions about the openal-soft packages.
http://lists.debian.org/debian-devel-games/2008/04/msg00158.html
http://lists.debian.org/debian-devel-games/2008/05/msg00020.html

Cristian KLEIN (cristiklein) wrote :

Andres Mejia wrote:
> Just so you know, this is being worked on in Debian. I'm waiting for someone to upload the openal-soft packages to the archive. You can try them out yourself.
> - dget http://mentors.debian.net/debian/pool/main/o/openal-soft/openal-soft_1.3.253-1~experimental0.dsc

That's great news. I tested the above mentioned package and it works great!

Andres Mejia (amejia1) wrote :

The openal-soft packages have been reuploaded to mentors.debian.net. This adds a debug package and would also mean a direct upload to sid.
- dget http://mentors.debian.net/debian/pool/main/o/openal-soft/openal-soft_1.3.253-1.dsc

Dear Cristian KLEIN,
thank you for posting the "gross library hack". I know it's not the Debian/Ubuntu way, but I could cope with it, as long as OpenAL Soft is not officially
available through Debian/Ubuntu package system.

Unfortunately, I'm using the also-supported amd64 version of Ubuntu. Could you kindly create packages for this flavour too?
If you cannot compile for amd64, please instruct me how to generate the deb packages for you, I'll be glad to help.

Update:
Cristian, I managed to build your packages locally, by using dget and debuild. Still I was not able to sign them with your private key ;-)

OpenAL Soft is up, hacked and running right now :-D

Cristian KLEIN (cristiklein) wrote :

alfredio wrote:
> Update:
> Cristian, I managed to build your packages locally, by using dget and debuild. Still I was not able to sign them with your private key ;-)
>
> OpenAL Soft is up, hacked and running right now :-D
>

Great to know my worked helped somebody. I personally, don't like my solution
and I just pushed it this way in hope that it might get into Hardy.

I would rather use the package from the previous post, then override openal0a's
libopenal.so.0.0.0 with a symlink to libopenal.so.1.

> I would rather use the package from the previous post, then override openal0a's
> libopenal.so.0.0.0 with a symlink to libopenal.so.1.

I believe this would not work. This hack would break every time a new package is installed, because ldconfig is run after each run of the package manager, thus changing
the hacked symlinks (I had this problem, this is why I used your "gross hack")

I know your packages are NOT the solution. They are a workaround, until the library is not going to be officially supported in Ubuntu.

The Fiddler (stapostol) wrote :

Are there any news on this from the Debian and/or Ubuntu side? Intrepid still contains the broken packages...

Changed in openal:
status: New → Fix Committed
Changed in openal:
status: Fix Committed → Fix Released
Fabrice Coutadeur (fabricesp) wrote :

Hi,

Do you confirm that Intrepid still contains broken package?

When doing a rdepends on libopenal1, I get a lot of games:
(intrepid)fabrice@fabrice-desktop:~/temp/u2nl-1.3$ apt-cache rdepends libopenal1
libopenal1
Reverse Depends:
  tremulous
  mplayer-nogui
  mplayer
  glest
  funguloids
  xpilot-ng-client-x11
  xpilot-ng-client-sdl
  warzone2100
  vegastrike
  trigger
  torcs
  supertuxkart
  supertux
  simgear1.0.0
  scorched3d
  python-soya
  python-openal
  openarena
  libsfml-audio1
  libosgal1
  libopenal1-dbg
  libopenal-dev
  libalut0
  flightgear
  chromium
  btanks
  blender
  antigravitaattori

So it seems that this bug can be close with Intrepid.

Changed in openal:
status: Confirmed → Incomplete
Cesare Tirabassi (norsetto) wrote :

openal-soft (1:1.3.253-4ubuntu1) intrepid; urgency=low

  [ Andres Mejia ]
  * Exclude libasound2-dev dependency for kfreebsd and hurd kernels.
  * Bumped to Standards-Version 3.8.0 (no changes required).
  * Add watch file.

  [ Reinhard Tartler ]
  * reenable building of libopenal-dev.
  * prerelease upload to intrepid.

 -- Reinhard Tartler <email address hidden> Sun, 29 Jun 2008 10:32:20 +0200

Changed in openal:
status: Incomplete → Fix Released
Robin (mobileforces) wrote :
Mikko Saarinen (mikk0) wrote :

So is this fixed for good?

Me (and others) have sound problems in Jaunty too. Namely supertuxkart and other games sound terrible and have performance issues as well. Could this be related to this bug?
The games used to work in Intrepid.

Bug 385013: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/385013
Forums: http://ubuntuforums.org/showthread.php?t=1125214

I would appreciate your comments,
Mikko

Robin (mobileforces) wrote :

OpenAL Soft is probably not where your problem lies, no.

prower2000 (prower2000) wrote :

I'm experiencing the same issues with "crackling sound" in FlightGear using Karmic, I have an Intel HDA-based on-board chip for sound. I've seen the same issue in most other games using OpenAL that I've tried as well, so I doubt it's just a problem with FlightGear in Karmic. I think this needs to be re-examined.

Robin (mobileforces) wrote :

OpenAL Soft 1.10 is just released

Konrad (konradmb) wrote :

I also experience this problem with flightgear and karmic koala 9.10 ubuntu. This must be integrated with distro !

David Robert Lewis (afrodeity) wrote :

Apparently the problem is fixed with an ALSA upgrade http://monespaceperso.org/blog-en/2009/10/29/upgrade-alsa-1-0-21-on-ubuntu-karmic-koala-9-10/. Ihaven't tried this yet because I don't want to touch my pulseaudio installation. Waiting for an official release via Synaptic.

Is http://kcat.strangesoft.net/openal-releases/openal-soft-1.5.304.tar.bz2 recommended fix then?

Konrad (konradmb) wrote :

Yes, openal-soft fixed this horrible sound, but alsa has not updates in karmic-proposed .

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.