open-vm-dkms doesn't detect vmxnet and vsock properly during install

Bug #836277 reported by Nate Muench (Mink) on 2011-08-28
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
open-vm-tools (Ubuntu)
Medium
Nate Muench (Mink)

Bug Description

I'm in the process of getting the August release ready, but I just wanted to get a few things out the way first.

I'm using Ubuntu Oneiric Alpha 3, and I'm using open-vm-tools from the Main Oneiric Repo. During the install, I get some warnings during the DKMS install stage (It's dated but it's still there).

Loading new open-vm-tools-2011.07.19 DKMS files...
make: *** vmxnet: No such file or directory. Stop.
make: *** vsock: No such file or directory. Stop.
First Installation: checking all kernels...
Building only for 3.0.0-7-generic
Building for architecture i686
Building initial module for 3.0.0-7-generic
make: *** vmxnet: No such file or directory. Stop.
make: *** vsock: No such file or directory. Stop.

I know it's dated, but I was hoping that this was a bug in the source packaging, but it isn't (because it's gotten worse in the August packaging).

After using Google to find a solution (using the generic query "No such file or directory. Stop."), I have found that this is an issue with the 3.0.0 kernel (I think, the results pointed to a kernel issue)

I'm looking for a patch for the open-vm-tools packaging.

Dave Walker (davewalker) wrote :

Thanks Nate for looking into this. A number of packages had to have fixes which rely on '2.6' being the kernel version, so it would not surprise me if if this one of them.

Changed in open-vm-tools (Ubuntu):
importance: Undecided → Medium
Nate Muench (Mink) (n-muench) wrote :

Good, I had a feeling that it might be the kernel.

Also, I still am planning on pushing the August release (correctly this time). There's an issue, that I might have fixed, but I'm not sure.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in open-vm-tools (Ubuntu):
status: New → Confirmed

There is a typing error in the dkms.conf file. See the attached patch.

The attachment "open-vm-dkms_conf.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Benjamin Reid (benjamin-reid) wrote :

I'm curious on the status of this bug; it shows as Unassigned still;

The issue isn't fix in oneiric yet;

I ended up repackaging open-vmtools myself with the patch Ronny Kotzschmar provided to resolve my issue.

Thanks Ronny :)

Changed in open-vm-tools (Ubuntu):
assignee: nobody → Nate Muench (Mink) (n-muench)
status: Confirmed → Fix Committed
Nate Muench (Mink) (n-muench) wrote :

I forgot this existed. I backported the dkms patch from Precise, but I need someone to please create the oneiric-proposed branch. I am unable to make a request for a merge until oneiric-proposed actually exists.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers