Ubuntu

open-vm-source doesn't build

Reported by Stefan Soriga on 2008-10-05
34
This bug affects 2 people
Affects Status Importance Assigned to Milestone
VMWare tools
Unknown
Unknown
open-vm-tools (Ubuntu)
High
Unassigned
Nominated for Karmic by erlguta
Intrepid
Undecided
Unassigned
Jaunty
High
Unassigned

Bug Description

Binary package hint: open-vm-source

1) root@ubuntu:~# lsb_release -rd
Description: Ubuntu intrepid (development branch)
Release: 8.10

2)root@intrepid:~# apt-cache policy open-vm-source
open-vm-source:
  Installed: 2008.08.08-109361-1ubuntu1
  Candidate: 2008.08.08-109361-1ubuntu1
  Version table:
 *** 2008.08.08-109361-1ubuntu1 0
        500 http://us.archive.ubuntu.com intrepid/multiverse Packages
        100 /var/lib/dpkg/status

3) m-a build open-vm-source
 I expected to build and after to install using m-a install open-vm-source.
 The dependencies were installed using m-a vm-tools / prepare

4) In file included from /usr/src/modules/open-vm/modules/linux/vmci/vmci_kernel_if.h:43,
                 from /usr/src/modules/open-vm/modules/linux/vmci/vmciDatagram.c:45:
/usr/src/modules/open-vm/modules/linux/vmci/compat_semaphore.h:23:27: error: asm/semaphore.h: No such file or directory
make[5]: *** [/usr/src/modules/open-vm/modules/linux/vmci/vmciDatagram.o] Error 1
make[4]: *** [_module_/usr/src/modules/open-vm/modules/linux/vmci] Error 2
make[4]: Leaving directory `/usr/src/linux-headers-2.6.27-4-server'
make[3]: *** [vmci.ko] Error 2
make[3]: Leaving directory `/usr/src/modules/open-vm/modules/linux/vmci'
make[2]: *** [build] Error 2
make[2]: Leaving directory `/usr/src/modules/open-vm'
make[1]: *** [binary-modules] Error 2
make[1]: Leaving directory `/usr/src/modules/open-vm'
make: *** [kdist_build] Error 2

Stefan Soriga (sgstefan) on 2008-10-05
description: updated
Stefan Soriga (sgstefan) wrote :

In hardy this packet doesn't exist anymore because of alpha quality issues. Why is it present in intrepid then?

Changed in open-vm-tools:
status: New → Invalid
Sven Hartge (svenhartge) wrote :

I wonder if Intrepid is going to be released with this version of open-vm-tools, which cannot compiled with the release kernel?

In the current state, this package is unusable and broken and should either be fixed or removed.

Dan (danser) wrote :

The open-vm-source package has been included in Intrepid, and does fail to build, so the bug still stands.

hseffler (hseffler) wrote :

Oh, nice. The vmware-tools from ESX do not build and neither does open-vm-source that actually comes with 8.10....

/usr/local/dick (dick-tienhuis) wrote :

cd /us/src
tar xvfj open-vm.tar.bz2
perl -pi -e 's/#include\ <asm\/semaphore.h>//g' $(find /usr/src/modules/open-vm)
rm open-vm.tar.bz2
tar cvfj open-vm.tar.bz2 modules

Now the module do compile

Nick Barcet (nijaba) wrote :

I think this is an easy SRU fix.

Changed in open-vm-tools:
importance: Undecided → High
status: Invalid → Triaged
Didier Roche (didrocks) on 2008-11-02
Changed in open-vm-tools:
assignee: nobody → didrocks
Didier Roche (didrocks) wrote :

Hum, I do not have any issue to compile it in my intrepid up-to-date pbuilder chroot.
Does anybody can confirm that this problem still exists for him?

Didier Roche (didrocks) on 2008-11-02
Changed in open-vm-tools:
status: Triaged → Incomplete
Nick Barcet (nijaba) wrote :

Didier: the problem does not occur when building the package, but when building the kernel module using module assistant following the procedure in /usr/share/doc/open-vm-source/README.Debian

Changed in open-vm-tools:
status: Incomplete → Triaged

There's a clean patch for this problem available in the upstream open-vm-tools bug tracker:
http://sourceforge.net/tracker/index.php?func=detail&aid=2071170&group_id=204462&atid=989708

Or a direct link to the patch:
http://downloads.sourceforge.net/open-vm-tools/open-vm-tools-2008.08.08-2.6.27.kernels.patch

This should apply cleanly to the 2008.08.08 release, which Intrepid is using.

Dan (danser) wrote :

This debdiff incorporates the upstream patch, and the resulting open-vm-source builds successfully here.

Didier Roche (didrocks) wrote :

Dan, if you think that your debdiff is correct, please assign u-u-s (cf https://wiki.ubuntu.com/SponsorshipProcess) to get it reviewed and sponsored

Changed in open-vm-tools:
assignee: didrocks → nobody
Chuck Short (zulcss) wrote :

If this is for intrepid then it *really* has to follow the SRU process.

Please see https://wiki.ubuntu.com/StableReleaseUpdates.

Dan (danser) wrote :

Requesting sponsorship for the above debdiff -- this fixes the problem for me, and the resulting modules work as expected (although it is particularly affected by #297215). If my understanding of SRU is correct, we need to get this fix tested in Jaunty before we can release it for Intrepid.

Jaunty has a newer version which is unaffected. This simply needs to be fixed via SRU in intrepid.

Changed in open-vm-tools:
status: Triaged → Fix Released

Any sponsors out there listening? Dan requested sponsorship for his bug fix 10 days ago and it doesn't look like there's been any action towards getting the package fixed since. This bug renders open-vm-source unusable on Intrepid, so it would be really nice to see it fixed.

In an effort to make some forward progress, I'm going to reassign to u-u-s (as recommended by Didier), though I'm not sure if that's the correct procedure.

Changed in open-vm-tools:
assignee: nobody → ubuntu-universe-sponsors
status: New → In Progress
Chuck Short (zulcss) wrote :

Hi,

I uploaded it but not the way it is was at first. Since intrepid has closed it has to go into proposed, as well as the version number was wrong since this is an SRU.

Regards
chuck

Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in open-vm-tools:
status: In Progress → Fix Committed

Works for me, thanks (using a Workstation 6.5 host).

I've found a few other issues, but I'll file separate bug reports for them.

Ruben Laban (r-laban) wrote :

Works for me as well (ESXi 3.5 host).

Now it is uploaded, we can remove Ubuntu Sponsors for universe for affected / subscriptions.

Changed in open-vm-tools:
assignee: ubuntu-universe-sponsors → nobody

changing the tag as it hs been verified by two persons.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package open-vm-tools - 2008.08.08-109361-1ubuntu2.1

---------------
open-vm-tools (2008.08.08-109361-1ubuntu2.1) intrepid-proposed; urgency=low

  * Upstream patch to make open-vm-source compatible with Intrepid's kernel (LP: #278711)

 -- Dan Sheridan <email address hidden> Wed, 12 Nov 2008 12:11:47 +0000

Changed in open-vm-tools:
status: Fix Committed → Fix Released
erlguta (gonzalomarcote) wrote :

This bug still persist in Karmic.
m-a fails to build modules.

# dpkg -l opnen-vm-source

ii open-vm-source 2009.07.22-179896-2 Source for VMware guest systems driver

# uname -a
Linux denese 2.6.31-14-generic-pae #48-Ubuntu SMP Fri Oct 16 15:22:42 UTC 2009 i686 GNU/Linux

I also attach m-a log file:
open-vm-source.buildlog.2.6.31-14-generic-pae.1256898385

I think this is important to be fixed before 10.4 LTS version in server for VM machines with vmware.
We have several VM server machines with 8.04 and open-vm installed in my company. That machines can not be upgraded to the LTS, as without these modules for vmware-tools will not suspend properly, besides other interesting features (like time synchronize, etc).

erlguta (gonzalomarcote) wrote :

Please, REOPEN this bug in karmic. I repeat open-vm modules does not compile in karmic kernels. It is very problematic for the virtualized servers i mantain in my company.
I think it should be solved before Lucid.

Martin Pitt (pitti) on 2010-02-17
Changed in open-vm-tools (Ubuntu):
status: Fix Released → Confirmed
erlguta (gonzalomarcote) wrote :

This problem seems to have been resolved in Lucid and compile open-vm correctly.

Martin Pitt (pitti) on 2010-04-23
Changed in open-vm-tools (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.