open-vm-tools 11.1.0 released

Bug #1877672 reported by Oliver Kurth on 2020-05-08
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
open-vm-tools (Debian)
Fix Released
Unknown
open-vm-tools (Ubuntu)
Medium
Christian Ehrhardt 
Focal
Medium
Christian Ehrhardt 

Bug Description

[Impact]

 * In the past a lack of updated open-vm-tools versions was found fatal
   and therefore we agreed to regularly backport those to the latest LTS.
   This is backporting the recent version 11.1 to Focal.

[Test Case]

 * Test open-vm-tools done by VMWare QA Team as agreed for these
   backports.

[Regression Potential]

 * This has the usual regression potential of a new version upgrade and
   therefore is higher than a usual SRU. But as agreed int he past to
   support new (virtual) hardware open-vm-tools shall regularly be
   backported. I suggest keeping it somewhat longer in proposed than usual
   just to be on the safe side.

[Other Info]

 * This is a practice for or quite a while (almost two years now), see:
   - https://bugs.launchpad.net/ubuntu/+source/open-vm-tools/+bug/1741390
   - https://bugs.launchpad.net/ubuntu/+source/open-vm-tools/+bug/1784638
   - https://bugs.launchpad.net/ubuntu/+source/open-vm-tools/+bug/1813944
   - https://bugs.launchpad.net/ubuntu/+source/open-vm-tools/+bug/1822204
   - https://bugs.launchpad.net/ubuntu/+source/open-vm-tools/+bug/1844834
   - https://bugs.launchpad.net/ubuntu/+source/open-vm-tools/+bug/1868012

The request back then came from the community and the decision back then was between VMWare and Ubuntu. VMWare QA Team since then does the qualification of these uploads as we (I) don't have a matrix of Host versions for that around.

Under the accepted special SRU cases [1] this qualifies for #2 and #3 of [2].

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Documentation_for_Special_Cases
[2]: https://wiki.ubuntu.com/StableReleaseUpdates#Other_safe_cases

---

We have released open-vm-tools 11.1.0.

See https://github.com/vmware/open-vm-tools/releases/tag/stable-11.1.0

See also at Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=960061

tags: added: upgrade-software-version
Changed in open-vm-tools (Debian):
status: Unknown → New

Thank you Oliver,
it will take some time as we always let it mature in the current -dev release a while but as usual we will later on also backport this to the latest LTS therefore I'm adding a focal task right away.

The package is currently in sync, so I'd wait for Bernd to bump this in Debian unless this is more urgent (as we are only at the beginning of the groovy cycle).

@bzed - I know you usually see these bugs, if you need help to prep this in Debian let me know.

Changed in open-vm-tools (Ubuntu Focal):
status: New → Triaged
importance: Undecided → Medium
Changed in open-vm-tools (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in open-vm-tools (Ubuntu):
assignee: nobody → Christian Ehrhardt  (paelzer)
Changed in open-vm-tools (Ubuntu):
status: Triaged → In Progress

FYI - Still waiting on Debian to find the time on the MPs.

It would be nice to get this done until ~mid June to then do the LTS backports for 20.04 before 20.04.1 will be released ~mid July. This is still fine atm and the timing should be ok, no need to rush anyone.

FYI - my MPs were accepted and currently wait in Debian NEW-queue

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package open-vm-tools - 2:11.1.0-2

---------------
open-vm-tools (2:11.1.0-2) unstable; urgency=medium

  [ Christian Ehrhardt ]
  * [4d69c6a] d/p/lp-1877678-: fixes for the sdmp plugin that is new in 11.1.0.
    Signed-off-by: Christian Ehrhardt <email address hidden>
  * [38bd11e] d/control: change net-tools dependency to iproute2.
    Signed-off-by: Christian Ehrhardt <email address hidden>

  [ Bernd Zeimetz ]
  * [c15c08d] Add net-tools as dependency again.
    Various scripts still use ifconfig.

 -- Bernd Zeimetz <email address hidden> Fri, 19 Jun 2020 14:05:44 +0200

Changed in open-vm-tools (Ubuntu):
status: In Progress → Fix Released
Changed in open-vm-tools (Debian):
status: New → Fix Released
Changed in open-vm-tools (Ubuntu Focal):
assignee: nobody → Christian Ehrhardt  (paelzer)
tags: added: server-next
description: updated

Uploaded to focal-unapproved for the SRU Team to take a look at it.

Hello Oliver, or anyone else affected,

Accepted open-vm-tools into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/open-vm-tools/2:11.1.0-2~ubuntu20.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in open-vm-tools (Ubuntu Focal):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-focal
vmware-gos-Yuhua (yhzou) wrote :

Hi all,
   It works well when do sanity check for open-vm-tools 10.1.0 from repository focal-proposed

   Check in
    Ubuntu-20.04-Desktop-amd64
    ubuntu-20.04-live-server-amd64

   Check items:
    1) install / upgrade /uninstall open-vm-tools
    2) check tools service and VGAuth services when install / upgrade open-vm-tools
    3) check tools service and VGAuth services after install / upgrade and reboot guestOS
uninstall open-vm-tools 10.1.0
    4) check ip address, OS full name, sync hosttime after install open-vm-tools
    5) install/uninstall package open-vm-tools-desktop in Ubuntu-20.04-Desktop

vmware-gos-Yuhua (yhzou) wrote :

Hi all,
   It works well when do sanity check for open-vm-tools 11.1.0 from repository focal-proposed

   Check in
    Ubuntu-20.04-Desktop-amd64
    ubuntu-20.04-live-server-amd64

   Check items:
    1) install / upgrade /uninstall open-vm-tools
    2) check tools service and VGAuth services when install / upgrade open-vm-tools
    3) check tools service and VGAuth services after install / upgrade and reboot guestOS
uninstall open-vm-tools 11.1.0
    4) check ip address, OS full name, sync hosttime after install open-vm-tools
    5) install/uninstall package open-vm-tools-desktop in Ubuntu-20.04-Desktop

Thanks for the testing, marking this verified.
I also see that you have started the explicit tests on the sdmp plugin - thanks.

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package open-vm-tools - 2:11.1.0-2~ubuntu20.04.1

---------------
open-vm-tools (2:11.1.0-2~ubuntu20.04.1) focal; urgency=medium

  * Update to latest release v11.1.0 (LP: #1877672)
    - among many fixes this also brings the sdmp plugin (LP: #1877678)
    - fixes upgrade issues due to bad package versions (LP: #1884483)
    - Revert "Add net-tools as dependency again." as we don't want to
      modify the focal seed/ISO content without a real issue behind it.

open-vm-tools (2:11.1.0-2) unstable; urgency=medium

  [ Christian Ehrhardt ]
  * [4d69c6a] d/p/lp-1877678-: fixes for the sdmp plugin that is new in 11.1.0.
    Signed-off-by: Christian Ehrhardt <email address hidden>
  * [38bd11e] d/control: change net-tools dependency to iproute2.
    Signed-off-by: Christian Ehrhardt <email address hidden>

  [ Bernd Zeimetz ]
  * [c15c08d] Add net-tools as dependency again.
    Various scripts still use ifconfig.

open-vm-tools (2:11.1.0-1) unstable; urgency=medium

  [ Christian Ehrhardt ]
  * [6b7d31d] New upstream version 11.1.0
    (Closes: #960061) (LP: #1877672)
  * [3ece93a14] d/control, d/rules, d//*sdmp*: add service discovery plugin (sdmp)
    (Closes: #960065) (LP: #1877678)
    Thanks to Oliver Kurth for the initial contribution, changes in addition:
    - d/control: improve description
    - rules fix whitespace damage
    - maintscripts: fixed some whihtespace damage
    - maintscripts: fixed maintainer scripts per skeletons from dh_make
    - maintscripts: added the service-active-before-restart check to postinst
      as well (was only in rm)
    - maintscripts: use deb-systemd-invoke
    - d/control: add further dependencies used in sdmp
  * [e0c9fbc14] remove patches applied upstream in 11.1.0
    - d/p/4ee0bd3c8_Rectify-a-log-spew-in-vmsvc-logging-vmware-vmsvc-root.log
    - d/p/89c0d4445_GitHub-Issue-367.-Remove-references-to-deprecated-G_INLINE_FUNC
    - d/p/f1f0b812e_add-appinfo-plugin
  * [f4cf14931] d/rules: drop perm fixup of vm-support as it is properly
    in /usr/bin/ now
  * [d71e99e33] lintian: add overrides for intentional cases
  * [ba27a73eb] d/p/debian/vmxnet_fix_kernel_4.7.patch: drop unused patch
  * [7488e6e2f] d/copyright: fix tab in text

 -- Christian Ehrhardt <email address hidden> Mon, 22 Jun 2020 08:40:58 +0200

Changed in open-vm-tools (Ubuntu Focal):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for open-vm-tools has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Hello Oliver, or anyone else affected,

Accepted open-vm-tools into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/open-vm-tools/2:11.1.5-1~ubuntu20.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in open-vm-tools (Ubuntu Focal):
status: Fix Released → Fix Committed
tags: added: verification-needed verification-needed-focal
removed: verification-done verification-done-focal

I had a wrong bug reference - sorry my bad for disturbing this old bug.
I'll have it overwritten in -proposed with a fixed upload.
Let me set this one here back to Released.

Changed in open-vm-tools (Ubuntu Focal):
status: Fix Committed → Fix Released
tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
vmware-gos-Yuhua (yhzou) wrote :

It works well when do sanity check for open-vm-tools 11.1.5 from repository focal-proposed

   Check in
    1)Ubuntu 20.04.1 Desktop
    2)Ubuntu 20.04.1 Live Server

   Check items:
    1) install / uninstall open-vm-tools
    2) check tools service and VGAuth services when install open-vm-tools
    3) check tools service and VGAuth services after install and reboot guestOS
    4) check ip address, OS full name, sync hosttime after install open-vm-tools
    5) uninstall open-vm-tools 11.1.5
    6) install/uninstall package open-vm-tools-desktop in Ubuntu 20.04.1 Desktop

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.