incorrect tools.conf template is shipped with Ubuntu

Bug #1748122 reported by Dariusz Gadomski on 2018-02-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
VMWare tools
Fix Released
Unknown
open-vm-tools (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Dariusz Gadomski
Xenial
Undecided
Dariusz Gadomski
Artful
Undecided
Dariusz Gadomski

Bug Description

[Impact]

 * The default tools.conf template shipped with the Ubuntu package is useless - it gets cleared on the first run as it contains an unrecognized content.

[Test Case]

 * Install open-vm-tools.
 * Check contents of /etc/vmware-tools/tools.conf.
 * Start vmtoolsd service e.g. by systemctl start open-vm-tools.
 * Check tools.conf contents again.

Expected result:
Config is read an left untouched.

Actual result:
Config file is cleared.

[Regression Potential]

 * If any of the parameters in the template is set to a non-default value
the behaviour of vmtoolsd may change slightly (e.g. different log verbosity, log target - file vs. syslog).
   But people will get the usual conffile changed prompts, so those who modified it will have to consciously decide which makes it safe.

[Other Info]

 * Original bug description:

The tools.conf template shipped with Ubuntu (debian/local/tools.conf) is incorrect.

It's current contents:
bindir = "/usr/bin"
do not mean anything to open-vm-tools - it's not interpreted in any way by vmtoolsd.

Moreover, on the first launch this content is cleared by a piece of code doing a "config upgrade".

I believe replacing it with a more meaningful content is necessary.

tags: added: sts
Dariusz Gadomski (dgadomski) wrote :

A more useful example based on the comment in open-vm-tools/lib/include/vmware/tools/log.h.

description: updated

I see your debian bug and assume that should be the change, but here gnome-themes-standard ?

Changed in open-vm-tools:
status: Unknown → New
Dariusz Gadomski (dgadomski) wrote :

This time the correct patch attached.

Dariusz Gadomski (dgadomski) wrote :

Thanks for noticing that, wrong debdiff attached. Sorry about that.

Thanks for he patch and it is indeed what you provided to Debian.
I'd prefer to stay synced if possible.

Could you watch if Debian reacts to your report (then it will auto sync and fix it here as well)?
If they do not respond in lets say two weeks, please reach out to me and we get it sponsored before the feature freeze.

Dariusz Gadomski (dgadomski) wrote :

Of course. I will do that.

Thanks Christian!

Dariusz Gadomski (dgadomski) wrote :

Christian, debian has merged the proposal [1].

I believe we're good to merge it to Ubuntu.

Thanks!

[1] https://github.com/bzed/pkg-open-vm-tools/commit/34538a58a8ed705e09f0dcf8c1627319efba49fd

We now just wait for Debian to do the next upload.
This will still be autosynced and get fixed then.

You might ask on your bug report if the maintainer has a date for the next upload in mind.
You might even let him know that you'd appreciate if that could be before the Debian import freeze on [1].

[1]: https://wiki.ubuntu.com/BionicBeaver/ReleaseSchedule

2:10.2.0-3 has the right fix and is migrated in bionic.

Changed in open-vm-tools (Ubuntu):
status: New → Fix Released
Dariusz Gadomski (dgadomski) wrote :

SRU proposal for Trusty.

Dariusz Gadomski (dgadomski) wrote :

SRU proposal for Xenial.

Dariusz Gadomski (dgadomski) wrote :

SRU proposal for Artful.

Changed in open-vm-tools (Ubuntu Trusty):
status: New → In Progress
Changed in open-vm-tools (Ubuntu Xenial):
status: New → In Progress
Changed in open-vm-tools (Ubuntu Artful):
status: New → In Progress
Changed in open-vm-tools (Ubuntu Trusty):
assignee: nobody → Dariusz Gadomski (dgadomski)
Changed in open-vm-tools (Ubuntu Xenial):
assignee: nobody → Dariusz Gadomski (dgadomski)
Changed in open-vm-tools (Ubuntu Artful):
assignee: nobody → Dariusz Gadomski (dgadomski)
description: updated

Artful doesn't apply - in artful is 2:10.1.10-3 not 2:10.0.7-3227872-5ubuntu1~16.04.1 as the debdiff assumes.

The other two are good, I'm waiting with sponsoring until all three debdiffs match.

Actually I think the versions also need cleanup in general.
This is a normal bugfix - it is not making the same version available in multiple releases.
So following beloved [1] it should be:
Artful 2:10.1.10-3 -> 2:10.1.10-3ubuntu0.1

X and T already had updates, so you correctly bumped the last part of the version in those.

I can fix all that for you on upload.

[1]: https://wiki.ubuntu.com/SecurityTeam/UpdatePreparation

Fixed on upload as mentioned.
In the approval queue for the SRU Team now.

Changed in open-vm-tools:
status: New → Fix Released

Hello Dariusz, or anyone else affected,

Accepted open-vm-tools into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/open-vm-tools/2:10.1.10-3ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in open-vm-tools (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-artful
Changed in open-vm-tools (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
Brian Murray (brian-murray) wrote :

Hello Dariusz, or anyone else affected,

Accepted open-vm-tools into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/open-vm-tools/2:10.0.7-3227872-5ubuntu1~16.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in open-vm-tools (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed-trusty
Brian Murray (brian-murray) wrote :

Hello Dariusz, or anyone else affected,

Accepted open-vm-tools into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/open-vm-tools/2:9.4.0-1280544-5ubuntu6.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Dariusz Gadomski (dgadomski) wrote :

Managed to successfully verify the following:
artful - 2:10.1.10-3ubuntu0.1 - OK
xenial - 2:10.0.7-3227872-5ubuntu1~16.04.2 - OK

tags: added: verification-done-artful verification-done-xenial
removed: verification-needed-artful verification-needed-xenial
Dariusz Gadomski (dgadomski) wrote :

Turns out Trusty config requires a path to logfile explicitly stated in tools.conf as there is no code for figuring out a default path in that version.

Uploading new SRU proposal for Trusty.

Changed in open-vm-tools (Ubuntu Trusty):
status: Fix Committed → In Progress
tags: added: verification-failed-trusty
removed: verification-needed-trusty

Sponsored with some minor cleanups to ensure it is clear where this change belongs to.
Note: build with -v<old> to get both changelogs processed on SRU release eventually.

@SRU team - this shall upload the current one in trusty proposed.

Robie Basak (racb) wrote :

Hello Dariusz, or anyone else affected,

Accepted open-vm-tools into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/open-vm-tools/2:9.4.0-1280544-5ubuntu6.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in open-vm-tools (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed-trusty
removed: verification-failed-trusty
Dariusz Gadomski (dgadomski) wrote :

Verified
Trusty 2:9.4.0-1280544-5ubuntu6.4.

Works as expected.

tags: added: verification-done verification-done-trusty
removed: verification-needed verification-needed-trusty
tags: removed: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package open-vm-tools - 2:10.1.10-3ubuntu0.1

---------------
open-vm-tools (2:10.1.10-3ubuntu0.1) artful; urgency=medium

  * Make tools.conf template useful. (LP: #1748122)

 -- Dariusz Gadomski <email address hidden> Thu, 15 Feb 2018 11:22:29 +0100

Changed in open-vm-tools (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for open-vm-tools has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package open-vm-tools - 2:10.0.7-3227872-5ubuntu1~16.04.2

---------------
open-vm-tools (2:10.0.7-3227872-5ubuntu1~16.04.2) xenial; urgency=medium

  * Make tools.conf template useful. (LP: #1748122)

 -- Dariusz Gadomski <email address hidden> Thu, 15 Feb 2018 11:19:17 +0100

Changed in open-vm-tools (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package open-vm-tools - 2:9.4.0-1280544-5ubuntu6.4

---------------
open-vm-tools (2:9.4.0-1280544-5ubuntu6.4) trusty; urgency=medium

  * d/local/tools.conf: Explicitly point to logfile in tools.conf
    fixup for (LP 1748122).

open-vm-tools (2:9.4.0-1280544-5ubuntu6.3) trusty; urgency=medium

  * Make tools.conf template useful. (LP: #1748122)

 -- Dariusz Gadomski <email address hidden> Tue, 20 Feb 2018 14:01:55 +0100

Changed in open-vm-tools (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.