vmhgfs-fuse to open-vm-tools package

Bug #1551558 reported by Jukka Kangas on 2016-03-01
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
open-vm-tools (Ubuntu)
Medium
Unassigned

Bug Description

Hi,

Vmhgfs-fuse is in the open-vm-tools-desktop package, thus forcing installing a lot of unnecessary packages to server environment. Can this be included in the open-vm-tools -package?

Description: Ubuntu Xenial Xerus (development branch)
Release: 16.04

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in open-vm-tools (Ubuntu):
status: New → Confirmed
tags: added: dependencies xenial
tags: added: packaging
Changed in open-vm-tools (Ubuntu):
importance: Undecided → Medium
AdlerHorst (adlerhorst) wrote :

I installed the open-vm-tools and a

udo mount -t hgfs .host:/ /mnt/hgfs

ends in

mount: unknown filesystem type 'vmhgfs'

Distributor ID: Ubuntu
Description: Ubuntu Xenial Xerus (development branch)
Release: 16.04
Codename: xenial

danand (danandand) wrote :

Hi all,

I'm in agreement with the fact that vmhgfs-fuse is part of the wrong package. Having to install a bunch of desktop/X Windows packages just to be able to used shared folders under VMware Workstation/Fusion is certainly less than ideal.

However, I am against including vmhgfs-fuse in the open-vm-tools package as this would mean installing unnecessary binaries within VM guests running on non Workstation/Fusion systems. Clearly there is no need for vmhgfs-fuse within a VM running on top of VMware ESXi as ESXi has no need for, or concept of shared folders.

As such, could we instead break out vmhgfs-fuse (and any additional deps from the open-vm-tools-desktop package) into a completely separate package? This seems to make the most sense to me and would give everyone the ability to install the tools they need without any additional cruft!

Perhaps a name change would be in order as well? To the uninitiated 'vmhgfs-fuse' doesn't really tell you what the package does or give any clue as to its intended use. Perhaps 'open-vm-tools-shared-folders' would be better albeit a little long...

Andrij Abyzov (drolevar) wrote :

I have managed to have hgfs auto-mounted by adding the following line to /etc/fstab:

.host:/ /mnt/hgfs fuse.vmhgfs-fuse allow_other,uid=1000,gid=1000,auto_unmount,users,defaults 0 0

Not sure all of it is necessary, but at least it works. Also I think it should be mentioned in Ubuntu FAQ somewhere.

Tong Sun (suntong001) wrote :

@drolevar,

Could you elaborate a bit how you get hgfs auto-mounted please?

The following is what I did to my freshly insalled Ubuntu 16.04 LTS:

apt-get -y install open-vm-tools
apt-get -y install open-vm-tools-desktop

echo '.host:/ /mnt/hgfs fuse.vmhgfs-fuse allow_other,uid=1000,gid=1000,auto_unmount,users,defaults 0 0' \
 | tee -a /etc/fstab

but when I tried to mout it, I get the bad superblock error

mount: wrong fs type, bad option, bad superblock on .host:/,
       missing codepage or helper program, or other error

when I tried to reboot, the system get into maintenance mode because some vmhgfs module failed to load.

Thanks

Tong Sun (suntong001) wrote :

+1

Agree that the Vmhgfs-fuse should be moved out from the open-vm-tools-desktop package, into the open-vm-tools package, or standalone.

Tong Sun (suntong001) wrote :

got hgfs auto-mounted now, exactly as @drolevar said.

What I've missed previously is that the Vmhgfs-fuse *should* depends on fuse (obviously), but that dependent is not define in the package thus *not* installed automatically.

Till Kolditz (lolmegafroi) wrote :

+1

On Windows10 host and Ubuntu 16.04.02 LTS guest with only open-vm-tools*** packages installed and kernel 4.8.0-34-generic, the same problem was solved by the fix from @drolevar

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers