open-vm-tools-dkms fails to build on kernel 4.2 (Wily Werewolf) [error: implicit declaration of function ‘nd_set_link’]

Bug #1500581 reported by dc on 2015-09-28
272
This bug affects 69 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
High
Unassigned
open-vm-tools (Debian)
Fix Released
Unknown
open-vm-tools (Ubuntu)
High
Robert C Jennings
Wily
Undecided
Unassigned

Bug Description

/var/lib/dkms/open-vm-tools/9.10.2/build/vmhgfs/link.c:59:21: warning: initialization from incompatible pointer type [-Wincompatible-pointer-types]
    .follow_link = HgfsFollowlink,
                     ^
/var/lib/dkms/open-vm-tools/9.10.2/build/vmhgfs/link.c:59:21: note: (near initialization for ‘HgfsLinkInodeOperations.follow_link’)
/var/lib/dkms/open-vm-tools/9.10.2/build/vmhgfs/link.c:61:21: warning: initialization from incompatible pointer type [-Wincompatible-pointer-types]
    .put_link = HgfsPutlink,
                     ^
/var/lib/dkms/open-vm-tools/9.10.2/build/vmhgfs/link.c:61:21: note: (near initialization for ‘HgfsLinkInodeOperations.put_link’)
/var/lib/dkms/open-vm-tools/9.10.2/build/vmhgfs/link.c: In function ‘HgfsFollowlink’:
/var/lib/dkms/open-vm-tools/9.10.2/build/vmhgfs/link.c:127:10: error: implicit declaration of function ‘nd_set_link’ [-Werror=implicit-function-declaration]
          nd_set_link(nd, fileName);
          ^
/var/lib/dkms/open-vm-tools/9.10.2/build/vmhgfs/link.c: In function ‘HgfsPutlink’:
/var/lib/dkms/open-vm-tools/9.10.2/build/vmhgfs/link.c:238:15: error: implicit declaration of function ‘nd_get_link’ [-Werror=implicit-function-declaration]
    fileName = nd_get_link(nd);
               ^
/var/lib/dkms/open-vm-tools/9.10.2/build/vmhgfs/link.c:238:13: warning: assignment makes pointer from integer without a cast [-Wint-conversion]
    fileName = nd_get_link(nd);
             ^

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: open-vm-tools 2:9.10.2-2822639-1ubuntu3
ProcVersionSignature: Ubuntu 4.2.0-11.13-generic 4.2.1
Uname: Linux 4.2.0-11-generic x86_64
ApportVersion: 2.19-0ubuntu1
Architecture: amd64
Date: Mon Sep 28 15:30:14 2015
InstallationDate: Installed on 2015-03-21 (191 days ago)
InstallationMedia: Ubuntu-MATE 15.04 "Vivid Vervet" - Alpha amd64 (20150320)
ProcEnviron:
 LANGUAGE=en_US
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: open-vm-tools
UpgradeStatus: Upgraded to wily on 2015-09-28 (0 days ago)
modified.conffile..etc.vmware.tools.tools.conf:

mtime.conffile..etc.vmware.tools.tools.conf: 2015-03-21T13:05:43.026485

dc (darkcharl) wrote :
dc (darkcharl) wrote :

trace is different from #1489675, I included it to indicate further dependency issues

summary: - open-vm-tools-dkms fails to build on kernel 4.2 (Wily Werewolf)
+ open-vm-tools-dkms fails to build on kernel 4.2 (Wily Werewolf) [error:
+ implicit declaration of function ‘nd_set_link’]
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in open-vm-tools (Ubuntu):
status: New → Confirmed
Changed in open-vm-tools (Ubuntu):
importance: Undecided → High
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → High
Changed in open-vm-tools (Debian):
status: Unknown → New

The attachment "0001-vmhgfs-support-linux-4.2.x-kernel.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Dyno (dyno-fu) wrote :

https://github.com/vmware/open-vm-tools/tree/stable-9.10.3

the vmhgfs kernel module source has been updated and should now work with Linux 4.2 kernel and we have run internal test against Ubuntu 15.10/4.2.0-16-generic kernel. please use the source from stable-9.10.3. thanks.

Robert C Jennings (rcj) on 2015-10-23
Changed in open-vm-tools (Ubuntu):
assignee: nobody → Robert C Jennings (rcj)
milestone: none → wily-updates
Robert C Jennings (rcj) wrote :

I have removed the patch from comment #4. Running with the vmhgfs driver from the 9.10.2 code can result in data corruption. The backport of the driver from 10.0.0 to 9.10.3 resolves the data corruption issue as well as addressing the kernel compilation failures for 4.1 and 4.2 kernels.

As noted in comment #7, the 9.10.3 code has been tested by VMWare against 15.10 with the 4.2.0-16 kernel.

Changed in open-vm-tools (Debian):
status: New → Fix Released
Robert C Jennings (rcj) wrote :

Debian has moved to 10.0.0. Ubuntu will update 9.10.2 to 9.10.3 for Wily and pull in 10.0.0 for Xenial.

Robert C Jennings (rcj) wrote :

Package @ ppa:rcj/open-vm-tools

Robert C Jennings (rcj) on 2015-11-05
Changed in open-vm-tools (Ubuntu):
status: Confirmed → In Progress
Robert C Jennings (rcj) wrote :

Fixed changelog mistake in commit 3595280d8803319f71b53a22e39c386fab1577bf of the tree.

The changelog in the merge of 9.10.3-3167576 accidentally dropped
history and pulled in content from a dead development branch. This
patch fixes the changelog to reflect actual changes.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in open-vm-tools (Ubuntu Wily):
status: New → Confirmed

The new version from the PPA works fine on amd64 but doesn't on i386 with a current 15.10 on VMPlayer 12.0.1.
There are no visible errors, vmware-hgfsclient does not show any shared folders, mount gives i/o errors. vmware tools also don't work on i386, so there might be a general problem.

Dyno (dyno-fu) wrote :

@armin-kunaschik, can you help to try these steps and help to isolate if it is vmware problem or packaging problem? thanks!

apt-get install build-essential linux-headers-generic git
apt-get install libmspack-dev libglib2.0-dev libprocps3-dev libdnet-dev libdumbnet-dev

git clone https://github.com/vmware/open-vm-tools.git
git checkout stable-9.10.x
./configure --without-x --without-pam --without-ssl --without-icu
make MODULES=vmhgfs
insmod modules/linux/vmhgfs/vmhgfs.ko

mount -t vmhgfs .host:/ /mnt
ls /mnt

with the above steps, i don't see a problem to list/update files in shared folder...

Frederick W. Roller (fwroller) wrote :

git checkout stable-9.10.x

failed with

fatal: Not a git repository (or any of the parent directories): .git

Dyno (dyno-fu) wrote :

sorry stable-9.10.x is a remote branch

$ git branch -r
  origin/HEAD -> origin/master
  origin/master
  origin/stable-10.0.x
  origin/stable-8.4.x
  origin/stable-8.6.x
  origin/stable-8.8.x
  origin/stable-9.0.x
  origin/stable-9.10.x
  origin/stable-9.2.x
  origin/stable-9.4.6-deploypkg
  origin/stable-9.4.x

# set up a local branch to track it
$ git branch ovt910x origin/stable-9.10.x

$ git checkout ovt910x

@dyno-fu Compiles without error.

mount -t vmhgfs .host:/ /mnt/hgfs
Could not add entry to mtab, continuing

ls -l /mnt/hgfs
total 0

lsmod |grep hgfs
vmhgfs 53248 1

vmware-checkvm and vmware-toolbox-cmd (from vmware-tools package) are working, so I suspect no general VMWare problem.

BTW: Today I updated to VMWare Player 12.1.0 with vmware-tools 10.0.5. No changes with vmware-tools either, still not working.

Dyno (dyno-fu) wrote :

i think the situation is more like Ubuntu has not yet update their open-vm-tools-dkms package to pick the 9.10.3 or 10.0.5 release of open-vm-tools from github.

when you trying to install vmware-tools shipped with vmware player, if it detect there is open-vm-tools installed (released by Ubuntu) then it will not replace it as we are in favor of the distro packaged one.

> dpkg -l open-vm-tools-dkms
the one in the repository is still 9.10.2 ... i have not try the PPA yet.

VMware support for open-vm-tools (2073803), http://kb.vmware.com/kb/2073803

@dyno-fu I *was* using the open-vm-tools from the PPA!
I tried several things with either open-vm-tools or vmware-tools and the conflicting software removed.
Ubuntu was upgraded from 15.04 (initially 12.04), open-vm-tools and vmware-tools were both always working fine.
After the upgrade, things didn't work as described above.

To keep my (maybe broken) Ubuntu system out the equation I installed a clean 32-bit Ubuntu 15.10 from scratch into a new VM (in fact I downloaded one from osboxes.org)
Surprise: open-vm-tools 9.10.3 are working fine on a 32-bit VM.

Obviously my installation has to be broken in some way.
If noone else has the same problem, I'll throw away the garbage and start over new...

zappe (zappee) wrote :

I also got this issue.
When installing open-vm-tools and open-vm-tools-desktop I got a popup to submit error report and was taken to bug #1502539 and then found this one.

From the beginning I came from this thread, https://communities.vmware.com/thread/525601?tstart=0, since I have general issues with VMware Tools.

Let me know if you need any testing from me.

Another fail:

sudo apt install open-vm-tools-desktop
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-4.2.0-16 linux-headers-4.2.0-16-generic
  linux-image-4.2.0-16-generic linux-image-extra-4.2.0-16-generic
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  open-vm-tools-dkms
The following NEW packages will be installed:
  open-vm-tools-desktop open-vm-tools-dkms
0 upgraded, 2 newly installed, 0 to remove and 3 not upgraded.
Need to get 0 B/518 kB of archives.
After this operation, 6,640 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Selecting previously unselected package open-vm-tools-desktop.
(Reading database ... 241725 files and directories currently installed.)
Preparing to unpack .../open-vm-tools-desktop_2%3a9.10.2-2822639-1ubuntu3_amd64.deb ...
Unpacking open-vm-tools-desktop (2:9.10.2-2822639-1ubuntu3) ...
Selecting previously unselected package open-vm-tools-dkms.
Preparing to unpack .../open-vm-tools-dkms_2%3a9.10.2-2822639-1ubuntu3_all.deb ...
Unpacking open-vm-tools-dkms (2:9.10.2-2822639-1ubuntu3) ...
Processing triggers for man-db (2.7.4-1) ...
Setting up open-vm-tools-desktop (2:9.10.2-2822639-1ubuntu3) ...

Failed to get unit file state for run-vmblockx2dfuse.mount: No such file or directory
run-vmblock\x2dfuse.mount is a disabled or a static unit, not starting it.
Setting up open-vm-tools-dkms (2:9.10.2-2822639-1ubuntu3) ...
Loading new open-vm-tools-9.10.2 DKMS files...
Building only for 4.2.0-22-generic
Building initial module for 4.2.0-22-generic
ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/open-vm-tools-dkms.0.crash'
Error! Build of vmhgfs.ko failed for: 4.2.0-22-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/open-vm-tools/9.10.2/build/ for more information.
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.120ubuntu6) ...
update-initramfs: Generating /boot/initrd.img-4.2.0-22-generic

Could you port version 10 like Fedora did?

Thank you.

Is there a reason why the PPA version (9.10.3) is not put into wily-updates?
It seems to work and there were no other issues reported with version 9.10.3
#21 and #22 refer to version 9.10.2

Ted Chien (hsiangtai-chien) wrote :

Hi, please consider updating the open-vm-tools package to the latest version. I could not use the Share Folder feature with VMware Fusion on Ubuntu 15.10 now and it really bothers me.

Thanks!

Paul (prowla) wrote :

Hi, folks - any updates on plans to deal with this long-standing issue?

(I'm using Ubuntu 15.10 in VMware Workstation on a Windows 7 host.)

Frederick W. Roller (fwroller) wrote :

Why not use the current version of the tools from VMware?

Timothy Quinn (tim-c-quinn) wrote :

@fwroller - VMware is now pushing users towards using open-vm-tools instead of their own vmware tools. See: http://kb.vmware.com/kb/2073803

Kali Linux discusses formally tranitioning over with their 2016-1 release: https://www.kali.org/news/kali-linux-rolling-edition-2016-1/

a name (kaweka) wrote :

@fwroller
open-vm-tools promises less maintenance efforts on kernel updates.
VmWare makes the recommendations - within VmWare Tools installation script and several other sources - to replace bundled VmWare Tools with open-vm-tools provided by package management of used disro. This reco I can understand very well.
Shared folders do not work in following setup: Ubuntu 15.10 64Bits Desktop + open_vm_tools offered by Wily's package management system, status: two days ago.

*editorial fixes

For anyone still waiting:
If you're ok with doing a little bit of editing on the patch files, open-vm-tools 10.0.5 from github works fine on 15.10 - including hgfs and copy/paste sharing. (although I just did it an hour ago, so may not spotted other issues)
Just make sure you apply all relevant patches from the 9.10.xx version.

a name (kaweka) wrote :

Hi Stanislaw, Thanks for information from you.
One point however is not clear for me. All that on github seems to be VmWare's own open-vm-tools repo.
The guys there claim (see Readme.md file, last update 7 months ago) open-vm-tools would not include
Linux drivers as those were available as part of Linux kernel itself. According to same file Linux kernels since
3.10 would include all Linux drivers except for (vm)hgfs, so the impression arises VmWare open-vm-tools project
does not target Linux drivers, inclusively hgfs. They leave this task the distribution vendors or mainline kernels - so far
my understanding. How does it comply with your last statement here?
Or you mean other github open-vm-tools project, not the VmWare's one. Which one then?

Tong Sun (suntong001) wrote :

@stanislaw-pitucha, want to know the answer to @kaweka's question as well -- how did you get hgfs and copy/paste sharing working.

Thanks

Paul (prowla) wrote :

Hi (again)
Ubuntu is great, and free, so thanks very much!
But I think you have to agree that this issue persisting for 8 months is a bit lame.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.