open-vm-dkms 2011.12.20-562307-0ubuntu1: open-vm-tools kernel module failed to build [error: implicit declaration of function ‘d_alloc_root’]

Bug #1381824 reported by Jiss

This bug report was converted into a question: question #257539: open-vm-dkms 2011.12.20-562307-0ubuntu1: open-vm-tools kernel module failed to build [error: implicit declaration of function ‘d_alloc_root’].

24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
open-vm-tools (Ubuntu)
Won't Fix
Undecided
Unassigned

Bug Description

During startup this message will shown. Also I can't access shared folders after that(/mnt/hgfs not present). I reinstalled vmware tools. But effect is same.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: open-vm-dkms 2011.12.20-562307-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-44.66~precise1-generic 3.8.13.25
Uname: Linux 3.8.0-44-generic i686
ApportVersion: 2.0.1-0ubuntu17.7
Architecture: i386
DKMSKernelVersion: 3.8.0-44-generic
Date: Tue Oct 14 18:37:59 2014
InstallationMedia: Ubuntu 12.04.3 LTS "Precise Pangolin" - Release i386 (20130820.1)
MarkForUpload: True
PackageArchitecture: all
PackageVersion: 2011.12.20-562307-0ubuntu1
SourcePackage: open-vm-tools
Title: open-vm-dkms 2011.12.20-562307-0ubuntu1: open-vm-tools kernel module failed to build
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Jiss (jissj) wrote :
tags: removed: need-duplicate-check
summary: open-vm-dkms 2011.12.20-562307-0ubuntu1: open-vm-tools kernel module
- failed to build
+ failed to build [ error: implicit declaration of function
+ ‘d_alloc_root’]
summary: open-vm-dkms 2011.12.20-562307-0ubuntu1: open-vm-tools kernel module
- failed to build [ error: implicit declaration of function
- ‘d_alloc_root’]
+ failed to build [error: implicit declaration of function ‘d_alloc_root’]
Revision history for this message
Jiss (jissj) wrote :

Till now I cant able to fix this issue. Please help me...

Changed in open-vm-tools (Ubuntu):
status: New → Confirmed
status: Confirmed → Invalid
status: Invalid → Confirmed
Revision history for this message
Bryce Harrington (bryce) wrote :

Closing out pre-18.04 build failure bug reports for open-vm-tools.

This type of bug is often due to a kernel/vmware version discrepancy, that was specific to the versions in play at the time. So, this particular build failure is unlikely to be relevant to currently maintained Ubuntu versions. If you hit similar-looking build failures with newer versions of Ubuntu please file a new bug report with the corresponding log and config files.

Changed in open-vm-tools (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers