iSCSI root installation creates manual eth0 configuration + long boot

Bug #870214 reported by James Page on 2011-10-07
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
ifupdown (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned
Precise
High
Unassigned
open-iscsi (Ubuntu)
High
Stéphane Graber
Oneiric
High
Stéphane Graber
Precise
High
Stéphane Graber

Bug Description

ISO Tracker Test Case: http://testcases.qa.ubuntu.com/Install/ServeriSCSIRoot#Unauthenticated%20Login

Installation completed fine, system does boot but has the following entry in /etc/network/interfaces:

# The primary network interface
auto eth0
iface eth0 inet manual

As a result the failsafe upstart configuration appears to kick in to the server takes a while to get to a login prompt

ProblemType: Bug
DistroRelease: Ubuntu 11.10
ProcVersionSignature: Ubuntu 3.0.0-12.19-server 3.0.4
Uname: Linux 3.0.0-12-server x86_64
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Fri Oct 7 19:38:07 2011
InstallationMedia: Ubuntu-Server 11.10 "Oneiric Ocelot" - Beta amd64 (20111007)
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)

James Page (james-page) wrote :
affects: network-manager (Ubuntu) → ubuntu
description: updated
tags: added: iso-testing
Dave Walker (davewalker) on 2011-10-07
tags: added: server-o-rs
James Page (james-page) wrote :

Impacts authenticated and unauthenticated installations on i386 and amd64

tags: added: rls-mgr-o-tracking
James Page (james-page) wrote :
James Page (james-page) wrote :

Re-confirmed in 20111009 images

affects: ubuntu → open-iscsi (Ubuntu)
Steve Langasek (vorlon) wrote :

Stéphane, could you please have a look at this bug? If open-iscsi is setting up a broken interfaces file, I think we should try to get this fixed for oneiric.

This impacts the server CD.

Changed in open-iscsi (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-11.10
assignee: nobody → Stéphane Graber (stgraber)
Stéphane Graber (stgraber) wrote :

http://paste.ubuntu.com/706210/ is the /etc/network/interfaces generated by d-i.
This is taken from the .img over iscsi before ever booting the system.

Stéphane Graber (stgraber) wrote :

Commenting the part about eth0 works around the issue.
I'd still think "inet manual" should be considered as a similar setup and not wait 2 minutes for something to happen (which will never happen as the interface is already up and nothing needs to be done).

Stéphane Graber (stgraber) wrote :

Marking as Invalid for open-iscsi and bumping the importance for ifupdown + targeting for SRU.

Changed in ifupdown (Ubuntu Oneiric):
status: New → Invalid
status: Invalid → Triaged
Changed in open-iscsi (Ubuntu Oneiric):
status: New → Invalid
Changed in ifupdown (Ubuntu Oneiric):
importance: Undecided → High
milestone: none → oneiric-updates
Steve Langasek (vorlon) wrote :

not reproducible with a 'manual' interface in /e/n/i without open-iscsi installed. Looks like /etc/init/iscsi-network-interface.conf is probably the culprit.

Changed in open-iscsi (Ubuntu Oneiric):
status: Invalid → Triaged
Changed in ifupdown (Ubuntu Oneiric):
status: Triaged → Invalid
James Page (james-page) wrote :

Removing the /etc/init/iscsi-network-interface.conf upstart configuration results in a normal boot;

I verified that the /etc/network/if-up.d/upstart script fires for both lo and eth0 (rather that just lo as it did with iscsi-network-interface in place).

Steve Langasek (vorlon) wrote :

While we need to remove the upstart job to let the ifupdown hooks fire, we also need to be careful that in doing so, previously-working systems don't now have ifupdown reconfiguring their network interface out from under iscsi. So if we're dropping the job we need to somehow ensure on upgrade that /e/n/i gets fixed up to not have any configuration for the interface in question.

Hello James, or anyone else affected,

Accepted open-iscsi into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in open-iscsi (Ubuntu Oneiric):
milestone: ubuntu-11.10 → oneiric-updates
status: Triaged → Fix Committed
tags: added: verification-needed
Patrick Domack (patrickdk) wrote :

It corrects the issue for me, and nice fast boot is achieved.

Network is still up and working.
Filesystem works, and rw

Thanks for testing. much appreciated.

tags: added: verification-done
removed: verification-needed
Changed in ubuntu-release-notes:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package open-iscsi - 2.0.871-0ubuntu9

---------------
open-iscsi (2.0.871-0ubuntu9) oneiric-proposed; urgency=low

  * Make sure the upstart job triggers ifupdown's upstart script to avoid
    waiting 2 minutes at boot time for network to come up. (LP: #870214)
 -- Stephane Graber <email address hidden> Tue, 11 Oct 2011 22:31:39 +0100

Changed in open-iscsi (Ubuntu):
status: Fix Committed → Fix Released
Changed in open-iscsi (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Christophe (christophe-wk3) wrote :
Download full text (3.2 KiB)

It doesn't seem to fix the problem.

ii open-iscsi 2.0.871-0ubuntu9 High performance, transport independent iSCSI implementation
ii open-iscsi-utils 2.0.871-0ubuntu9 iSCSI initiatior administrative utility

Oct 19 13:19:53 r60 NetworkManager[907]: <info> sleep requested (sleeping: no enabled: yes)
Oct 19 13:19:53 r60 NetworkManager[907]: <info> sleeping or disabling...
Oct 19 13:19:53 r60 NetworkManager[907]: <info> (eth0): now unmanaged
Oct 19 13:19:53 r60 NetworkManager[907]: <info> (eth0): device state change: activated -> unmanaged (reason 'sleeping') [100 10 37]
Oct 19 13:19:53 r60 NetworkManager[907]: <info> (eth0): deactivating device (reason 'sleeping') [37]
Oct 19 13:19:54 r60 NetworkManager[907]: <info> (eth0): canceled DHCP transaction, DHCP client pid 1091
Oct 19 13:19:54 r60 NetworkManager[907]: <info> (eth0): cleaning up...
Oct 19 13:19:54 r60 NetworkManager[907]: <info> (eth0): taking down device.
Oct 19 13:19:54 r60 kernel: [ 176.684717] tg3 0000:02:00.0: PME# enabled
Oct 19 13:19:54 r60 kernel: [ 176.684744] pcieport 0000:00:1c.0: wake-up capability enabled by ACPI
Oct 19 13:19:54 r60 NetworkManager[907]: <info> (wlan0): now unmanaged
Oct 19 13:19:54 r60 NetworkManager[907]: <info> (wlan0): device state change: unavailable -> unmanaged (reason 'sleeping') [20 10 37]
Oct 19 13:19:54 r60 NetworkManager[907]: <info> (eth0): carrier now OFF (device state 10)
Oct 19 13:19:54 r60 kernel: [ 176.684717] tg3 0000:02:00.0: PME# enabled
Oct 19 13:19:54 r60 kernel: [ 176.684744] pcieport 0000:00:1c.0: wake-up capability enabled by ACPI
Oct 19 13:20:02 r60 kernel: [ 184.560042] connection1:0: ping timeout of 5 secs expired, recv timeout 5, last rx 4294935932, last ping 4294937184, now 4294938436
Oct 19 13:20:02 r60 kernel: [ 184.560063] connection1:0: detected conn error (1011)
Oct 19 13:20:03 r60 iscsid: Kernel reported iSCSI connection 1:0 error (1011) state (3)
Oct 19 13:20:02 r60 kernel: [ 184.560042] connection1:0: ping timeout of 5 secs expired, recv timeout 5, last rx 4294935932, last ping 4294937184, now 4294938436
Oct 19 13:20:02 r60 kernel: [ 184.560063] connection1:0: detected conn error (1011)
Oct 19 13:20:05 r60 iscsid: cannot make a connection to 192.168.178.27:3260 (-1,101)
Oct 19 13:20:38 iscsid: last message repeated 11 times
Oct 19 13:21:41 iscsid: last message repeated 21 times
Oct 19 13:22:02 iscsid: last message repeated 7 times
Oct 19 13:22:02 r60 kernel: [ 305.120071] session1: session recovery timed out after 120 secs
Oct 19 13:22:02 r60 anacron[2414]: Anacron 2.3 started on 2011-10-19
Oct 19 13:22:02 r60 anacron[2414]: Normal exit (0 jobs run)
Oct 19 13:22:03 r60 kernel: [ 305.361209] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,data=writeback,commit=0
Oct 19 13:22:02 r60 kernel: [ 305.120071] session1: session recovery timed out after 120 secs
Oct 19 13:22:03 r60 kernel: [ 305.361209] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,data=writeback,commit=0
Oct 19 13:22:04 r60 kernel: [ 307.163876] PM: Syncing filesystems ... done.
Oct 19 13:22:04 r60 kernel: [ 307.170237] PM: P...

Read more...

Stéphane Graber (stgraber) wrote :

Your log shows usage of NetworkManager which is incompatible with iscsi root.

Network Manager on startup will try to re-establish the existing network connections, thereby killing your iscsi root in the process.

Changed in ubuntu-release-notes:
status: Fix Committed → Fix Released
Changed in open-iscsi (Ubuntu Precise):
milestone: oneiric-updates → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers