open-iscsi will not start at boot if /usr is on a separate mount point

Bug #208441 reported by LinuxBladeGuy on 2008-03-28
2
Affects Status Importance Assigned to Milestone
open-iscsi (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: open-iscsi

The current open-iscsi package puts the iscsid binary into /usr/sbin/

While this works fine for "all in one" partitioned systems, it prevents open-iscsi from running at boot time, and also prevents an iSCSI-mounted /usr partition.

Since /usr/sbin/iscsid does not exist prior to mounting /usr, and since open-iscsi starts before mounting filesystems, the open-iscsi startup script will always exit without bringing up iSCSI at boot time.

The simple fix is to "not put /usr onto a separate file system" but this makes lots of server admins nervous... ;)

Related branches

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package open-iscsi - 2.0.865-1ubuntu3

---------------
open-iscsi (2.0.865-1ubuntu3) hardy; urgency=low

  * Migration of /usr/{bin,sbin,lib} -> to /{bin,sbin,lib}.
    (LP: #208441)
  * Push the shutdown scripts back. (LP: #196748)
  * Update control to 3.7.3.
  * Updated the maintainer according to spec.

 -- Chuck Short <email address hidden> Wed, 09 Apr 2008 18:09:28 -0400

Changed in open-iscsi:
status: New → Fix Released
LinuxBladeGuy (spam-nashira) wrote :

Confirmed that the above change works

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers