Open-iscsi causes machine to hang on reboot

Bug #181188 reported by AndreasB
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
open-iscsi (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by Alessandro Gervaso

Bug Description

Binary package hint: open-iscsi

Machine, a Dell PowerEdge 2950 has no problems rebooting when open-iscsi is not installed. However, once open-iscsi is installed, the computer hangs indefinetly on reboot.

I have tried the reboot flags described here: https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/115906 but those did not fix the problem.

I also tried uninstalling open-iscsi, and while the computer hung on the first reboot (as kernel modules were still loaded, it rebooted just fine after that.

System goes through the entire reboot message sequence up and with the "Reboothing machine now" message, but nothing happens after that.

Install is Ubuntu 7.10 server x64.

Related branches

Revision history for this message
AndreasB (andreasb) wrote :

root@mod:~# uname -a
Linux mod 2.6.22-14-server #1 SMP Tue Dec 18 05:52:24 UTC 2007 x86_64 GNU/Linux
root@mod:~#

Revision history for this message
AndreasB (andreasb) wrote :
Revision history for this message
AndreasB (andreasb) wrote :
Revision history for this message
AndreasB (andreasb) wrote :
Revision history for this message
AndreasB (andreasb) wrote :
Revision history for this message
AndreasB (andreasb) wrote :

See: http://groups.google.com/group/open-iscsi/browse_thread/thread/2ff9c06c67ff30b7

"Yeah, the iscsi stuff is not getting shutdown completely. There is a bug
when using 2.6.21 and newer with targets that are using write back cache
like your target.

There is a fix for the upstream 2.6.25 kernel when it comes out. And in
the open-iscsi git tree there is a fix in the kernel modules we
distribute in that tarball."

Revision history for this message
Alessandro Gervaso (gervystar) wrote :

This is still a bug in hardy. I'm having the same issue using -server and -xen kernels in all of my machines.

The suggested fix is to use the 2.0-869.2 tools and kernel modules from open-iscsi.org as suggested in http://<email address hidden>/msg00778.html

It would be nice if they could be updated or backported at least for the .1 release (they are already packaged in debian sid atm).

Revision history for this message
Alessandro Gervaso (gervystar) wrote :

I forgot to mention that the reboot process hangs displaying "iscsi: can not broadcast skb (-3)" on the console; at that point the only way to reboot a machine is by using the sysrq keys or with a hard reset.

Changed in open-iscsi:
assignee: nobody → ubuntu-kernel-team
Revision history for this message
kryanth (chris-gopc) wrote :

Can confirm this in hardy-heron (8.04LTS) -xen (2.6.24-19-xen) , with the current packaged iscsi (2.0-865).

I rebuilt the kernel (necessary to get the build for open-iscsi 2.0-869.2 to work) - however I'm experiencing with being unable to maintain sessions with the SAN ( MD3000i). It does fix the hangs however. Looks like I'll have to build new kernel with 2.6.25, however there doesnt seem to be any Ubuntu source for this, so would prefer not to.

Whats the ETA for 2.6.25-xen and open-iscsi-2.0.869 in Hardy Heron? This is a showstopper for me currently.

Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package open-iscsi - 2.0.870.1-0ubuntu1

---------------
open-iscsi (2.0.870.1-0ubuntu1) jaunty; urgency=low

  * New upstream release:
   - Support 2.6.26/27 kernels (LP: #289470).
   - Fix iscsid shutdown (LP: #181188).
  * Merge from Debian. Remaining Ubuntu changes:
   - Note: Debian version isn't 870~rc3 but 869.2 which leads to a big
     .diff.gz file. Only files in debian/ have been considered for this merge
     since debian hasn't patched the source.
   - debian/control, debian/rules, debian/open-iscsi-udeb*:
     + Add open-iscsi-udeb.
   - debian/open-iscsi.dirs:
     + rename dirs to open-iscsi.dirs because of open-iscsi-udeb addition.
     + drop network/if-up.d/ directory since we're using symlinks instead.
     + utilities installed in /bin,/sbin rather than /usr/bin,/usr/sbin.
   - debian/open-iscsi.init:
     + utilities installed in /bin,/sbin rather than /usr/bin,/usr/sbin.
     + lsb log messages.
     + Don't generate initiatorname name (moved to postinst).
     + Support for being called from ifup/ifdown scripts.
     + Refactor start functions:
       - move daemon start to startdaemon function.
       - call udevadm settle rather then udevsettle (which doesn't do anything
         useful).
       - don't exit if the daemon is already running during sanitychecks.
         Instead check in startdaemon if the daemon needs to be started.
       - only start automatic targets if necessary.
       - add waitfordevices function: called during rcS, waits for all
         automatic targets to be ready. Iscsi targets are considered as
         local block devices - they don't need to be marked with _netdev in
         fstab. (LP: #227848)
       - start targets if not run from rcS.
     + Check status of iscsid daemon in addition to listing the iscsi sessions
       when status action is called.
     + Add iscsid to the list of processes that should not be killed by
       sendsigs during shutdown (LP: #192080).
     + Add starttargets, stoptargets and restarttargets to usage message.
   - debian/rules:
     + Install utilities /bin,/sbin rather than /usr/bin,/usr/sbin.
     + Start open-iscsi at S25 (waiting for devices created by ifupdown
       calls and before local filesystems are checked and mounted)
     + stop at S41 (after local filesystems are unmounted). Don't use
       umountiscsi.sh script from debian. (LP: #192080).
   - debian/initiatorname.iscsi, debian/open-iscsi.postinst:
     + Generate the random initiatorname during postinstall rather than in the
     init script.
     + Don't ship a default initiatorname.iscsi file.
   - debian/open-iscsi.postinst:
     + fix init script ordering on upgrades.
   - debian/open-iscsi.links:
     + symlink open-iscsi init script in if-up.d and if-down.d directory so
       that the iscsi subsystem is started/stopped when network interfaces
       are configured.
   - debian/open-iscsi.postrm:
     + delete iscsi configuration when the package is purged.
   - utils/iscsi_discovery: De-bashify iscsi_discovery.
   - usr/idbm.c: Fix build failure with new glibc. LP: #299843.
  * Dropped:
   - Exit without error if /sys is not available. Otherwise, it's ...

Read more...

Changed in open-iscsi:
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote : Kernel team bugs

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Revision history for this message
Wido den Hollander (wido) wrote :

I am also having this issue on Ubuntu Hardy 8.0.4.2

At the moment we backport the package from Jaunty, but since Hardy is a LTS we prefer using the versions delivered through the Hardy repositories.

Is there an eta for a fix for Hardy?

Revision history for this message
Simon Déziel (sdeziel) wrote :

I am also affected by this problem on Ubuntu Hardy 8.04.4. I would also appreciate a lot a backport of the fix.

Thanks

# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 8.04.4 LTS
Release: 8.04
Codename: hardy

# uname -a
Linux ubuntu 2.6.24-27-openvz #1 SMP Fri Mar 12 03:27:32 UTC 2010 x86_64 GNU/Linux

# dpkg -l|grep iscsi
ii open-iscsi 2.0.865-1ubuntu3.3 High performance, transport independent iSCS

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers