open-iscsi should not leave around the stamp file if no connections were made

Bug #1800681 reported by Dimitri John Ledkov on 2018-10-30
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
open-iscsi (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned
Disco
Undecided
Unassigned

Bug Description

[Impact]

 * Shutdown is delayed by 30s when open-iscsi is configured to auto mode but no iscsi devices were found.

[Test Case]

(1) * Start a PV (non-iscsi) instance in Oracle Cloud (https://www.oracle.com/cloud/)
 * Monitor the instance's console.
 * Shut down the instance
 * Observe the shutdown proceeding in a timely manner without the following printouts:

[ 851.308389] sd-umoun[2880]: Failed to unmount /oldroot: Device or resource busy
[ 851.311743] sd-umoun[2881]: Failed to unmount /oldroot/dev: Device or resource busy
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
iscsiadm: No active sessions.
Unexpected iSCSI Connection State, forcing iSCSI logout.
iscsiadm: No matching sessions found
[ 881.434458] sd-execu[2882]: /usr/lib/systemd/system-shutdown/open-iscsi.finalrd failed with exit status 21.
[ 881.438313] shutdown[1]: Failed to finalize file systems, ignoring

(2) * Start an iSCSI instance in Oracle Cloud (https://www.oracle.com/cloud/)
 * Monitor the instance's console.
 * Restart the instance
 * Observe the instance rebooting properly

[Regression Potential]

 * The fix is removing /run/initramfs/open-iscsi.interface during running initramfs scripts if not iscsi disks were found. In case not detecting an iscsi device but removing the .interface file the system may reconfigure the network interface later losing connection to the iscsi device.

[Original Bug Text]

open-iscsi should not leave around the stamp file if no connections were made

open-iscsi finalrd hook is sensitive to /run/initramfs/open-iscsi.interface as an indicator that rootfs might have been an iscsi mount, and thus logout needs to happen inside finalrd.

However, in auto-mode, and without any iscsi hard-drives found, that stamp file is still left around. It should be cleaned up, such that such boots do not result in 30s shutdown delay.

Proposed patch is this:

/usr/share/initramfs-tools/scripts/local-top$ diff -u iscsi.orig iscsi
--- iscsi.orig 2018-10-30 15:53:36.314256545 +0000
+++ iscsi 2018-10-30 15:53:02.883686328 +0000
@@ -360,4 +360,19 @@
  done
 fi

+# Remove the interface file if no disks are present
+if [ -f /run/initramfs/open-iscsi.interface ] ; then
+ found=0
+ for disk in /dev/disk/by-path/*-iscsi-*; do
+ if ! "$(readlink -f "$disk")" ; then
+ continue
+ fi
+ found=1
+ break;
+ done
+ if [ $found = 0 ] ; then
+ rm /run/initramfs/open-iscsi.interface
+ fi
+fi
+
 exit 0

tags: added: id-5bbe5cb1a3a04d69ef6d9037
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package open-iscsi - 2.0.874-5ubuntu13

---------------
open-iscsi (2.0.874-5ubuntu13) disco; urgency=medium

  [ Robert C Jennings & Dimitri John Ledkov ]
  * If iscsi root was requested, but no iscsi devices were mounted, remove
    the initramfs interfaces stamp file. Meaning, that on shutdown there
    is no 30s delay, whilst trying to re-establish iscsi login to perform
    a logout. LP: #1800681

 -- Dimitri John Ledkov <email address hidden> Sun, 09 Dec 2018 22:29:20 +0000

Changed in open-iscsi (Ubuntu Disco):
status: New → Fix Released
David Krauser (davidkrauser) wrote :

I tested this fix on disco, and it appears to be working as intended.

The issue still exists on bionic, however.

Balint Reczey (rbalint) on 2019-10-25
Changed in open-iscsi (Ubuntu Cosmic):
status: New → Won't Fix
Balint Reczey (rbalint) on 2019-10-28
description: updated
Balint Reczey (rbalint) on 2019-10-28
description: updated

Hello Dimitri, or anyone else affected,

Accepted open-iscsi into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/open-iscsi/2.0.874-5ubuntu2.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in open-iscsi (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Balint Reczey (rbalint) on 2019-10-28
description: updated

All autopkgtests for the newly accepted open-iscsi (2.0.874-5ubuntu2.8) for bionic have finished running.
The following regressions have been reported in tests triggered by the package:

nova/2:17.0.11-0ubuntu1 (armhf)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/bionic/update_excuses.html#open-iscsi

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers