open-iscsi uses domainsearch instead of search for /etc/resolv.conf

Bug #1791108 reported by Victor Tapia on 2018-09-06
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
open-iscsi (Ubuntu)
Medium
Victor Tapia
Xenial
Medium
Victor Tapia
Bionic
Medium
Victor Tapia
Cosmic
Medium
Victor Tapia

Bug Description

[Impact]

* open-iscsi is adding "domainsearch", a non-existent configuration option, instead of "search" in /etc/resolv.conf. As a result, the search list is ignored in the clients.

[Test case]

* Install an ubuntu machine that uses iscsi as root, and does not use systemd-resolvd.
* Prepare the dhcp server to provide the search list to its clients. For instance, in dnsmasq:

dhcp-option=option:domain-search,canonical.com

* Boot the machine and check the content of /etc/resolv.conf
- if domainsearch is present, the search list will be ignored:

root@iscsi-xenial:/home/ubuntu# ping -c1 golem
ping: unknown host golem

root@iscsi-xenial:/home/ubuntu# strace ping -c1 golem 2>&1 | grep golem
execve("/bin/ping", ["ping", "-c1", "golem"], [/* 19 vars */]) = 0
sendto(4, "_(\1\0\0\1\0\0\0\0\0\0\5golem\0\0\1\0\1", 23, MSG_NOSIGNAL, NULL, 0) = 23
recvfrom(4, "_(\201\203\0\1\0\0\0\0\0\0\5golem\0\0\1\0\1", 1024, 0, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("192.168.122.1")}, [16]) = 23
write(2, "ping: unknown host golem\n", 25ping: unknown host golem

- if search is present, the search list will be used:

root@iscsi-xenial:/home/ubuntu# ping -c1 golem
PING golem.canonical.com (91.189.89.199) 56(84) bytes of data.
64 bytes from golem.canonical.com (91.189.89.199): icmp_seq=1 ttl=57 time=63.7 ms

--- golem.canonical.com ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 63.735/63.735/63.735/0.000 ms

root@iscsi-xenial:/home/ubuntu# strace ping -c1 golem 2>&1 | grep golem
execve("/bin/ping", ["ping", "-c1", "golem"], [/* 19 vars */]) = 0
sendto(4, "\1\\\1\0\0\1\0\0\0\0\0\0\5golem\tcanonical\3com"..., 37, MSG_NOSIGNAL, NULL, 0) = 37
recvfrom(4, "\1\\\201\200\0\1\0\1\0\0\0\0\5golem\tcanonical\3com"..., 1024, 0, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("192.168.122.1")}, [16]) = 53
write(1, "PING golem.canonical.com (91.189"..., 145PING golem.canonical.com (91.189.89.199) 56(84) bytes of data.
64 bytes from golem.canonical.com (91.189.89.199): icmp_seq=1 ttl=57 time=63.5 ms
write(1, "--- golem.canonical.com ping sta"..., 157--- golem.canonical.com ping statistics ---

[Regression potential]

* The change is minor (a string replacement) and it's currently not working.
* Any possible regression would involve continuing to break DNS resolution.

[Other info]

* resolv.conf man page: http://man7.org/linux/man-pages/man5/resolv.conf.5.html

[Original description]

Having an interface file such as /run/net-eno2.conf with the following content:

DEVICE='eno2'
PROTO='dhcp'
IPV4ADDR='10.10.10.10'
IPV4BROADCAST='10.10.10.255'
IPV4NETMASK='255.255.255.0'
IPV4GATEWAY='10.10.10.1'
IPV4DNS0='169.254.169.254'
IPV4DNS1='0.0.0.0'
HOSTNAME=''
DNSDOMAIN='test.com'
NISDOMAIN=''
ROOTSERVER='169.254.169.254'
ROOTPATH=''
filename='/ipxe.efi'
UPTIME='45'
DHCPLEASETIME='86400'
DOMAINSEARCH='test.com'

net-interface-handler translates it to:

nameserver 169.254.169.254
domainsearch test.com

instead of:

nameserver 169.254.169.254
search test.com

The problem is that domainsearch is not a valid configuration option for /etc/resolv.conf and is ignored.

Victor Tapia (vtapia) wrote :

The affected versions are Xenial, Bionic and Cosmic. I'm attaching a patch with what might be the fix

The attachment "domainsearch-to-search.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Victor Tapia (vtapia) on 2018-09-18
description: updated
Victor Tapia (vtapia) on 2018-09-18
tags: added: sts-sru-needed
Victor Tapia (vtapia) on 2018-09-18
description: updated
Dan Streetman (ddstreet) on 2018-09-19
tags: added: sts-sponsor
Changed in open-iscsi (Ubuntu Cosmic):
importance: Undecided → Medium
Changed in open-iscsi (Ubuntu Bionic):
importance: Undecided → Medium
Changed in open-iscsi (Ubuntu Xenial):
importance: Undecided → Medium
Changed in open-iscsi (Ubuntu Cosmic):
status: New → In Progress
Changed in open-iscsi (Ubuntu Bionic):
status: New → In Progress
Changed in open-iscsi (Ubuntu Xenial):
status: New → In Progress
Changed in open-iscsi (Ubuntu Cosmic):
assignee: nobody → Victor Tapia (vtapia)
Changed in open-iscsi (Ubuntu Bionic):
assignee: nobody → Victor Tapia (vtapia)
Changed in open-iscsi (Ubuntu Xenial):
assignee: nobody → Victor Tapia (vtapia)
description: updated
Dan Streetman (ddstreet) wrote :

i made minor changes to the template - to include "and does not use systemd-resolvd." to the testcase section, and add a possible regression line to the regression potential section (having 'None' in RP is specifically advised against). If either of those need adjustment please feel free to edit.

Dan Streetman (ddstreet) wrote :

@vtapia, the (LP: #1791108) tag is missing from your debdiffs - can you update them and re-attach?

Victor Tapia (vtapia) wrote :
Victor Tapia (vtapia) wrote :
Victor Tapia (vtapia) wrote :
Eric Desrochers (slashd) wrote :

Sponsored for development release (cosmic).

I'll start the SRU, beginning of next week. That will give cosmic the time to go through build, autopkgtest, ... and get "Fix Released" by the time we are starting the SRU.

- Eric

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package open-iscsi - 2.0.874-5ubuntu9

---------------
open-iscsi (2.0.874-5ubuntu9) cosmic; urgency=medium

  * d/net-interface-handler: replace 'domainsearch' with the correct
    configuration option 'search' in net-interface-handler (LP: #1791108)

 -- Victor Tapia <email address hidden> Mon, 17 Sep 2018 15:58:34 +0200

Changed in open-iscsi (Ubuntu Cosmic):
status: In Progress → Fix Released
Dan Streetman (ddstreet) wrote :

unfortunately the bionic upload for this is blocked by bug 1755858; once that upload is either approved or rejected, we can upload this.

Patricia Gaughen (gaughen) wrote :

Dan, Eric - you all are now unblocked. Get'r'done!

Dan Streetman (ddstreet) wrote :

x/b uploaded, in upload queues awaiting approval for -proposed

Hello Victor, or anyone else affected,

Accepted open-iscsi into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/open-iscsi/2.0.874-5ubuntu2.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in open-iscsi (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Changed in open-iscsi (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
Brian Murray (brian-murray) wrote :

Hello Victor, or anyone else affected,

Accepted open-iscsi into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/open-iscsi/2.0.873+git0.3b4b4500-14ubuntu3.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Victor Tapia (vtapia) wrote :

#VERIFICATION-XENIAL
- Before the update
ubuntu@iscsi_base:~$ dpkg -l | grep open-iscsi
ii open-iscsi 2.0.873+git0.3b4b4500-14ubuntu3.5 amd64 iSCSI initiator tools

ubuntu@iscsi_base:~$ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 192.168.122.1
domainsearch example.com

ubuntu@iscsi_base:~$ strace ping -c1 www 2>&1 | grep www
execve("/bin/ping", ["ping", "-c1", "www"], [/* 20 vars */]) = 0
sendto(3, "=\370\1\0\0\1\0\0\0\0\0\0\3www\0\0\1\0\1", 21, MSG_NOSIGNAL, NULL, 0) = 21
recvfrom(3, "=\370\201\203\0\1\0\0\0\1\0\0\3www\0\0\1\0\1\0\0\6\0\1\0\0*0\0@"..., 1024, 0, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("192.168.122.1")}, [16]) = 96
write(2, "ping: unknown host www\n", 23ping: unknown host www

- After the update
ubuntu@iscsi_base:~$ dpkg -l | grep open-iscsi
ii open-iscsi 2.0.873+git0.3b4b4500-14ubuntu3.6 amd64 iSCSI initiator tools

ubuntu@iscsi_base:~$ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 192.168.122.1
search example.com

ubuntu@iscsi_base:~$ strace ping -c1 www 2>&1 | grep www
execve("/bin/ping", ["ping", "-c1", "www"], [/* 20 vars */]) = 0
sendto(3, "\241\223\1\0\0\1\0\0\0\0\0\0\3www\7example\3com\0\0\1\0"..., 33, MSG_NOSIGNAL, NULL, 0) = 33
recvfrom(3, "\241\223\201\200\0\1\0\1\0\0\0\0\3www\7example\3com\0\0\1\0"..., 1024, 0, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("192.168.122.1")}, [16]) = 49

Victor Tapia (vtapia) wrote :
Download full text (3.6 KiB)

#VERIFICATION-BIONIC

- Before the update
ubuntu@iscsi-bionic:~$ dpkg -l | grep open-iscsi
ii open-iscsi 2.0.874-5ubuntu2.2 amd64 iSCSI initiator tools

ubuntu@iscsi-bionic:~$ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
# 127.0.0.53 is the systemd-resolved stub resolver.
# run "systemd-resolve --status" to see details about the actual nameservers.

nameserver 192.168.122.1
domainsearch example.com

ubuntu@iscsi-bionic:~$ sudo strace ping -c1 www 2>&1 | grep www
execve("/bin/ping", ["ping", "-c1", "www"], 0x7ffeb4aecd70 /* 14 vars */) = 0
sendmmsg(5, [{msg_hdr={msg_name=NULL, msg_namelen=0, msg_iov=[{iov_base="\300\17\1\0\0\1\0\0\0\0\0\0\3www\0\0\1\0\1", iov_len=21}], msg_iovlen=1, msg_controllen=0, msg_flags=MSG_TRUNC|MSG_DONTWAIT|MSG_EOR|MSG_WAITALL|MSG_CONFIRM|MSG_RST|MSG_MORE|MSG_BATCH|MSG_ZEROCOPY|MSG_FASTOPEN|0xb420000}, msg_len=21}, {msg_hdr={msg_name=NULL, msg_namelen=0, msg_iov=[{iov_base="\0\31\1\0\0\1\0\0\0\0\0\0\3www\0\0\34\0\1", iov_len=21}], msg_iovlen=1, msg_controllen=0, msg_flags=MSG_CTRUNC|MSG_FIN|MSG_SYN|MSG_CONFIRM|MSG_RST|MSG_MORE|MSG_BATCH|MSG_ZEROCOPY|MSG_FASTOPEN|0xb420010}, msg_len=21}], 2, MSG_NOSIGNAL) = 2
recvfrom(5, "\300\17\201\203\0\1\0\0\0\0\0\0\3www\0\0\1\0\1", 2048, 0, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("192.168.122.1")}, [28->16]) = 21
recvfrom(5, "\0\31\201\203\0\1\0\0\0\1\0\0\3www\0\0\34\0\1\0\0\6\0\1\0\0\"L\0@"..., 65536, 0, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("192.168.122.1")}, [28->16]) = 96
write(2, "ping: www: Name or service not k"..., 37ping: www: Name or service not known

- After the update
ubuntu@iscsi-bionic:~$ dpkg -l | grep open-iscsi
ii open-iscsi 2.0.874-5ubuntu2.3 amd64 iSCSI initiator tools

ubuntu@iscsi-bionic:~$ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
# 127.0.0.53 is the systemd-resolved stub resolver.
# run "systemd-resolve --status" to see details about the actual nameservers.

nameserver 192.168.122.1
search example.com

ubuntu@iscsi-bionic:~$ sudo strace ping -c1 www 2>&1 | grep www
execve("/bin/ping", ["ping", "-c1", "www"], 0x7ffea5cd0390 /* 14 vars */) = 0
sendmmsg(5, [{msg_hdr={msg_name=NULL, msg_namelen=0, msg_iov=[{iov_base="\262\224\1\0\0\1\0\0\0\0\0\0\3www\7example\3com\0\0\1\0"..., iov_len=33}], msg_iovlen=1, msg_controllen=0, msg_flags=MSG_TRUNC|MSG_DONTWAIT|MSG_EOR|MSG_WAITALL|MSG_CONFIRM|MSG_ERRQUEUE|MSG_NOSIGNAL|MSG_MORE|MSG_BATCH|MSG_ZEROCOPY|MSG_CMSG_CLOEXEC|0x1b480000}, msg_len=33}, {msg_hdr={msg_name=NULL, msg_namelen=0, msg_iov=[{iov_base="\226\235\1\0\0\1\0\0\0\0\0\0\3www\7example\3com\0\0\34\0"..., iov_len=33}], msg_iovlen=1, msg_controllen=0, msg_flags=MSG_CTRUNC|MSG_FIN|MSG_SYN|MSG_CONFIRM|MSG_ERRQUEUE|MSG_NOSIGNAL|MSG_MORE|MSG_BATCH|MSG_ZEROCOPY|MSG_CMSG_CLOEXEC|0x1b480010}, msg_len=33}], 2, MSG_NOSIGNAL) = 2
recvfrom(5, "\262\224\201\200\0\1\0\1\0\0\0\0\3www\...

Read more...

Dan Streetman (ddstreet) on 2018-10-03
tags: added: sts-sru-done verification-done verification-done-bionic verification-done-xenial
removed: sts-sru-needed verification-needed verification-needed-bionic verification-needed-xenial
tags: removed: sts-sponsor
Robie Basak (racb) wrote :

I see a autopkgtest failure in resource-agents: http://autopkgtest.ubuntu.com/packages/r/resource-agents/bionic/armhf

However this has both passed and failed before with the same error, so appears to be a flaky test rather than a regression caused by this SRU.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package open-iscsi - 2.0.873+git0.3b4b4500-14ubuntu3.6

---------------
open-iscsi (2.0.873+git0.3b4b4500-14ubuntu3.6) xenial; urgency=medium

  * d/net-interface-handler: replace 'domainsearch' with the correct
    configuration option 'search' in net-interface-handler (LP: #1791108)

 -- Victor Tapia <email address hidden> Mon, 17 Sep 2018 16:39:15 +0200

Changed in open-iscsi (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for open-iscsi has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package open-iscsi - 2.0.874-5ubuntu2.3

---------------
open-iscsi (2.0.874-5ubuntu2.3) bionic; urgency=medium

  * d/net-interface-handler: replace 'domainsearch' with the correct
    configuration option 'search' in net-interface-handler (LP: #1791108)

 -- Victor Tapia <email address hidden> Mon, 17 Sep 2018 16:37:22 +0200

Changed in open-iscsi (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers