Unable to deploy xenial on MAAS / resolv.conf not populated

Bug #1553017 reported by Cheryl Jennings on 2016-03-04
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
open-iscsi (Ubuntu)
High
Scott Moser

Bug Description

When trying to deploy a Xenial node on MAAS, the node quickly transitions from "Deploying" to "Failed Deployment".

Connecting to the console shows that cloud init continues to run, and the node will eventually get to a login screen, but I cannot access the machine over the network.

This has been seen on MAAS 1.9.1 and 1.10.

Related bugs:
 * Bug 1050487: resolvconf not updated on iscsi root
 * Bug 1463461: resolvconf not updated by /lib/systemd/system/ifup@.service.d/open-iscsi.conf
 * Bug 1501033: transient error results in /etc/resolv.conf not populated in iscsi root

Cheryl Jennings (cherylj) wrote :

Cloud-init output from roaksoax: http://pastebin.ubuntu.com/15278513/

Scott Moser (smoser) wrote :

I havent tried this time, but there is fairly good re-create for the previous versions of this bug in bug 1463461 and bug 1501033.

description: updated
no longer affects: cloud-init
Scott Moser (smoser) on 2016-03-04
summary: - Unable to deploy xenial on MAAS
+ Unable to deploy xenial on MAAS / resolv.conf not populated
Andres Rodriguez (andreserl) wrote :

Work around in curtin_userdata, add:

22:54 < smoser> early_command:
22:54 < smoser> fixresolv: ['sh', '-c', 'echo nameserver 8.8.8.8 > /etc/resolv.conf']

Andres Rodriguez (andreserl) wrote :

early_command:
     fixresolv: ['sh', '-c', 'echo nameserver 8.8.8.8 > /etc/resolv.conf']

Scott Moser (smoser) wrote :

for more explicit fix what you need is:

$ printf "\n#%s\n%s:\n %s\n" "work around lp 1553017" "early_commands" "fixresolv: ['sh', '-c', 'echo nameserver 8.8.8.8 > /etc/resolv.conf']" | sudo tee -a /etc/maas/preseeds/curtin_userdata

$ tail -n 4 /etc/maas/preseeds/curtin_userdata

#work around lp 1553017
early_commands:
  fixresolv: ['sh', '-c', 'echo nameserver 8.8.8.8 > /etc/resolv.conf']

Scott Moser (smoser) on 2016-03-04
Changed in open-iscsi (Ubuntu):
importance: Undecided → High
Scott Moser (smoser) wrote :

ok. so I've reproduced this using
 http://bazaar.launchpad.net/~smoser/maas/maas-ephemeral-sniff/view/head:/README.txt
basically:
  ./get-maas-eph xenial.d xenial hwe-w
  ./tgt-boot-test xenial.d/root-image.patch xenial.d/hwe-w/boot-kernel xenial.d/hwe-w/boot-initrd

The issue is simply that /lib/open-iscsi/net-interface-handler is installed without execute permissions.

** note, 'hwe-w' above is a bug, which will be fixed very soon in maas images metadata so you'll have to use 'hwe-x'.

Changed in open-iscsi (Ubuntu):
status: New → Confirmed
assignee: nobody → Scott Moser (smoser)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package open-iscsi - 2.0.873+git0.3b4b4500-14ubuntu1

---------------
open-iscsi (2.0.873+git0.3b4b4500-14ubuntu1) xenial; urgency=medium

  * Merge from debian. Remaining changes:
    - debian/tests: Add Ubuntu autopkgtest.
    - debian/iscsi-network-interface.rules, debian/net-interface-handler,
      debian/open-iscsi.install:
      Prevent network interface that contains iscsi root from bouncing
      during boot or going down during shutdown.
      Integrates with resolvconf and initramfs code that writes
      /run/initramfs/open-iscsi.interface
    - debian/open-iscsi.maintscript: clean up the obsolete
      iscsi-network-interface upstart job, file on upgrade.
  * make debian/net-interface-handler executable (LP: #1553017)

 -- Scott Moser <email address hidden> Fri, 04 Mar 2016 13:17:45 -0500

Changed in open-iscsi (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers