open-iscsi init script creates dependency cycle with NetworkManager

Bug #1465196 reported by Dimitri John Ledkov on 2015-06-15
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
open-iscsi (Ubuntu)
High
Unassigned

Bug Description

Jun 15 09:46:54 djledkov-mobl1 systemd[1]: Found dependency on NetworkManager-wait-online.service/start
Jun 15 09:46:54 djledkov-mobl1 systemd[1]: Breaking ordering cycle by deleting job NetworkManager-wait-online.service/start
Jun 15 09:46:54 djledkov-mobl1 systemd[1]: Job NetworkManager-wait-online.service/start deleted to break ordering cycle starting with network-online.target/start
Jun 15 09:46:54 djledkov-mobl1 systemd[1]: Found dependency on NetworkManager.service/start
Jun 15 09:46:54 djledkov-mobl1 systemd[1]: Breaking ordering cycle by deleting job NetworkManager.service/start
Jun 15 09:46:54 djledkov-mobl1 systemd[1]: Job NetworkManager.service/start deleted to break ordering cycle starting with network.target/start
Jun 15 09:46:55 djledkov-mobl1 systemd[1]: Found dependency on NetworkManager-wait-online.service/start
Jun 15 09:46:55 djledkov-mobl1 systemd[1]: Found dependency on NetworkManager-wait-online.service/start
Jun 15 09:46:55 djledkov-mobl1 systemd[1]: Reached target Network.
Jun 15 09:46:55 djledkov-mobl1 systemd[1]: Starting Network.
Jun 15 09:46:55 djledkov-mobl1 systemd[1]: Reached target Network is Online.
Jun 15 09:46:55 djledkov-mobl1 systemd[1]: Starting Network is Online.
Jun 15 09:46:56 djledkov-mobl1 whoopsie[1065]: [09:46:56] Could not get the Network Manager state:
Jun 15 09:46:56 djledkov-mobl1 whoopsie[1065]: [09:46:56] GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files

So, my system boots, but without any internets =(

Martin Pitt (pitti) wrote :

Jun 15 09:46:54 djledkov-mobl1 systemd[1]: Found ordering cycle on network-online.target/start
Jun 15 09:46:54 djledkov-mobl1 systemd[1]: Found dependency on NetworkManager-wait-online.service/start
Jun 15 09:46:54 djledkov-mobl1 systemd[1]: Found dependency on basic.target/start
Jun 15 09:46:54 djledkov-mobl1 systemd[1]: Found dependency on sockets.target/start
Jun 15 09:46:54 djledkov-mobl1 systemd[1]: Found dependency on cups.socket/start
Jun 15 09:46:54 djledkov-mobl1 systemd[1]: Found dependency on sysinit.target/start
Jun 15 09:46:54 djledkov-mobl1 systemd[1]: Found dependency on open-iscsi.service/start
Jun 15 09:46:54 djledkov-mobl1 systemd[1]: Found dependency on network-online.target/start
Jun 15 09:46:54 djledkov-mobl1 systemd[1]: Breaking ordering cycle by deleting job NetworkManager-wait-online.service/start

Same old story -- rcS early boot init script with an overly demanding $remote_fs dependency. That can't work together with NetworkManager. Best solution would be to either move this to $local_fs or provide a proper systemd unit with more fine-grained dependencies.

affects: network-manager (Ubuntu) → open-iscsi (Ubuntu)
Changed in open-iscsi (Ubuntu):
status: New → Triaged
Martin Pitt (pitti) on 2015-06-15
no longer affects: systemd (Ubuntu)
tags: added: systemd-boot
summary: - NetworkManager-wait-online job deleted to break ordering cycle
+ open-iscsi init script creates dependency cycle with NetworkManager
Martin Pitt (pitti) on 2015-06-15
Changed in open-iscsi (Ubuntu):
importance: Undecided → Critical
importance: Critical → Medium
Vincent Ladeuil (vila) wrote :

I ran into that bug again now that I really need open-iscsi ;)

I'm using systemd on vivid.

I want to mount remote disks but I don't want to boot from one.

s/remote_fs/local_fs/ in /etc/init.d/open-iscsi doesn't seem to be enough :-/

Purging open-iscsi (and removing the mount from fstab) was the only escape path.

I'd try to reproduce on a test system but any advice on what I can try next warmly welcome ;)

Vincent Ladeuil (vila) wrote :

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=%23775778 seems to be related.

How far is ubuntu from debian on this precise topic ?

Vincent Ladeuil (vila) wrote :

For the record, on a wily system, there is still a dependency loop involving open-iscsi but system can still boot successfully.

Roughly, I can do:

# apt-get install open-iscsi
# iscsi_discovery <iscsi server IP>

and see the expected volumes

But rebooting from there causes the dependency loop and open-iscsi is not started on next reboot.

I'll try to reproduce in a vm to provide better info.

Julian Taylor (jtaylor) wrote :

still the case in xenial, bumping to high as ending up with no network can be highly problematic.

Changed in open-iscsi (Ubuntu):
importance: Medium → High

There was a merge and it would be great if one could verify if the issue still exists with >2.0.873+git0.3b4b4500-13ubuntu1.
It seems that upload missed jtaylors last test by just a few hours.
Currently we have 2.0.873+git0.3b4b4500-14ubuntu1 / 2.0.873+git0.3b4b4500-14ubuntu2 available, but those only differer in autotests.

Please if still an issue share what version you had tested and if possible a few simplified steps how to test it to give us a chance to get this fixed before or early in the 16.04 cycle.

Julian Taylor (jtaylor) wrote :

I have rebooted the machine a couple times since and it has not occurred again. Probably the issue has been fixed.
Please reopen if you are still affected.

Changed in open-iscsi (Ubuntu):
status: Triaged → Fix Released
Mathias Lehnfeld (esqilin) wrote :

Occurs consistently on my Xubuntu 16.04 installation. It did infrequently until a few days ago (I don't know exactly).

[ 14.850019] systemd[1]: network-online.target: Found ordering cycle on network-online.target/start
[ 14.850024] systemd[1]: network-online.target: Found dependency on NetworkManager-wait-online.service/start
[ 14.850027] systemd[1]: network-online.target: Found dependency on basic.target/start
[ 14.850029] systemd[1]: network-online.target: Found dependency on sockets.target/start
[ 14.850030] systemd[1]: network-online.target: Found dependency on acpid.socket/start
[ 14.850032] systemd[1]: network-online.target: Found dependency on sysinit.target/start
[ 14.850033] systemd[1]: network-online.target: Found dependency on open-iscsi.service/start
[ 14.850035] systemd[1]: network-online.target: Found dependency on network-online.target/start
[ 14.850037] systemd[1]: network-online.target: Breaking ordering cycle by deleting job NetworkManager-wait-online.service/start
[ 14.850039] systemd[1]: NetworkManager-wait-online.service: Job NetworkManager-wait-online.service/start deleted to break ordering cycle starting with network-online.target/start
[ 14.850092] systemd[1]: network.target: Found ordering cycle on network.target/start
[ 14.850094] systemd[1]: network.target: Found dependency on NetworkManager.service/start
[ 14.850096] systemd[1]: network.target: Found dependency on basic.target/start
[ 14.850098] systemd[1]: network.target: Found dependency on sockets.target/start
[ 14.850099] systemd[1]: network.target: Found dependency on acpid.socket/start
[ 14.850101] systemd[1]: network.target: Found dependency on sysinit.target/start
[ 14.850102] systemd[1]: network.target: Found dependency on open-iscsi.service/start
[ 14.850104] systemd[1]: network.target: Found dependency on network-online.target/start
[ 14.850105] systemd[1]: network.target: Found dependency on network.target/start
[ 14.850107] systemd[1]: network.target: Breaking ordering cycle by deleting job NetworkManager.service/start
[ 14.850109] systemd[1]: NetworkManager.service: Job NetworkManager.service/start deleted to break ordering cycle starting with network.target/start

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers